Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Firefox cannot find my microphone

  • 9 回覆
  • 1 有這個問題
  • 52 次檢視
  • 最近回覆由 piotrkot

more options

I have Firefox 68.9.0ers (64bit) on antiXLinux-19. My microphone seems to work. It's not muted. I can record my voice with cheese or recordmydesktop.

However, when I go to https://meet.jit.si/ or https://www.onlinemictest.com/ I get the error that the microphone cannot be found. That means I do not even get the prompt to allow to use my microphone. In other words, MediaDevice.getUserMedia() throws NotFoundError.

With https://meet.jit.si/ I do get prompt for video, and video is working just fine.

I have the same problem with Firefox 76.0.1 (64bit).

All Replies (9)

more options

Using Mozilla Firefox: Click on the site identity icon (the lock symbol) in the address bar. Choose Allow on each menu next to Use the Camera and Use the Microphone: Click anywhere on the web page to close the menu, then click the Retry button.

Helpful?

more options

Hii

1 Click the Padlock icon that displays in the address bar on the left.

  • Any relevant permission statuses for the 

current site are displayed in the Permissions section of the Site Information drop-down panel.

 2  Click the X next to Allowed , Allowed

Temporarily, Blocked or Blocked Temporarily to clear the status so that Firefox will ask again for

permission when you next visit the site.


Hope it solve your problem...

由 Aashish Kumar 於 修改

Helpful?

more options

Permissions to use the microphone was explicitly set to Allow. This is visible in the Site Information. Reloading the page and reinstalling the browser does not help.

Helpful?

more options

Hello,

Have you tried doing a settings refresh for Firefox?

  • To do this, click the menu button at the top right corner of the Firefox window.
  • Click the “Help” option near the bottom of the menu.
  • Click the “Troubleshooting Information” option in the Help menu.
  • Click the “Refresh Firefox” button at the top right corner of the Troubleshooting Information page.
  • You’ll be warned that this will remove your browser add-ons, reset your customizations, and revert other browser data to the default settings. Click “Refresh Firefox” to confirm you want to make these changes.

https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

That URL should show an article on how to refresh/reset Firefox. That may resolve the issue.

Helpful?

more options

Thanks for the info about the Firefox refresh. Didn't know about it. Unfortunately, it didn't help. I was also looking into crash reports - none reported; and various FF settings but couldn't find anything useful.

Helpful?

more options

Hi, there is no more about:permissions page.

The usual behavior is for pages to ask for permission and for Firefox to drop down a panel from the left end of the address bar to get your confirmation. If you don't see that panel, you can try using the Permissions panel of the Page Info dialog. Here's how:

While you are on the page that you want to have permission, call up Page Info using any of these:

   right-click a blank area of the page and choose View Page Info > Permissions
   (menu bar) Tools menu > Page Info > Permissions
   click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions 

Scroll down to "Use the Microphone" and uncheck the "Use default" box; a bullet should appear in front of "Always Ask". Click the permission you prefer, presumably "Allow".

Changes you make in this dialog are saved as you go, so after making the change, you can close the dialog.

Does that work?

Note that some sites may use the Flash plugin for audio. The plugin notification icon would appear at the left end of the address bar and looks like a small gray Lego block. If it you see it there, click it to check whether the page has permission to use Flash.

Helpful?

more options

Hi again.

This doesn't work. Permissions to use microphone are set to Allow for all the pages listed above. And the pages do not use Flash either.

I used to communicate on jitsi, googleMeet, etc. without an issue with Firefox but on another operating system (Xubuntu). With AntiX I have the mentioned problem. It seems to be in the guts of the Firefox and I'd like to nail it down since, as I said before, the microphone used for operating system applications (like Cheese, RecordMyDesktop) does work.

Helpful?

more options

hello piotrkot,

follow the step and visit the given link easily to resolved the problem.

  1. Click the menu button Menu and select Options.
  2. Click Privacy & Security from the left menu.
  3. Scroll down to the Permissions section.
  4. Click the Settings… button for the Camera option.
  5. Enter the website URL in the Search field for the site that you want to access your camera.
  6. Press the Enter key.
  7. The website displays in the list below. You can remove it at any time by selecting it from the list and clicking the Remove Website.
  8. Select the Block new requests asking to access your camera checkbox if you do not want to give any other sites access to your camera.
  9. Click the Save Changes button.

for better help visit the link:

[https://support.mozilla.org/en-US/kb/how-manage-your-camera-and-microphon...]

I hope resolved your the problem then reply back to me.

Thank you asked question in Mozilla Support.

Regards,

Arman

Helpful?

more options

Hello Arman Khan.

As I already explained earlier, the problem firstly is not with the camera but with the microphone. And secondly it's not about managing permissions but about not finding the microphone in the first place. Furthermore it seems to be related to the operating system.

I wonder how Firefox finds audio devices on the machine. Some other software I can monitor/debug for audio devices used/discovered. Can I do the same for Firefox? If so, how can I do it?

Helpful?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題