Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Favicons appear correctly in bookmarks, but not in URL window

more options

Even though bookmarked sites appear with their favicons, no favicon is displayed for any site in Firefox and the other browsers I use. Even new bookmarks I continue adding continue to display the corresponding favicon, but none next to the website address. .

附加的畫面擷圖

All Replies (11)

more options

Hello thalaharate,

Follow the instructions :

There's no "cache" for Favicons. They are saved directly in the places.sqlite file, in your Profile folder, with your bookmarks and browser history. There are a few hidden prefs that deal with Favicons, but those prefs are for the display or not of Favicons in the UI - they shouldn't affect the saving of Favicons in the bookmarks file. It is possible that your places.sqlite file is partially corrupt and is causing that problem, but the "fix" involves deleting that file with Firefox closed, so that when you start Firefox a new places.sqlite file will be created. The downside is that all your browsing history will be gone, and all your saved Favicons will also be gone. The bookmark backup file that is used to restore your bookmarks after deleting that file doesn't backup the Favicons.

From what I have seen with the bookmarks I have saved over the years, like maybe 50% of the websites out there even have Favicons and some websites don't follow the established standards for Favicons. The Favicon may appear in the URL bar and on a Tab, but Firefox won't save it because the Favicon image is the wrong format or it's hidden in a remote file and Firefox can't save it when the bookmark is used for the first time.

Also, if you are in the Private Browsing mode, Firefox won't save the Favicon. http://support.mozilla.com/en-US/kb/Private+Browsing


I hope resolve your problem then reply me back.

Thank you

Helpful?

more options

thalaharate said

Even new bookmarks I continue adding continue to display the corresponding favicon, but none next to the website address.

Hi thalaharate, when you load a page, the site icon appears on the page's tab (on the tabs bar) instead of in the address bar. I think most browsers work that way in recent years. Some people have said that sites were using a lock icon as their site icon to fool users into thinking they were secure. Maybe it was that or something else which led to the change.

Helpful?

more options

hii you I'll try clearing that particular extra cache and see what happens. UPDATE - SOLVED: After deleting the favicon cache using the "SQLite Manager" Firefox add-on all works as it should. So the secret was the EXTRA (sqlite) CACHE FOR FAVICONS in Firefox, WHICH IS NOT CLEARED BY THE REGULAR "Clear Cache" command. I hope resolve your problem.

Helpful?

more options

Okay, this is the bizarre thing. In Bookmarks, the favicon shows. When I open it in a tab, it shows. But in the URL window it does not show. It USED TO display before. That is what puzzles me. Case in point, my site:

I can see it in Bookmarks as below:

image 1

Also, as you can see, the tab also displays it:

image 2

But the URL itself doesn't show it:

image 3

So, something is missing here.

Helpful?

more options

I deleted the places.sqlite file, to no avail. In fact, I replaced the entire profile but no change. This is happening with IE, and Vivaldi browsers, as well. But, in the third image, you can see that favicons for various sites appearing in the bookmarks.

由 Fire Marshal Bil 於 修改

Helpful?

more options

Fire Marshal Bil said

Okay, this is the bizarre thing. In Bookmarks, the favicon shows. When I open it in a tab, it shows. But in the URL window it does not show. It USED TO display before.

The site icon was removed from the address bar in Firefox 14 in mid-2012. (Ancient historical document: https://blog.mozilla.org/ux/2012/06/site-identity-ui-updates/.)

If you have seen the icon there between Firefox 14 and Firefox 56, perhaps an add-on was restoring it. However, in Firefox 57+, that isn't the kind of change an add-on could make.

Helpful?

more options

That is ridiculous! Why would they tinker with such things? I am locked into ver 68.0.1 and will never move forward because none of the features I love work in the later versions. I am slowly drifting away from Firefox after having been with it since its inception, and Navigator before that.

However, having said that, none of the other browsers I have tried display favicons, either. Go figure. :-)

Helpful?

more options

Fire Marshal Bil said

Okay, this is the bizarre thing. In Bookmarks, the favicon shows. When I open it in a tab, it shows. But in the URL window it does not show. It USED TO display before. That is what puzzles me. Case in point, my site: ....

Quite awhile ago the Favicon was removed from the the Location Bar window (to the left of HTTPS: ) , due to what jscher2000 mentioned; and the way that Firefox now works is per your 3 images.

And that is not really "new", its been like that for a few years now although I don't remember which previous version of Firefox where the "change" was made.

Helpful?

more options

Oh, well. I noticed it only now after many years of not looking for it. :-)

Helpful?

more options

In current Firefox releases there are two icons always present in the location bar if you have a web page opened in a tab.
The first is the Tracking Protection shield icon that is always present and gets a blueish highlight when active and the second icon is the padlock icon.
The Control Center 'i' icon has been replaced by the padlock icon with a possible permission icon ("You have granted this website additional permissions") next to it when permissions have been changed from their default value.

Helpful?

more options

Yes, as I see. I wish they had retained the favicon, though.

Helpful?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題