搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

links within pdf in firefox viewer don't work

  • 3 回覆
  • 1 有這個問題
  • 18 次檢視
  • 最近回覆由 ARMAN KHAN

more options

I have a web page with a link to a PDF on it. When I click on this link, the PDF opens in a new tab using the Adobe viewer, and displays fine. However, links within the PDF itself are ignored. When I view the same web page in Chrome or IE, the PDF also opens in a viewer, but under these browsers, the links within the PDF itself work as well. Is there any setting or adjustment I can make to Firefox or its PDF viewer to make the links within the PDF work? Thanks for any help. WJH

所有回覆 (3)

more options

Hi, please try the following:

   Click the menu button New Fx Menu and choose Options.
   Select the Applications panel on the left.
   Check "Preview in Firefox" is set for "Portable Document Format (PDF)" --     if not, change it to this. 

View PDF files in Firefox or choose another viewer See for a screenshot of what this page looks like.

If it is already set to that and it still won't load with the built-in viewer, please let us know.

有幫助嗎?

more options

Hi Anamika - Thanks for replying, but I may not have made the problem clear. The PDF file displays OK as a preview within Firefox. However, the PDF itself contains links, and it is these links that don't work. The PDF links work OK (with suitable security warnings) when I view the PDF in the built-in viewers in Chrome or IE11 (although not Edge).

I've just used the Options page to change the way Firefox handles PDFs from "Open in Firefox" to "Use Windows default application". Now when I click on the link to the PDF in the web page, the PDF opens in Adobe Reader externally to Firefox, and the links within the PDF work OK. So there is a work-around. However, it would be nice if the default PDF viewer in Firefox enabled link functionality within the PDF itself. So I guess my question is whether I'm missing some option setting that would do this? WJH

有幫助嗎?

more options

Hey,

Try the following:

  • Go to setting (3 bars) > options > applications.
  • Under applications panel.
  • Find Portable Document Format (PDF) in the list and click on it to select it.
  • Click on the drop-down arrow in the Action column for the above entry and select Use PDF reader name (in Firefox) or preview in firefox.

If PDF files are still downloaded instead of displayed, try these solutions Reset download actions

* Open your profile folder:

Click the menu button click help Help and select Troubleshooting Information. The Troubleshooting Information tab will open.

Under the Application Basics section, click on Show Folder. A window with your profile files will open.

Click the menu button New Fx Menu and then click Exit Close 29

Delete the mimetypes.rdf file.

Then open firefox again and see.

I hope it helps.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題