搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

javascript void 0 error

  • 8 回覆
  • 2 有這個問題
  • 104 次檢視
  • 最近回覆由 cor-el

more options

Hi all,

I have an error where i try to go to website this https://www.telstra.com.au/contact-us/plans-products/fixed-services#lp:2way

when i click on chat now button, it does nothing. I have installed the latest firefox ver 76, whitelist this webstie, untick pop up block, install shockwave flash 32

even if i go directly to livechat link which that button suppose to go this: https://www.telstra.com.au/chatnow/landing?pageId=https%3a%2f%2flivechat.telstra.com%2fTCOM%3aCrowdsupport%3aConsumer

it still doesn't help because it simply show javascript void 0

anyone can help? thank you

附加的畫面擷圖

被選擇的解決方法

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a blueish highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check in the Web Console what content is blocked.


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
從原來的回覆中察看解決方案 👍 0

所有回覆 (8)

more options

選擇的解決方法

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a blueish highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check in the Web Console what content is blocked.


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

有幫助嗎?

more options

ahupito1 said

it still doesn't help because it simply show javascript void 0

I just wanted to mention that when a site attaches a script to a button, it often uses a fake address for the link like:

  • #
  • javascript:void(0)

This is because the script is going to take over the function of the link.

If the script fails to run properly for some reason, such as it didn't load or isn't compatible with Firefox or is blocked, then the button doesn't do anything useful.

cor-el's reply gives numerous things to check along those lines.

有幫助嗎?

more options

I manage to get the livechat working with safe mode. is this proof that addon is the cause?

有幫助嗎?

more options

Hi ahupito1, that is the usual reason. Do you have any anti-tracking or privacy add-ons that might block cross-site chat tools? They may have a toolbar button to make a site exception as you browse.

有幫助嗎?

more options

@jscher2000 I have adblock plus , disable html5 autoplay, youtube control panel, greasemonkey -> this one only make backspace means delete a character NOT go back one page.

sorry for delay on replay, i don't think i can gave up any of these addon. i still could not make it work without safe mode. not sure why even i disable these addone only on telstra website. it still not work. i have a high reason to believe the cause is disable html5 autoplay.

i just dislike a video is automatic play, not starts on pause mode.

有幫助嗎?

more options

cor-el might have other suggestions.

Regarding Backspace, there is a built-in preference for that: https://support.mozilla.org/questions/1261234

有幫助嗎?

more options

@jscher2000 ah thanks. i can remove greasemonkey with that about:config

有幫助嗎?

more options

If it works in Safe Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via one of these:

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題