搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Using Outlook.com on FF, in an email, numbering items is incorrect, but it looks fine on desktop Outlook or with Chrome or Edge browsers

more options

When using FF and on Outlook.com, if I start numbering a list, FF shows it incorrectly when I have main level and sublevels. Going back to the main level, the next number is skipped, so is then 1 off.

If I look at the same draft email in Outlook on Desktop, or in Edge or Chrome, it does not have the issue. It did not skip a number, but stayed consecutive. FF 1

    a
    b

3 Should be: 1

    a
    b

2 See attachments.

When using FF and on Outlook.com, if I start numbering a list, FF shows it incorrectly when I have main level and sublevels. Going back to the main level, the next number is skipped, so is then 1 off. If I look at the same draft email in Outlook on Desktop, or in Edge or Chrome, it does not have the issue. It did not skip a number, but stayed consecutive. FF 1 a b 3 Should be: 1 a b 2 See attachments.
附加的畫面擷圖

所有回覆 (4)

more options

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

I tried all those points and the issue never left. I also tried Gmail on FF - but it worked like you'd expect it to and did not skip numbers. Do you have an outlook account or hotmail where you could try it?

more options

I use the Thunderbird mail browser. But the times I used Firefox I had no problem.

https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history

Remove History For One Site

Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any settings.

more options

Okay, this is a little weird, stick with me.

When you take the preexisting item 2 in your outer list and indent it to create a sub-list, Outlook creates it as a separate element in the outer list, instead of creating it as part of item 1. So then the next item in the outer list is 3, etc. Here's a screenshot showing what the HTML looks like, and where the sub-list really belongs.

One workaround is to use line breaks (instead of paragraph breaks) for the items you want in your sub-list, and then create the sub-list after building your outer list. In this composite screenshot, I've used Shift+Enter to insert line breaks in item 1. Shift+Enter doesn't trigger creating a new list item. Then I've selected those items and instead of using indent, I've clicked the numbered list button. This then creates a properly nested sub-list, as shown by viewing the source HTML.

I don't know whether there is an easier fix if you can't get used to this way of working. Probably a little script could move the indented list where it belongs to fix the outer list numbering, but... yeah... these mail sites are complicated so I haven't looked into that.