搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Email Link freezes Firefox for twenty seconds

more options

Win10 - I was originally using a 3rd party addon, and experiencing this problem. I tried a few of them and they all did the same thing: the screen froze for about 20 seconds, then switched over to a new email in my Outlook (desktop) program, which had already been open (i.e. FF didn't have to wait for the program to open). I tried this from Chrome, and it worked instantly (so, the underlying functions work just fine). I got rid of the addon (I had tried a few of them) and just used the built-in Alf-F "Email link" function; it did the same thing. Right now my only quick method is to use Chrome, but I'd prefer Firefox instead. I appreciate any help.

Win10 - I was originally using a 3rd party addon, and experiencing this problem. I tried a few of them and they all did the same thing: the screen froze for about 20 seconds, then switched over to a new email in my Outlook (desktop) program, which had already been open (i.e. FF didn't have to wait for the program to open). I tried this from Chrome, and it worked instantly (so, the underlying functions work just fine). I got rid of the addon (I had tried a few of them) and just used the built-in Alf-F "Email link" function; it did the same thing. Right now my only quick method is to use Chrome, but I'd prefer Firefox instead. I appreciate any help.

所有回覆 (2)

more options

Is this just with e-mails?

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

Hi rich_vanasse, also, could you temporarily set your mailto handling back to "Always Ask".

I'm curious whether the problem occurs in the lead up to Firefox deciding what program to use (time to launch the dialog), or after it is told what program to use. This article describes that setting, although I suspect you have updated it before: Change the program used to open email links.

(As a point of reference, mine takes a second or two to show the list of mail options, and about 3 seconds to launch a new message in Outlook.)