搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot find spurious login IDs at about:logins

  • 2 回覆
  • 1 有這個問題
  • 21 次檢視
  • 最近回覆由 TLMurray

more options

Say that I have a login at a site, and I got there previously with another browser. When I go to the same site with Firefox for the first time, that site's ID field might drop down to show a number of entries, and many times (but not always) there is no "View Saved Logins" below the list.

Here is an example of a site than many readers of this might not go to: DevonTechnologies.com and this might be the same for you. Devon's login ID wants an email address, and the field dropped down to show 29. A bunch of them were emails I would swear on my kid's heads I have never used anywhere, not even in another browser, and one was a misspelling of my own email address. Only a small few were addresses that were valid elsewhere. But here is the rub: A search of about:logins for the weird addresses and my misspelling came up empty.

Further, I can go to another site I have never visited with Firefox, and I might not get a drop-down at all or I might get just one of my three typical email addresses.

For those sites where I have used Firefox for the first time, the questions are

  • Where did Firefox get those spurious addresses?
  • Where did Firefox get a good address, and why did it leave out the "usual" others?
  • Why are the odd logins not found at about:logins?

I have Firefox 76.0.1 under Catalina 10.15.4, and I sync with Lockwise.

Thanks.

被選擇的解決方法

Hi TLMurray, as a test to determine the source of the items in the drop-down, could you temporarily turn off the form history feature. Here's how:

Open the Preferences page using one of these methods:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

Change to the Privacy and Security panel by clicking that heading in the left column.

Scroll down to the History section and change the selector to:

Firefox will: Use custom settings for history

That should revealed detailed settings.

Uncheck the box for

[_] Remember search and form history

That is for not just remembering, but also suggesting values you previously entered into form fields.

If you go back to the login page, are the suggestions different?

從原來的回覆中察看解決方案 👍 1

所有回覆 (2)

more options

選擇的解決方法

Hi TLMurray, as a test to determine the source of the items in the drop-down, could you temporarily turn off the form history feature. Here's how:

Open the Preferences page using one of these methods:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

Change to the Privacy and Security panel by clicking that heading in the left column.

Scroll down to the History section and change the selector to:

Firefox will: Use custom settings for history

That should revealed detailed settings.

Uncheck the box for

[_] Remember search and form history

That is for not just remembering, but also suggesting values you previously entered into form fields.

If you go back to the login page, are the suggestions different?

有幫助嗎?

more options

I have three choices: Remember, Never Remember, and Custom. Never Remember didn't work, so I did a Clear. Clearing Form & Search History (for all time) didn't work, so I cleared everything except cookies, and it at least that worked. Thanks.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題