搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I press the letter "T" on the keyboard it refreshes the page.

more options

Installed Firefox 75 and then 76 on Windows 7 embedded (32 bit) on a thin-client. No errors. When I press the letter "t" on the keyboard it refreshes the page. I have tried this on several input fields on this specific webpage and it has the same outcome. This only happens if I use a lowercase t -- shift-t and T (using caps-lock) does not refresh.

This occurs on a specific page on my internal network. I reproduced this on 3 computers running the same versions of everything. Reinstalled windows and Firefox and same problem.

Another Windows 7 computer running Firefox 56 does not have this symptom so my next step was installing Firefox 56 which worked. I installed each version incrementally until I found where this started - version 64 works fine, version 65 refreshes when I press "t".

I am so confused.

所有回覆 (5)

more options

How strange. Reload would usually be Ctrl+r or F5, or to bypass the cache, Ctrl+Shift+r or Ctrl+F5.

If you are patient person with time for further testing, there is a tool called mozregression that lets you identify the particular change between Firefox 64 and 65 that is related to this behavior. You tell it to start a new bisection, say release 64 was good and release 65 was bad, then it downloads intermediate builds, you test, and tell it whether that one is good or bad. It demands a lot of bandwidth, so it's helpful to have a distraction on the side. More info on this page: https://mozilla.github.io/mozregression/

But since you know the change was in Firefox 65, there was a change in how pages can detect keystrokes: developers need to listen for keydown or keyup instead of keypress for some keys. I don't think that should affect the letter t, so this doesn't seem like an obvious answer, but I'll link to more info on it anyway: https://www.fxsitecompat.dev/en-CA/docs/2018/non-printable-keys-no-longer-fire-keypress-event/. To test whether that is the issue, try this:

(0) Open the page that has the problem, so you can easily reference its address

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste hack and pause while the list is filtered

(3) Double-click the dom.keyboardevent.keypress.hack.dispatch_non_printable_keys.addl preference to display an editing field -- usually it's empty. Type or paste the hostname of the site where the problem occurs. For example, in this URL

https://www.example.com/index.html

the part you want to put into the preference is

www.example.com

Then press Enter or click the blue check mark button to save the change. Any difference?

More info on about:config: Configuration Editor for Firefox.

有幫助嗎?

more options

If it's a form, is it possible that t is submitting the form back to itself? Unless the developer coded around it, this generally would lead to an accumulation of entries on the Back button, which doesn't happen with a simple reload.

有幫助嗎?

more options

Thank you for your answers. I did what you instructed in the about:config on Firefox 65 and it did not change the behavior. it is a form but the back button stays greyed out after each refresh. It acts as if I am pressing f5 each time I press t, exact same behavior. One thing that is quite odd is that I don't have to be in any field for it to refresh. I can press t anywhere on the page and it will act like I pressed F5. I wonder if this one is related: https://support.mozilla.org/en-US/questions/1281566

由 Renen 於 修改

有幫助嗎?

more options

I have the same problem; in my case it is the password field for a particular banking site. I am using v78.0.1 (64-bit). I am not having this problem with Internet Explorer.

由 rahulagarwala 於 修改

有幫助嗎?

more options

rahulagarwala said

I have the same problem; in my case it is the password field for a particular banking site. I am using v78.0.1 (64-bit). I am not having this problem with Internet Explorer.

Please start your own questions thread, rather than bury it back here. That might get you the attention that you deserve for your problem, which while it may sound similar to you it is different enough to warrant your own support thread, IMO.

Start here:
https://support.mozilla.org/en-US/products/firefox

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題