搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

user.js is not getting copied to profiles even though it is available under browser/defaults/profile

  • 3 回覆
  • 1 有這個問題
  • 1820 次檢視
  • 最近回覆由 cor-el

more options

Hi,

user.js is not getting copied to profile folder automatically. I have a file user.js in installed directory/browser/defaults/profile/user.js in version Mozilla Firefox 52.0.2

The same operation used to happen in Mozilla Firefox 45.5.1 without any problem

被選擇的解決方法

I'm not sure if this way of initializing a profile is still supported. Maybe try to place the file in "browser/defaults/preferences" instead. Otherwise you need to use a autoconfig.cfg file to copy the file(s) yourself to the profile folder.

It is probably better to use the autoconfig.cfg or policies.json file to initialize prefs.

從原來的回覆中察看解決方案 👍 1

所有回覆 (3)

more options

directory/browser/defaults/profile/ strikes me as being in the wrong location, like in the Program Files = Firefox program /defaults/ folder rather than in the C:\Users\user\AppData\Roaming\Mozilla\Firefox\Profiles\profile-name folder.

The optional user.js file belongs in the Profile folder which is located under Roaming.

You can use Help > Troubleshooting Information within Firefox to get to the correct folder for the Profile being used -- at Profile Folder and then use the Open Folder button in the UI list in the left column.

more options

HI,

Thanks for the reply.

Here, am launching firefox not on Windows but on linux based machine. So normally in firefox..whatever files we keep under installed_directory/browser/defaults/profile directory will copy it to the newly created profile directory for example /.user_homedirectory/.mozilla/firefox/randomname_directory/ . But it is not happening now..If i copy the user.js manually to /.user_homedirectory/.mozilla/firefox/randomname_directory/ everything is working fine. But i want to automate that for every user. So where I need to keep user.js in order to automatically copy it newly created profile or opened sessions

TIA

more options

選擇的解決方法

I'm not sure if this way of initializing a profile is still supported. Maybe try to place the file in "browser/defaults/preferences" instead. Otherwise you need to use a autoconfig.cfg file to copy the file(s) yourself to the profile folder.

It is probably better to use the autoconfig.cfg or policies.json file to initialize prefs.