搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Some websites don't display letters such as "y" on FF. Why is this?

  • 3 回覆
  • 2 有這個問題
  • 7 次檢視
  • 最近回覆由 Joseph

more options

Some websites don't display certain letters. Currently, I'm experiencing this problem on thekitchn.com, where the letter "y" isn't displaying. Here's an example sentence, "These steps might seem prett obvious, and for the most part the are, but there’s critical strateg within each of them." I've tried this particular website on Chrome, and have the same problem. However, on Safari all the letters are displayed.

Not all websites behave this way on FF. Out of the seven tabs I have open, only one isn't displaying correctly.

The extensions I have running are: - AdBlock Plus - Facebook Container - Epub Reader - Firefox Colour - Firefox Multi-Account Containers - Privacy Badger - Share Button for Facebook - Side View - SuperStop - To Google Translate - Tree Style Tab

Here are the steps I've taken to test and fix the problem: - To test if the problem is with the website itself, I copied and pasted the words elsewhere, and missing the letter is displayed. - I restarted FF in Safe Mode, but the problem persisted. - I deleted FF from applications, downloaded v.75.0 and installed that. No go.

I'm on a Mac.

Not sure what to do now. Thanks in advance for your help.

被選擇的解決方法

Thank you, cor-el.

The second question (/questions/1278708) helped with finding a solution.

First, I tried tried changing the fonts to "True Type" but there is no option for that in the menu.

Instead, I unchecked "Allow pages to choose their own fonts, instead of your selections above" and refreshed the page. Success!

Here were the steps: --> Open FF preferences --> Scroll down to "Language and Appearance" --> Click on "Advanced" --> Uncheck "Allow pages to choose their own fonts, instead of your selections above." --> Click "OK" --> Refresh webpage

Voila!

從原來的回覆中察看解決方案 👍 0

所有回覆 (3)

more options

It is possible that Firefox isn't able to access the requested font and falls back to a 'last resort' font that shows all glyphs as a '?' or an 'A'.

This can happen if you use third-party font managers that store their fonts is a not standard location. Firefox on Mac uses a rather restricted sandbox and blocks access to most of the file system and thus blocks access to the font file if the font isn't in a standard system location.


Related threads:

有幫助嗎?

more options

選擇的解決方法

Thank you, cor-el.

The second question (/questions/1278708) helped with finding a solution.

First, I tried tried changing the fonts to "True Type" but there is no option for that in the menu.

Instead, I unchecked "Allow pages to choose their own fonts, instead of your selections above" and refreshed the page. Success!

Here were the steps: --> Open FF preferences --> Scroll down to "Language and Appearance" --> Click on "Advanced" --> Uncheck "Allow pages to choose their own fonts, instead of your selections above." --> Click "OK" --> Refresh webpage

Voila!

有幫助嗎?

more options

I have this problem as well, and "x" is replaced with ". I tried this fix, but no change

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題