搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

how do i turn off the popup urlbar in the latest nightly build? (77.0a1 09/04/2020)

  • 13 回覆
  • 3 有這個問題
  • 138 次檢視
  • 最近回覆由 dodav22008

more options

Again asking for help to turn off the popup urlbar "pic related",I have asked the same question back then in Nightly version 75.0a1 when this (irritating) feature was introduced and I tried the same steps but setting "browser.urlbar.update1" to "false" doesn't work.

is this permanent? if so why? if I wanted a bulky UI I would just use the Touch Mode or the Normal Mode, at least give us the option to turn it off/on, my problem with this is 1- it ruins the Perfect aesthetic of the UI and make FF looks like Quasimodo (just saying FF has the best UI out there) 2- it overlaps with other elements of the Compact UI like the bookmarks toolbar making it irritating as a "Jack Russell terrier"

and do me please a favor Don't ruin the compact UI

附加的畫面擷圖

所有回覆 (13)

more options

This is the new design for the Firefox address bar. It's a permanent change. The browser.urlbar.update1 preference is only there for testing purposes and will eventually be removed from Firefox.

If you want to permanently remove the resizing of the address bar, you will need to resort to userChrome modifications.

I've created some userChrome.css code to address the annoying growing and shrinking of the address bar, if that's a feature that you don't like. You can download the code from here.

If you've never used userChrome styling modifications before, refer to How to Create a userChrome.css File for more information.

Hope this helps.

NOTE: The code in the link must be located at the top of the file to work properly if your userChrome.css file already has content in it.
more options

please give us the option to turn the resizing off, it ruins the experience.

more options

It looks quite big (actually much to big) in the current Nightly build.

This code in userChrome.css works for me in the current Firefox Nightly build. Some of the code is in the HTML namespace, so you either need to place it above the @namespace line or use a @import url("urlbar.css"); rule to import a file with this code.

#urlbar[breakout], #urlbar[breakout][breakout-extend] { --urlbar-height: 28px !important; --urlbar-toolbar-height: 30px !important; width: 100% !important; top: calc((var(--urlbar-toolbar-height) - var(--urlbar-height)) / 2) !important; left: 0 !important; } #urlbar[breakout][breakout-extend] > #urlbar-input-container, #urlbar-input-container { height: var(--urlbar-height) !important; width: 100% !important; padding-block: unset !important; padding-inline: unset !important; transition: none !important; } #urlbar[breakout][breakout-extend] > #urlbar-background { animation: none !important; }


https://dxr.mozilla.org/mozilla-central/source/browser/themes/shared/urlbar-searchbar.inc.css

See also:

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true

See:

由 cor-el 於 修改

more options

this is the best i could do: 1-go to about:config page and set "toolkit.legacyUserProfileCustomizations.stylesheets" to true 2-Go to "about:support" find "profile folder" click on "open folder" 3-create new folder with the name "chrome" and open it 4-create a note pad file (text document) named"userChrome.css" (changing the file extension and the upper case C are important) 5- copy below in "userChrome.css" (i did tweak the script from Wesley Branton) 6- close and reopen FF / Nightly


/* REMOVE MEGABAR START

* VERSION 1.0.3
* RELEASE NOTES: http://userchrome.wesleybranton.com/notes/megabar */

@-moz-document url(chrome://browser/content/browser.xhtml) {

   #urlbar[breakout][breakout-extend] > #urlbar-input-container,
   #urlbar-input-container {
       height: 25px !important;
       padding-block: 0px !important;
       padding-inline: 0px !important;
       transition: none !important;
       border-radius: var(--toolbarbutton-border-radius) !important;
   }
   #urlbar[breakout][breakout-extend] {
       top: calc((var(--urlbar-toolbar-height) - 26px) / 2) !important;
       left: 0 !important;
       width: 100% !important;
   }
   
   #urlbar[breakout][breakout-extend] > #urlbar-background {
       box-shadow: 0 1px 4px rgba(0,0,0,.05) !important;
   }
   #urlbar[breakout][breakout-extend] > #urlbar-input-container {
       border: 1px solid var(--toolbar-field-focus-border-color) !important;
   }
   #urlbar[breakout][breakout-extend][open] > #urlbar-input-container {
       border-bottom: 1px solid transparent !important;
       border-radius: var(--toolbarbutton-border-radius) var(--toolbarbutton-border-radius) 0 0 !important;
   }

} /* REMOVE MEGABAR END */


Speacial thanks to Wesley Branton and cor-el

more options

I really don't like it as it steals another 2pixels (YES, 10%) of the already tiny bookmark buttons. Feels like I need to click something from under a ledge.

Please give us an option to disable it.

more options

Please give us an option to disable it.

more options

some fixes


/* REMOVE MEGABAR START

@-moz-document url(chrome://browser/content/browser.xhtml) {

  #urlbar[breakout][breakout-extend] > #urlbar-input-container,
  #urlbar-input-container {
      height: 25px !important;
      padding-block: 0px !important;
      padding-inline: 0px !important;
      transition: none !important;
      border-radius: var(--toolbarbutton-border-radius) !important;
  }
  #urlbar[breakout][breakout-extend] {
      top: calc((var(--urlbar-toolbar-height) - 26px) / 2) !important;
      left: 0 !important;
      width: 100% !important;
  }
  
  #urlbar[breakout][breakout-extend] > #urlbar-background {
      box-shadow: 0 1px 4px rgba(0,0,0,.05) !important;
  }
  #urlbar[breakout][breakout-extend] > #urlbar-input-container {
      border: 1px solid rgba(0,0,0,.05) !important;
  }
  #urlbar[breakout][breakout-extend][open] > #urlbar-input-container {
      border-bottom: 1px solid transparent !important;
      border-radius: var(--toolbarbutton-border-radius) var(--toolbarbutton-border-radius) 0 0 !important;
  }

more options

Speaking of Chrome... I think I'll just switch to the browser until this annoying feature is eliminated from future updates.

more options

Please give back a configuration option for the (awful) giant urlbar.

more options

I came here to report this bug as well, it needs to be addressed and removable.

more options

Odd how such a feature cannot be disabled from config ... does Mozilla want to lose users? I shouldn't have to know programming to disable it. It is so annoying that, like others, I'll just move over to Chrome. I guess that's what Firefox wants us to do anyway ... move over to Chrome.

more options

Honestly this "feature" is so terrible that it does make me want to move to a different browser and I've been on FF since the very beginning. Pretty pretty please with sugar on top add a tiny little checkbox somewhere to turn this... thing... off! Thanks!

more options

Horrible, just horrible!