Search Support

GMail has started logging me out...

  • 4 回覆
  • 1 有這個問題
  • 20 次檢視
  • 最近回覆由 cor-el

more options

Happening for the last 3 or 4 days, ROUGHLY every half an hour or so, though it seems pretty variable. I have not (knowingly) changed any settings.

I believe the problem is caused by some combination settings in Firefox or in an add-on. So all I can think to do (apart from switching to Chrome) is disable "everything" ("safe mode"?), and then re-enable things and restore settings one by one until the problem re-appears. But since the problem only appears after half an hour or more, this is gong to take many hours of work.

Any hints? Has anyone else seen this?

Developer tools shows me Javascript errors like this:

   Failed to get service worker registration(s): Storage access is restricted in this context due to user settings or private browsing mode.

This may be relevant, but I don't understand what it means.

"Enhanced tracking protection" is (now) OFF for mail.google.com. Any ideas what else might be causing this?

被選擇的解決方法

So the bad news is that I still got/get the "service worker" message.

BUT...

GMail has stopped logging me out.

So telling Firefox to exempt Google from having its cookies deleted when I close the browser stops Google kicking me out every half hour or so.

Obvious, really.

從原來的回覆中察看解決方案 👍 0

All Replies (4)

more options

Quote: Failed to get service worker registration(s): Storage access is restricted in this context due to user settings or private browsing mode.

You usually get this error if you use "Delete cookies and site data when Firefox is closed" to clear the cookies. A possible workaround is to create a cookie allow exception with the proper protocol for this domain.

Helpful?

more options

Thanks, Cor-el. I would not have expected there to be a link between in-session "service worker registration" (whatever that may be!) and setting "delete cookies... when Firefox is closed"!

But I do indeed have that set -- I have had for years! And I have exceptions for google **via HTTP**. I've just tried adding exceptions for HTTPS, so let's see if that makes a difference...

Thanks again for the suggestion.

Helpful?

more options

選擇的解決方法

So the bad news is that I still got/get the "service worker" message.

BUT...

GMail has stopped logging me out.

So telling Firefox to exempt Google from having its cookies deleted when I close the browser stops Google kicking me out every half hour or so.

Obvious, really.

Helpful?

more options

I think that it should work if you have the allow exception for the correct base domain. An exception for https://google.com should work for all Google sub domains.

Helpful?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題