Search Support

Firefox is not remembering urls or logins, across all OSes and hardware

  • 3 回覆
  • 1 有這個問題
  • 7 次檢視
  • 最近回覆由 Travis

more options

I'm attempting to switch back to Firefox on all my computers, but I'm having the same problem on all computers. Firefox can't autocomplete URLs and doesn't remember logins.

- I have to type the full URL for almost everything. Address bar autocomplete flat out does not work. I can visit "www.website.com", close the tab, open a new tab, type "www.website" and autocomplete doesn't suggest anything. I can visit website.com twenty times over the course of several weeks and autocomplete still doesn't work. Some urls are always autocompleted correctly. "news.google.com" autocompletes successfully every time. "linkedin.com" never autocompletes. The urls are present in History. I can open History and see "www.linkedin.com" sitting right there, but autocomplete doesn't suggest it.

- I have to re-login to random websites every time. For example, I have to do complete log ins for Amazon and LinkedIn every time I visit. I always check "Remember me on this computer", and then I do TFA, and then when I visit Amazon and LinkedIn tomorrow I have to log in and do TFA again. Firefox doesn't even suggest my username. I never have to log back in to any Google websites. The cookies are there. I can see Amazon and LinkedIn cookies on my local machine, but Firefox makes me log back in and doesn't remember my username from the last thirty logins.

I'm running up-to-date Firefox with default settings on computers at home and at work running MacOS 10.15, Windows10, and Ubuntu 18.04. I am not using Firefox Sync. Auto-updates are turned on for all OSes and all Firefox installations. And I'm getting the exact same problems on all three machines. Any thoughts?

All Replies (3)

more options

I'd make sure, in about:config

that

browser.urlbar. keyword.enabled browser.urlbar.autoFill

are set to true for the URL issue

as for the cookie/login issue, sometimes login cookies expire after a set time, but it should definitely be lasting longer than a day before you have to 2fa again.

I'd check your about:preferences#privacy and "Login and Passwords"

由 Eve 於 修改

Helpful?

more options

Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).

  • Options/Preferences -> Privacy & Security
    Firefox will: "Use custom settings for history"
  • remove checkmark: [ ] "Always use Private Browsing mode"

Helpful?

more options

Nope. I'm not using private browsing mode and urlbar settings are as expected.

I just uninstalled Firefox, searched my hard drive and deleted all Mozilla and Firefox folders, and reinstalled fresh copies of Firefox 74.0 on both of my home computers. I didn't install any add-ons, I didn't log in to Sync, and I didn't even open Preferences. I installed the browser, ran the browser, clicked on the address bar, and typed in urls. Nothing else. This is completely default Firefox 74.0 running in MacOS 10.15.3 and Windows10. In the first tab I typed in "amazon.com", pressed enter, the site loaded, and I logged in and selected "Keep me logged in". I opened a second tab, typed "amazon.co", and Firefox can't autocomplete the last letter. And when I quit Firefox and then reopen, I'm logged out of Amazon again and autocomplete still doesn't work for amazon.com. If I visit "news.google.com" one time, Firefox has no problem autocompleting "n" into "news.google.com". It seems like Firefox just refuses to remember certain websites. Really bizarre.

Helpful?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題