X
點擊此處開啟此網站的行動版。

技術支援討論區

Location Services not working since Firefox 73 install

已張貼

When trying to access website that needs to know my location for tailoring information, it says it is unable to determine my location. Location services in enabled and permission granted for that particular website. Moved to another browser and it works as expected.

When trying to access website that needs to know my location for tailoring information, it says it is unable to determine my location. Location services in enabled and permission granted for that particular website. Moved to another browser and it works as expected.

被選擇的解決方法

Were you previously using Firefox from the Ubuntu repositories ?

If you API key was previously included then there might have been license changes and Ubuntu may no longer be allowed to include this key.

You can use Firefox from the Mozilla server instead as that version should include this key.

從原來的回覆中察看解決方案 0
引用

額外的系統細節

已安裝的外掛程式

Password1 and AdBlock

應用程式

  • Firefox 73.0
  • 使用者代理:Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:73.0) Gecko/20100101 Firefox/73.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/73.0/Linux/en-US/

擴充套件

  • 1Password X – Password Manager 1.18.0 ({d634138d-c276-4fc8-924b-40a0ea21d284})
  • AdBlock 3.37.0 (jid1-NIfFY2CA8fy1tg@jetpack)
  • Amazon.com 1.1 (amazondotcom@search.mozilla.org)
  • Bing 1.1 (bing@search.mozilla.org)
  • DuckDuckGo 1.0 (ddg@search.mozilla.org)
  • eBay 1.0 (ebay@search.mozilla.org)
  • Google 1.0 (google@search.mozilla.org)
  • Twitter 1.0 (twitter@search.mozilla.org)
  • Wikipedia (en) 1.0 (wikipedia@search.mozilla.org)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: AMD TURKS (DRM 2.50.0 / 5.3.0-29-generic, LLVM 9.0.0)
  • adapterDeviceID: 0x6758
  • adapterDrivers:
  • adapterRAM: 1024
  • adapterVendorID: 0x1002
  • contentUsesTiling: False
  • crashGuards: []
  • driverDate:
  • driverVendor: mesa/r600
  • driverVersion: 19.2.8.0
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'Acceleration blocked by platform', u'type': u'env'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'OpenGL Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}, {u'status': u'unavailable', u'description': u'GPU Process', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'unavailable', u'message': u'Hardware compositing is unavailable.', u'type': u'env'}], u'name': u'GPU_PROCESS'}, {u'status': u'opt-in', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}], u'name': u'WEBRENDER'}, {u'status': u'blocked-device-too-old', u'description': u'WebRender qualified', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked-device-too-old', u'message': u'Device too old', u'type': u'env'}], u'name': u'WEBRENDER_QUALIFIED'}, {u'status': u'disabled', u'description': u'WebRender native compositor', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}], u'name': u'WEBRENDER_COMPOSITOR'}, {u'status': u'available', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OMTP'}, {u'status': u'disabled', u'description': u'WebGPU', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}], u'name': u'WEBGPU'}]}
  • info: {u'DisplayCount': 1, u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'CairoUseXRender': 0, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'none', u'Display0': u'1920x1080 default', u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: {u'key': u''}
  • numTotalWindows: 2
  • offMainThreadPaintEnabled: True
  • offMainThreadPaintWorkerCount: 4
  • targetFrameRate: 60
  • usesTiling: False
  • webgl1DriverExtensions: -
  • webgl1Extensions: -
  • webgl1Renderer: WebGL is currently disabled.
  • webgl1Version: -
  • webgl1WSIInfo: -
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL is currently disabled.
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic
  • windowProtocol: x11
  • windowUsingAdvancedLayers: False

修改過的偏好設定

其他

  • User JS: 否
  • 輔助功能: 否
FredMcD
  • Top 10 Contributor
4398 個解決方法 61709 個答案

What do these websites say about your location?

http://whatismyipaddress.com/ Under the map, look for Location Not Accurate?

http://browserleaks.com/geo

https://html5demos.com/geo/

https://www.iplocation.net/find-ip-address

How to set your location manually in Firefox(Windows) https://support.mozilla.org/en-US/questions/1197142#answer-1115502

What do these websites say about your location? http://whatismyipaddress.com/ Under the map, look for '''Location Not Accurate?''' http://browserleaks.com/geo https://html5demos.com/geo/ https://www.iplocation.net/find-ip-address How to set your location manually in Firefox(Windows) https://support.mozilla.org/en-US/questions/1197142#answer-1115502
這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17876 個解決方法 161748 個答案

Do you have all API keys in your Firefox version from the repositories if you check that on the "Help -> Troubleshooting Information" page ?

Do you have all API keys in your Firefox version from the repositories if you check that on the "Help -> Troubleshooting Information" page ?
這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17876 個解決方法 161748 個答案

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution. *https://www.mozilla.org/en-US/firefox/all/#product-desktop-release
這篇文章有幫助嗎?
引用

提出問題者

FredMcD said

What do these websites say about your location? http://whatismyipaddress.com/ Under the map, look for Location Not Accurate? http://browserleaks.com/geo https://html5demos.com/geo/ https://www.iplocation.net/find-ip-address How to set your location manually in Firefox(Windows) https://support.mozilla.org/en-US/questions/1197142#answer-1115502
''FredMcD [[#answer-1290858|said]]'' <blockquote> What do these websites say about your location? http://whatismyipaddress.com/ Under the map, look for '''Location Not Accurate?''' http://browserleaks.com/geo https://html5demos.com/geo/ https://www.iplocation.net/find-ip-address How to set your location manually in Firefox(Windows) https://support.mozilla.org/en-US/questions/1197142#answer-1115502 </blockquote>
這篇文章有幫助嗎?
引用

提出問題者

whatismyipaddress.com says: Location not accurate? Update my IP location

browserleaks.com says: (2) POSITION_UNAVAILABLE — The current position could not be determined

Not using Windows...

whatismyipaddress.com says: Location not accurate? Update my IP location browserleaks.com says: (2) POSITION_UNAVAILABLE — The current position could not be determined Not using Windows...
這篇文章有幫助嗎?
引用

提出問題者

cor-el said

Do you have all API keys in your Firefox version from the repositories if you check that on the "Help -> Troubleshooting Information" page ?

Mozilla Location Key is the only key missing.

Question then is, how did that happen? Was there before upgrade

''cor-el [[#answer-1290859|said]]'' <blockquote> Do you have all API keys in your Firefox version from the repositories if you check that on the "Help -> Troubleshooting Information" page ? </blockquote> Mozilla Location Key is the only key missing. Question then is, how did that happen? Was there before upgrade
這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17876 個解決方法 161748 個答案

選擇的解決方法

Were you previously using Firefox from the Ubuntu repositories ?

If you API key was previously included then there might have been license changes and Ubuntu may no longer be allowed to include this key.

You can use Firefox from the Mozilla server instead as that version should include this key.

Were you previously using Firefox from the Ubuntu repositories ? If you API key was previously included then there might have been license changes and Ubuntu may no longer be allowed to include this key. You can use Firefox from the Mozilla server instead as that version should include this key. *https://www.mozilla.org/en-US/firefox/all/#product-desktop-release
這篇文章有幫助嗎?
引用

提出問題者

That's one idea but I suspect I'm not going to be the only one affected by this. Additionally, to ensure a clean install, i will probably have to uninstall the version from the repositories which means I will lose my bookmarks, add-ons etc. Then reinstall from Mozilla and get everything back working (not trivial) only to lose it again when Firefox is auto installed from the repositories. Yep, could turn off auto install but then I lose all my other updates and that creates another hands on issue trying to keep the system updated. It's probably easier to just to convert to Chrome and be done with it.

Thank you for the information and assistance. At least I know why it's not working

That's one idea but I suspect I'm not going to be the only one affected by this. Additionally, to ensure a clean install, i will probably have to uninstall the version from the repositories which means I will lose my bookmarks, add-ons etc. Then reinstall from Mozilla and get everything back working (not trivial) only to lose it again when Firefox is auto installed from the repositories. Yep, could turn off auto install but then I lose all my other updates and that creates another hands on issue trying to keep the system updated. It's probably easier to just to convert to Chrome and be done with it. Thank you for the information and assistance. At least I know why it's not working
這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17876 個解決方法 161748 個答案

You do not need to lose data stored in the profile folder if you uninstall the Ubuntu Firefox version. The profile folder for all Firefox versions is in "~/.mozilla/firefox/" in the home directory and uninstalling should only affect the Firefox installation directory (likely in /usr/lib/) To be sure you can temporarily rename the "~/.mozilla/" folder and backup the Firefox profile folder. You can install Firefox in a root location like "/opt/mozilla/firefox" or in your home directory for easier updating.

You do not need to lose data stored in the profile folder if you uninstall the Ubuntu Firefox version. The profile folder for all Firefox versions is in "~/.mozilla/firefox/" in the home directory and uninstalling should only affect the Firefox installation directory (likely in /usr/lib/) To be sure you can temporarily rename the "~/.mozilla/" folder and backup the Firefox profile folder. You can install Firefox in a root location like "/opt/mozilla/firefox" or in your home directory for easier updating.
這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題