搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Tibetan text no more wraps

  • 8 回覆
  • 2 有這個問題
  • 33 次檢視
  • 最近回覆由 Arsis

more options

Hi, I manage a website that contains Tibetan fonts. Recently I've noticed that the Tibetan text no more wraps and cause my table-styled page broken. However, the page renders normally in other browsers. Here are the browsers that render normally and wrongly:

Page url: http://www.shartulrinpoche.org/index.html

Rendering wrongly: - Firefox 73.0 - Firefox (Android) 68.5.0 - Firefox lite (Android) 2.1.8 - Firefox Preview (Android) 3.2.1

Rendering normallyl: - Microsoft Edge Ver 80.0.361.53 - Google Chrome Ver 81.0.4044.17 - Google Chrome (Android) Ver 81.0.4044.18 - Brave (Android) 1.5.5 - Firefox Focus (Android) 8.0.25

Thanks in advance for any help.

所有回覆 (8)

more options

Hi Arsis, is the problem that Firefox isn't able to find the spaces between words in the language, or that Firefox won't break a long word the way other browsers do?

Do you recall the last version of Firefox that works the way you recall? Since you referenced Firefox for Android, based on Firefox 68, this issue may go back quite a while.

有幫助嗎?

more options

Can you attach a screenshot ?

Did you make sure this is not font related ?

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

I see this (screenshot).

有幫助嗎?

more options

Hi jscher2000 said

Hi Arsis, is the problem that Firefox isn't able to find the spaces between words in the language, or that Firefox won't break a long word the way other browsers do? Do you recall the last version of Firefox that works the way you recall? Since you referenced Firefox for Android, based on Firefox 68, this issue may go back quite a while.

Hi jscher2000 ,

The problem that I encounter seems to be that Firefox isn't able to find the spaces between words in the language (Tibetan) the way others browsers do. However, I cannot recall the last version of Firefox that worked...

Arsis

有幫助嗎?

more options

cor-el said

Can you attach a screenshot ? [...] Did you make sure this is not font related ? [...] You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website. I see this (screenshot).

Hi cor-el

Thank you so much for the debugging info. The problem is a little bit lower at the Tibetan part of the page: just before the 'Listen to chanting...." and before the Chinese paragraphe. As shown in my attachd image (#2).

I checked with the Inspect Element which confirmed that the font is correctly used as I defined (Tibet Machine Uni). I think it's not a problem of the font because earlier version of Firefox as well as MS Edge and Chrome can display it correctely. As shown in my attached image (#3, marked with "chrome")

By the way, I'm sure that the problem is the long Tibetan paragraphe (the one that you quoted in your screenshot). Because the page displays corrently if I delete that paragraphe.

Screenshots of Firefox 73 (for PC 64-bit) as attached.

BR, Arsis

由 Arsis 於 修改

有幫助嗎?

more options

That part looks fine for me as well.

有幫助嗎?

more options

Mine shows a different font is used (I must not have the specified one installed). See attached.

有幫助嗎?

more options

This seems to be largely a Windows 10 incompatibility for Firefox. Tibetan wraps as expected when running the latest version of Firefox on Windows 7 SP1 or MacOS 10.15.3 Catalina.

Of course most (all?) browsers on WIndows 10 --other than Firefox-- don't have any problem in wrapping Tibetan text at the inter-syllabic character (U+0F0B).

有幫助嗎?

more options

cor-el said

That part looks fine for me as well.

Hi Cor-el,

May I know which version do you use? I'm using 78.0.2 (64 bits) and it's still not displaying correctly..

Thanks, Arsis

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題