X
點擊此處開啟此網站的行動版。
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

技術支援討論區

Make "Minimize Memory Usage" default

已張貼

Like many users who have placed this same complaint on this forum and others, Firefox, when left active with even only a few tabs, uses all available RAM until my 16 GB machine is populated up to 98% and barely works (Dell Optiplex 5060, i7-8700, 16 GB RAM, Windows 10 64-bit; Firefox 72.0.2 (64-bit)).

When I shut Firefox down, I release 8 GB of RAM. I have used the "about:memory|Minimize Memory Usage" button with some success.

How can I make that memory setting permanent or the default, so I don't have to lose my research momentum by having to wait to get to a point where I can open the "about" settings window and manually click that button? It's very frustrating.

I've tested in Safe Mode, disabled any add-ons (I only have what Firefox supplied), and the condition still persists.

Making the "Minimize Memory Usage" setting, or an equivalent if there is one, permanent would help.

Thanks.

Like many users who have placed this same complaint on this forum and others, Firefox, when left active with even only a few tabs, uses all available RAM until my 16 GB machine is populated up to 98% and barely works (Dell Optiplex 5060, i7-8700, 16 GB RAM, Windows 10 64-bit; Firefox 72.0.2 (64-bit)). When I shut Firefox down, I release 8 GB of RAM. I have used the "about:memory|Minimize Memory Usage" button with some success. How can I make that memory setting permanent or the default, so I don't have to lose my research momentum by having to wait to get to a point where I can open the "about" settings window and manually click that button? It's very frustrating. I've tested in Safe Mode, disabled any add-ons (I only have what Firefox supplied), and the condition still persists. Making the "Minimize Memory Usage" setting, or an equivalent if there is one, permanent would help. Thanks.

由 ed9213 於 修改

引用

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 32.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

更多資訊

Mirinchuk Aleksey 0 個解決方法 1 個答案
https://support.mozilla.org/en-US/user/yoasif/documents
這篇文章有幫助嗎?
引用

提出問題者

Hello Mirinchuk Aleksey,

Thank you for sending the links to the articles and tips that pertain to Firefox’s performance, memory use, and work-arounds to make the computer and Firefox work better.

All have one thing in common - they don’t answer the question as to how to make Minimize Memory Usage a default setting.

With all the other issues Firefox presents, it does eat up all the available RAM on my computer.

I don’t have the time or expertise to troubleshoot add-ons and drivers and have to restart Firefox and reboot my computer just because Firefox seems to run away with all the available memory. There seems to be a way to cap its memory usage, and I would like to set that as a default.

If the frustrations of using Firefox outweigh its usefulness, then it will have to be replaced with another browser.

Thanks, again, for your help.

If you find the answer to my question, please let me know.

Ed9213

Hello Mirinchuk Aleksey, Thank you for sending the links to the articles and tips that pertain to Firefox’s performance, memory use, and work-arounds to make the computer and Firefox work better. All have one thing in common - they don’t answer the question as to how to make Minimize Memory Usage a default setting. With all the other issues Firefox presents, it does eat up all the available RAM on my computer. I don’t have the time or expertise to troubleshoot add-ons and drivers and have to restart Firefox and reboot my computer just because Firefox seems to run away with all the available memory. There seems to be a way to cap its memory usage, and I would like to set that as a default. If the frustrations of using Firefox outweigh its usefulness, then it will have to be replaced with another browser. Thanks, again, for your help. If you find the answer to my question, please let me know. Ed9213
這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17851 個解決方法 161559 個答案

If the memory usage of Firefox is increasing that much then it looks that you suffer from memory leaks where new memory keeps getting allocated and not freed.

Did you check on the about:memory page what is using that much memory ?


Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
If the memory usage of Firefox is increasing that much then it looks that you suffer from memory leaks where new memory keeps getting allocated and not freed. Did you check on the about:memory page what is using that much memory ? ---- Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題