X
點擊此處開啟此網站的行動版。
Scheduled maintenance: Wednesday, April 1, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

技術支援討論區

How to remove pixel-smoothing for Firefox when using in low-resolution mode of macOS

已張貼

I use an old macbook, and I usually use firefox in low-resolution mode for performance and energy efficiency. In the extended support release version, there is no pixel-smoothing in low resolution mode, which I find it looks better. However, when I switch to use the regular version, it seems like firefox apply from pixel-smoothing filter to the application when in low resolution mode, which I find it blurry and not looking very nice at all, and I doubt that it would some little more of my cpu/gpu useage. Is there any way to have a toggle setting (maybe in about:config) to turn this smoothing off? In the attachment you will find the pictures of 2 versions compare

I use an old macbook, and I usually use firefox in low-resolution mode for performance and energy efficiency. In the extended support release version, there is no pixel-smoothing in low resolution mode, which I find it looks better. However, when I switch to use the regular version, it seems like firefox apply from pixel-smoothing filter to the application when in low resolution mode, which I find it blurry and not looking very nice at all, and I doubt that it would some little more of my cpu/gpu useage. Is there any way to have a toggle setting (maybe in about:config) to turn this smoothing off? In the attachment you will find the pictures of 2 versions compare
附加的畫面擷圖
引用

額外的系統細節

應用程式

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:72.0) Gecko/20100101 Firefox/72.0

更多資訊

jscher2000
  • Top 10 Contributor
8951 個解決方法 73365 個答案

You could try disabling Firefox from using hardware acceleration. Obviously that affects other features, too, but I believe it will prevent Firefox from applying sub-pixel aliasing.

This article will get you to the relevant part of the Preferences page: Firefox's performance settings.

(Possibly that is why you don't have sub-pixel aliasing on your ESR installation?)

You could try disabling Firefox from using hardware acceleration. Obviously that affects other features, too, but I believe it will prevent Firefox from applying sub-pixel aliasing. This article will get you to the relevant part of the Preferences page: [[Firefox's performance settings]]. (Possibly that is why you don't have sub-pixel aliasing on your ESR installation?)
這篇文章有幫助嗎?
引用

提出問題者

Hi jscher2000,

Thank you for your response! I tried disabling the hardware acceleration as you suggested. However, it would not work.

Hi jscher2000, Thank you for your response! I tried disabling the hardware acceleration as you suggested. However, it would not work.

由 chanwutk 於 修改

這篇文章有幫助嗎?
引用
Matthew Thomas
  • Top 25 Contributor
13 個解決方法 90 個答案

Make sure that the following two settings are false in about:config

  • gfx.use_text_smoothing_setting
  • layout.css.osx-font-smoothing.enabled
Make sure that the following two settings are false in about:config * gfx.use_text_smoothing_setting * layout.css.osx-font-smoothing.enabled
這篇文章有幫助嗎?
引用

提出問題者

Hello Matthew,

Thank you for answering! However, it still does not work for me :(

Hello Matthew, Thank you for answering! However, it still does not work for me :(
這篇文章有幫助嗎?
引用
Matthew Thomas
  • Top 25 Contributor
13 個解決方法 90 個答案

It's hard for me to come up with a solution because I don't have a mac, and this behavior does not exist on other systems. Is it possible that you added some sort of exception in the system for the ESR Firefox? The blurriness is affecting parts of the window not drawn by Firefox, so it should be the system that controls this.

As a workaround, you could mess with the dpi of the application: layout.css.devPixelsPerPx

to try to find a sweet spot. The default value (-1) is automatic. I think you'd want a value less than 1.

It's hard for me to come up with a solution because I don't have a mac, and this behavior does not exist on other systems. Is it possible that you added some sort of exception in the system for the ESR Firefox? The blurriness is affecting parts of the window not drawn by Firefox, so it should be the system that controls this. As a workaround, you could mess with the dpi of the application: layout.css.devPixelsPerPx to try to find a sweet spot. The default value (-1) is automatic. I think you'd want a value less than 1.
這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17854 個解決方法 161578 個答案

Note that layout.css.devPixelsPerPx accepts 5% and 10% changes (0.1 and 0.05) to allow fine tuning. Make sure that you do not make the value too small or too large, so double check.

Note that layout.css.devPixelsPerPx accepts 5% and 10% changes (0.1 and 0.05) to allow fine tuning. Make sure that you do not make the value too small or too large, so double check.
這篇文章有幫助嗎?
引用

提出問題者

Hi, Thank you for the responses! I tried changing the value; however, it still does not work. I guess, it is fine for me to use the ESR version for now :)

Hi, Thank you for the responses! I tried changing the value; however, it still does not work. I guess, it is fine for me to use the ESR version for now :)
這篇文章有幫助嗎?
引用

提出問題者

Is it possible for requesting a feature to have a setting in the about:config to disable the pixel smoothing?

Is it possible for requesting a feature to have a setting in the about:config to disable the pixel smoothing?
這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題