X
點擊此處開啟此網站的行動版。

技術支援討論區

Strange error message

已張貼

FF updated and now I'm getting this very odd message-

"The iOS 10 private browser for Safari does not support storing settings locally. Some settings may not save or some features may not work properly for you. Updating to iOS 11 to solve this issue."

This shows on some sites when I try to log in but will work in a private window. Mac OS X Catalina 10.15.2 Firefox 72.0.1

To be clear...this error appears in firefox, NOT Safari despite the text content of the message

FF updated and now I'm getting this very odd message- "The iOS 10 private browser for Safari does not support storing settings locally. Some settings may not save or some features may not work properly for you. Updating to iOS 11 to solve this issue." This shows on some sites when I try to log in but will work in a private window. Mac OS X Catalina 10.15.2 Firefox 72.0.1 To be clear...this error appears in firefox, NOT Safari despite the text content of the message
附加的畫面擷圖

由 sparemailadd 於 修改

引用
benjamincorona157 0 個解決方法 1 個答案

Reinstall the app and restart your iPhone

Reinstall the app and restart your iPhone
這篇文章有幫助嗎? 0
引用

提出問題者

benjamincorona157 said

Reinstall the app and restart your iPhone

Well, there's a clear case of not reading the OP

''benjamincorona157 [[#answer-1282271|said]]'' <blockquote> Reinstall the app and restart your iPhone </blockquote> Well, there's a clear case of not reading the OP
這篇文章有幫助嗎?
引用
crankygoat
  • Top 25 Contributor
40 個解決方法 471 個答案

Your user agent string looks fine, but appears the sites in question are incorrectly detecting your browser and OS.

Is the style of that message box the same at any of the sites which display it to you? Is it many sites?

Your user agent string looks fine, but appears the sites in question are incorrectly detecting your browser and OS. Is the style of that message box the same at any of the sites which display it to you? Is it many sites?
這篇文章有幫助嗎?
引用

提出問題者

crankygoat said

Your user agent string looks fine, but appears the sites in question are incorrectly detecting your browser and OS. Is the style of that message box the same at any of the sites which display it to you? Is it many sites?

Had some time to look at more sites...there are different issues on multiple sites but they all revolve around the log in process. Some throw redirect errors, some simply fail to log in and return to the log in page.

These sites all worked well before the latest update.

''crankygoat [[#answer-1282491|said]]'' <blockquote> Your user agent string looks fine, but appears the sites in question are incorrectly detecting your browser and OS. Is the style of that message box the same at any of the sites which display it to you? Is it many sites? </blockquote> Had some time to look at more sites...there are different issues on multiple sites but they all revolve around the log in process. Some throw redirect errors, some simply fail to log in and return to the log in page. These sites all worked well before the latest update.
這篇文章有幫助嗎?
引用
crankygoat
  • Top 25 Contributor
40 個解決方法 471 個答案

Are you using any add-ons, particularly password managers or ad/script blockers? Do you log in manually, or do you have Firefox or another password manager autofill the login information?

Can you try Firefox in Safe Mode and see if the issue persists? ☰Menu → Preferences → Help → Restart with Add-ons Disabled

Are you using any add-ons, particularly password managers or ad/script blockers? Do you log in manually, or do you have Firefox or another password manager autofill the login information? Can you try Firefox in Safe Mode and see if the issue persists? &#9776;Menu &rarr; Preferences &rarr; Help &rarr; Restart with Add-ons Disabled
這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17764 個解決方法 160650 個答案

Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).

  • Options/Preferences -> Privacy & Security
    Firefox will: "Use custom settings for history"
  • remove checkmark: [ ] "Always use Private Browsing mode"

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear
Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History). *https://support.mozilla.org/en-US/kb/private-browsing-use-firefox-without-history *Options/Preferences -> Privacy & Security<br>Firefox will: "Use custom settings for history" *remove checkmark: [ ] "Always use Private Browsing mode" ---- Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Remove the Cookies" for websites that cause problems: *Options/Preferences -> Privacy & Security<br>Cookies and Site Data: "Manage Data" "Clear the Cache": *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Clear Data -> Cached Web Content: Clear
這篇文章有幫助嗎?
引用

提出問題者

actually, the logins work in private mode.

the only add-on is adblocker plus, which I disabled with the same result

actually, the logins work in private mode. the only add-on is adblocker plus, which I disabled with the same result
這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題