搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Slow theme load and number of processes

more options

I upgraded to Firefox 68.4.1, not because I wanted to (v60 was working perfectly for me). Netflix in their never ending quest to break people's access changed the minimum requirement to v65.

Of course, the upgrade broke things. I've managed to get everything working except for my theme. I'm using a theme called earth from space. When I start firefox I see the blank top section of the browser for up to 2 seconds before the them loads. On 56, 57 and 60 which are the last 3 versions I used, the theme loaded so fast I never saw the underlying browser.

I tried a couple of different themes but they are still slow to load.

I've also been experimenting with various performance settings in trying to solve this; Hardware acceleration on/off. Content process limit; Tried 1 - 8. Mind you, 1-8 still runs 5 processes @ ~ 500mb RAM when I have only one tab with my homepage open (I have a server here where my home page comes from. It's plain HTML and nothing else).

Any ideas on why the theme is loading so slowly and why setting performance settings always results in 5 processes?

I upgraded to Firefox 68.4.1, not because I wanted to (v60 was working perfectly for me). Netflix in their never ending quest to break people's access changed the minimum requirement to v65. Of course, the upgrade broke things. I've managed to get everything working except for my theme. I'm using a theme called earth from space. When I start firefox I see the blank top section of the browser for up to 2 seconds before the them loads. On 56, 57 and 60 which are the last 3 versions I used, the theme loaded so fast I never saw the underlying browser. I tried a couple of different themes but they are still slow to load. I've also been experimenting with various performance settings in trying to solve this; Hardware acceleration on/off. Content process limit; Tried 1 - 8. Mind you, 1-8 still runs 5 processes @ ~ 500mb RAM when I have only one tab with my homepage open (I have a server here where my home page comes from. It's plain HTML and nothing else). Any ideas on why the theme is loading so slowly and why setting performance settings always results in 5 processes?

由 TanyaC 於 修改

所有回覆 (5)

more options

Hi TanyaC, The earth from space theme loads instantly for me. Could it be your userChrome.css slowing it down?

As far as the processes running, Firefox moved to a multi-process architecture which helps with performance and prevents crashes. The best explanation is from @cor-el:

It is quite normal to see more Firefox processes running.

- one process for the main Firefox thread (user interface) - one process for the compositor thread - one process for the WebRender when this feature is enabled - one or more content processes (default is 8), see: Options/Preferences -> General -> Performance remove checkmark: [ ] "Use recommended performance settings"

You can find the current multi-process state on the Troubleshooting Information page (about:support).

"Help -> Troubleshooting Information" -> "Application Basics": Multiprocess Windows Remote Processes

See also the Remote Processes section further down for more detail. _______________________________________________________________ And also see this article from ghacks: https://www.ghacks.net/2016/07/22/multi-process-firefox/

more options

Just a note for if/when you update to ver. 69. You will see in the release notes: Firefox no longer loads userChrome.css or userContent.css by default improving start-up performance. Users who wish to customize Firefox by using these files can set the toolkit.legacyUserProfileCustomizations.stylesheets preference to true to restore this ability.

more options

RobertJ said

Just a note for if/when you update to ver. 69. You will see in the release notes: Firefox no longer loads userChrome.css or userContent.css by default improving start-up performance. Users who wish to customize Firefox by using these files can set the toolkit.legacyUserProfileCustomizations.stylesheets preference to true to restore this ability.

It gets worse with every release :(

I'm only installing ESR releases. I gather the next one will be v76?

由 TanyaC 於 修改

more options

RobertJ said

The earth from space theme loads instantly for me. Could it be your userChrome.css slowing it down?

It loaded instantly in v60 ESR. It;s only on v68 I'm seeing the problem across all PCs.

Please find attached my userChrome.css file;

https://pastebin.com/QHRYPJTB

This is taken directly from posts here and earlier Firefox support sites

more options

TanyaC said

It gets worse with every release :( I'm only installing ESR releases. I gather the next one will be v76?

There's always a trade off game, right?

Here's the Release Schedule https://wiki.mozilla.org/Release_Management/Calendar

TanyaC said

Please find attached my userChrome.css file; https://pastebin.com/QHRYPJTB This is taken directly from posts here and earlier Firefox support sites

I don't work with scripts but, someone else who does may be able to help you out.