搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Recently added bookmarks won't have favicons

  • 5 回覆
  • 2 有這個問題
  • 103 次檢視
  • 最近回覆由 macciofe

more options

Hello everyone!

I'm having a pretty weird problem here. Whenever I add a new site, it will show that grey globe instead of it's favicon on the bookmarks. If I go to my bookmarks and click on the recently added site, it will then load the favicon normaly, but that's the only way of "forcing" it to load.

Any idea of why this may be happening?

所有回覆 (5)

more options

That is strange. I'm wondering if the .sqlite file for the bookmark favicons got corrupted causing it to need you to visit the site manually to make the favicon appear.

You could try moving or renaming the favicons.sqlite file [don't delete it] in the Firefox profile folder while Firefox is not running. Then start Firefox & allow it to reload all the favicons from scratch. It will rebuild a new favicons.sqlite file on startup if it can't find a file with that name & hopefully that should fix the issue. If not, it may be a new bug we'll have to report.

If the favicons situation gets worse somehow, you can always just close down Firefox again & place the original favicons.sqlite file back in the Firefox profile folder. And it will be back to the previous state.

more options

Thank you so much for the quick answer!

Unfortunately, doing as described didn't solve the problem. It would still behave in the same way.

By the way, this only seems to happen here on my Windows 10 PC. I have a notebook running on Windows 7 with it's Firefox in Sync, and it don't have any problem with the favicons (although I will double check there as soon as I can just to be 100% sure).

more options

How are you creating the new bookmark ?

If you click the star in the location/address bar then Firefox should add the favicon automatically. If you create the new bookmark manually then you need to open the bookmark in a tab to make Firefox add the favicon.

more options

I'm using the star to create all my bookmarks. Actually, I never created one manually.

A little update regarding my notebook: Tried to bookmark something there, and it worked perfectly, favicon and all. Came to my PC and Firefox didn't even synchronized the site I bookmarked there. Definitely something is very wrong here.

more options

I'm having the same problem with favicons that were installed via syncing with firefox on my other computers. Some of the favicons were corrected when I visited the site. Others were not.