Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Gmail says browser not supported. Open basic HTML site only

more options

I have updated my firefox to latest version but gmail keep saying my browser isn't supported and it opens the basic HTML version only. I've checked gmail support page and it only says i need to update my firefox and enable cookies. Both which i have done.

The problem started around 2 weeks ago.

All Replies (15)

more options

Does the problem still happen when you run Firefox in Safe Mode? It's possible that an extension you have installed is causing the issue.

Also, try changing Enhanced Tracking Protection to Standard if it's not already set to that. If that fixes the problem, you may need to disable that feature on Gmail.

Hope this helps.

more options

Tried safe mode, but the problem persist. So it's not caused by any extension

more options

Do you have any content blocking extensions ?

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows an highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content.

  • click the shield icon for more details and possibly disable the protection

You can check in the Web Console what content is blocked

You can try to create a cookie allow exception for Gmail (https://google.com).

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Permissions
more options

this is all the things i tried

- run firefox in safe mode - check content blocking - refresh firefox to its default setting - uninstall and deleting everything, doing a fresh install afterwards

did all that, gmail is still saying my browser isn't supported

more options

Hi, I would like you to check followings things, goto https://www.whatsmyua.info/ and check your use agent. It looks like your user-agent have been changed somehow.

more options

Here are the result for my user agent

According to useragent v2.2.1: ua

   rawUa: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/71.0
   string:
   family: Firefox
   major: 71
   minor: 0
   patch: 0
   device: Other 0.0.0

os

   string: Windows 7 0.0.0
   family: Windows 7
   major: 0
   minor: 0
   patch: 0


According to ua-parser-js v0.7.20: ua

   ua: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/71.0

browser

   name: Firefox
   version: 71.0
   major: 71

engine

   name: Gecko
   version: 39.0

os

   name: Windows
   version: 7

device

   vendor: undefined
   model: undefined
   type: undefined

cpu

   architecture: amd64


According to platform.js v1.3.5: ua

   name: Firefox
   version: 71.0
   layout: Gecko

os

   os: Windows Server 2008 R2 / 7 64-bit

device

   product:
   manufacturer:
   description: Firefox 71.0 32-bit on Windows Server 2008 R2 / 7 64-bit

由 Syawal 於 修改

more options

Try to change the browser and back login , maybe it will help you nflbite

more options

This is probably not about the user agent, but about having disabled some features that Gmail needs to have enabled for the advanced features.

Maybe the Web Console gives some information.

more options

gmail still not working properly.

more options

This forum reads your User Agent as such: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/71.0

That rv:39.0 number should read as rv:71.0 ! Very purposely Mozilla aligned the Firefox version number with the Gecko engine version number 8 to 10 years ago so that they always match.

Perhaps Gmail is going by the Gecko revision version number?

more options

ok. do you have any suggestion how to change that 39.0 to latest version?

more options

Been a month now. Can someone help me?

It's not just gmail anymore, many other websites are saying i'm not using supported browser.

I have tried clean install of firefox more than 10 times.

Really don't want to change browser since i've been using firefox for years.

more options
more options

please someone help me...been more than 6 months already.. i've reinstalled firefox more than 70 times already.. still so many site says my browser is not supported. i've opened all the link people replied here but none of the solution works..

more options

Please start a new support thread so that we can see that UserAgent string right now!

That information only is picked up by this forum software with the initial posting when a support thread is started. And you can see that UA string when viewing Troubleshooting Information from the Help Menu. The Help menu will appear when you hit the Alt key on the keyboard. 7th item on the listing in Troubleshooting Information. Copy that string and paste it into this thread, if you don't want start a new thread, which IMO might be better. Sorry I lost track of this thread back in January, but hey I volunteer my time here to help other Firefox users try to solve their issues ...