搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Stop Videos from Automatically Playing in Firefox

  • 14 回覆
  • 4 有這個問題
  • 2065 次檢視
  • 最近回覆由 TyDraniu

more options

I have read every article on this I can find, including everything in Firefox. I cannot get videos to stop automatically play. I can get them to not play sound. I have changed every single setting in about:config, media.autoplay. Nothing stops them from playing. I have used numbers from 0 to 5 in media.autoplay.default. Attached is a screenshot of my settings.

I do not have any plug-ins at this point, as I just installed Windows 10 and am configuring my computer.

I am extremely sensitive to these moving videos; they make me feel sick. So I really need them disabled. PCMag is a good example of a site with a million different (types?) of videos playing.

附加的畫面擷圖

被選擇的解決方法

I don't experience any autoplaying. This is my setup:

media.autoplay.allow-extension-background-pages	false	
media.autoplay.block-event.enabled	true	
media.autoplay.block-webaudio	true	
media.autoplay.default	5	
media.autoplay.enabled.user-gestures-needed	false

See also Allow or block media autoplay in Firefox.

從原來的回覆中察看解決方案 👍 3

所有回覆 (14)

more options

The other thing is, there is not even anything to click on to stop them from playing. Why is that?

FYI, not only are these videos annoying as can be, the waste precious natural resources. Servers are more occupied, and they use tremendous amounts of energy to keep cool.

由 lsk123 於 修改

more options

選擇的解決方法

I don't experience any autoplaying. This is my setup:

media.autoplay.allow-extension-background-pages	false	
media.autoplay.block-event.enabled	true	
media.autoplay.block-webaudio	true	
media.autoplay.default	5	
media.autoplay.enabled.user-gestures-needed	false

See also Allow or block media autoplay in Firefox.

由 TyDraniu 於 修改

more options

Thanks. Works perfectly.

more options

The 5 point approach suggested above prevents the auto-play but NOT the loading! So still a resource hog and waste of bandwith for those operating with limited processors and bandwith.

I want it to only load if I click play.

more options

Secondly, auto-play is a two context problem. The above partial solutions partially handle embedded videos, but completely fail to prevent auto-play on video sites such as Dailymotion.

On Dailymotion's help pages, they state firefox preferences can prevent auto-play, but this is false. Even with all the firefox settings suggested above, daily motion incessantly loads more videos at the end of the desired one.

Thankfully, Youtube has a toggle button disabling autoplay, but sadly, it's not remembered. Any time there's a cache clean, that settting is forgotten.

I cant count how many nights I fell asleep to a video in bed, only to wake up six hours later with 50 videos having played while I slept! Ridiculous. It's disrespectful to web citizens to not allow control over this.

When Firefox is set to not auto-play, that should suffice for both embedded videos and video websites.

由 TNT666 於 修改

more options

Oh the horror, with all five of those settings, I can no longer play embedded video on that site at all! And when I click the info icon and re-enable audio and video, the lag time is horrible. Reversing all of those 5 steps. That was pointless. :(

more options

You can use the Autoplay setting in "Tools -> Page Info -> Permissions" to allow audio and video or use the Autoplay icon on the location bar. For videos that are embedded this can be more difficult, but you should always be able to click the play button to start a video.

If you have extensions that can block content or playing media then you should check their settings or temporarily disable the extension as a test.

more options

As I've stated, I've tried all three direct superficial methods, I've tried the 5 about:config methods. Fail. Fail on embedded videos, by blocking play when desired. Fail on video websites, following videos continued to auto-play.

I had to reset all settings to default, because with the 5 about:config setting changes, hitting the play arrow did nothing. I'm once more stuck with auto-playing videos in both contexts.

When people say "stop auto-play", it's safe to assume the vast majority also include in that statement the auto-load component.

由 TNT666 於 修改

more options

So on either of these pages you weren't able to play media even if you clicked the autoplay icon on the location bar to allow playing media ?

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required) where you have this issue ?

Are you using content blocking extensions ?

Did you try Firefox Safe Mode ?

more options

Both websites I presented (Fox News (https://www.foxnews.com/entertainment/evan-rachel-wood-kobe-bryant-sports-hero-rapist-tweet-hours-death) and Dailymotion (https://www.dailymotion.com/video/x5kns6r) ) are publicly accessible. Extension, I use ABP+

On the embedded Fox News video, the 5 about:config settings 1. prevented auto-play but video continued to load 2. prevented clicking play arrow at all on the embedded video, and when I changed the auto-play feature in the bar, the video had trouble playing, very intermittent. 3. When I reset all 5 about:config items, the embedded video played without a problem.

On the video website (Dailymotion) the 5 about:config settings 1. prevented auto-start initially, 2. allowed pressing using play button and 3. did not prevent autoplay at the end of of video

more options

None of the above means anything to me, as I am computer basic. I just want videos to STOP auto playing, on Facebook timeline. Yes, I do have the FB setting of OFF, but to no effect. As soon as I scroll to a video someone has posted, my computer freezes, and MUCH time passes before any activity. This happens multiple times during any session.

I believe it is a Firefox issue, as I tried it on the BRAVE browser, and it does not happen there.

Someone at Firefox, please advise in simple language (not lines of computer code / commands) how to fix this. I don't want to switch to BRAVE as my default browser, but will have to, if I can't fix this.

Surely, it is some setting that can be adjusted ???

more options

JP said

Surely, it is some setting that can be adjusted ???

Right. Just enter about:config in the URL bar. The rest is pretty straightforward.

more options

TyDraniu said

JP said
Surely, it is some setting that can be adjusted ???

Right. Just enter about:config in the URL bar. The rest is pretty straightforward.

Thanks. Done that, however, it goes to a list of about 1,000 or more options / links. Which one ?

more options

There's a Search preference field on top of that page. It's enough to type in media.autoplay.

Names and values of preferences to change I provided here before.