X
點擊此處開啟此網站的行動版。

技術支援討論區

webgl2 not available after upgrade from 60.9esr to 68.2esr - debian linux - amd hd 4200

已張貼

With amd HD 4200 graphics chip:

There was no webgl after updating from 60.9esr to 68.2.0esr on debian, and from debian standard repo.

After setting webgl.force-enabled true, webgl1 works, but no webgl2.

WebGL creation failed:

   Refused to create WebGL2 context because of blacklist entry: FEATURE_FAILURE_OLD_FGLRX 

GPU: GPU #1 Active Yes Description Gallium 0.4 on AMD RS880 (DRM 2.49.0 / 4.9.0-11-amd64, LLVM 3.9.1) Vendor ID 0x1002 Device ID 0x9710 Driver Vendor mesa/r600 Driver Version 13.0.6.0 RAM 256MB

The ff tarball from mozilla org extracted to /opt shows same behaviour. It should work, but it seems to be looking for fglrx when open source driver/mesa is installed.

With amd HD 4200 graphics chip: There was no webgl after updating from 60.9esr to 68.2.0esr on debian, and from debian standard repo. After setting webgl.force-enabled true, webgl1 works, but no webgl2. WebGL creation failed: Refused to create WebGL2 context because of blacklist entry: FEATURE_FAILURE_OLD_FGLRX GPU: GPU #1 Active Yes Description Gallium 0.4 on AMD RS880 (DRM 2.49.0 / 4.9.0-11-amd64, LLVM 3.9.1) Vendor ID 0x1002 Device ID 0x9710 Driver Vendor mesa/r600 Driver Version 13.0.6.0 RAM 256MB The ff tarball from mozilla org extracted to /opt shows same behaviour. It should work, but it seems to be looking for fglrx when open source driver/mesa is installed.
引用
b.e.wselim 0 個解決方法 1 個答案

basic search everything

basic search everything
這篇文章有幫助嗎?
引用
My_Cheese_Is_Slippin'
  • Top 10 Contributor
93 個解決方法 1023 個答案

Check these entries in about:config

webgl.disabled = False webgl.enable-webgl2 = True webgl.force-enabled = False

Check these entries in about:config webgl.disabled = False webgl.enable-webgl2 = True webgl.force-enabled = False
這篇文章有幫助嗎?
引用

提出問題者

'webgl.force-enabled 'is set to true. When set to false, there is no webgl whatsoever. When set to true, webgl 1 works.

These are set as shown (default) webgl.disabled = False webgl.enable-webgl2 = True

'''webgl.force-enabled '' 'is set to true. When set to false, there is no webgl whatsoever. When set to true, webgl 1 works. These are set as shown (default) webgl.disabled = False webgl.enable-webgl2 = True
這篇文章有幫助嗎?
引用
My_Cheese_Is_Slippin'
  • Top 10 Contributor
93 個解決方法 1023 個答案

Apparently, FEATURE_FAILURE_OLD_FGLRX is a failsafe/failure of the AMD fglrx driver.

Apparently, FEATURE_FAILURE_OLD_FGLRX is a failsafe/failure of the AMD fglrx driver.
這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題