搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Blurry text and other elements

  • 12 回覆
  • 2 有這個問題
  • 20 次檢視
  • 最近回覆由 cor-el

more options

Hi everyone.


I have stumbled upon a weird issue and can't seem to solve it - some of the pages I visit seem to be blurry and lack sharpness in general. You can see it all on screenshots attached. This happens in different places, using gmail just as an example. I am currently typing this in a tab next to that gmail one, text and images here are in perfectly good shape.


What I have already done:

- forced my NVidia GPU to work with Firefox since I intially suspected that it might be an integrated Intel GPU that is causing this (I might've done something wrong so if you suspect this might be it - please elaborate on how I could address this);

- double-checked font settings, zoom - all seems to be fine;

- reset ClearText settings;

- checked if this presists on an external monitor - it does.


I am not claiming this just started happening after the last update: I haven't used Firefox for some good time and am now considering switching back. Version is included on screenshots just for reference. I am currently on 70.0 (64-bit).


Any input would be immensly appreciated!


Thanks in advance.


P.S.: difference is clear if you open screenshots in separate tabs and switch between them, kinda hard to see it when embedded here =)

附加的畫面擷圖

由 hsws 於 修改

所有回覆 (12)

more options

I don't know what to tell you. I looked at your snapshots but can't see any problem.

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1

more options

FredMcD said

On the bottom, turn on Allow Web Sites To Choose Their Own.

Fred,

To my surprise this worked another way around: I have turned off that option and it seems to be in a perfectly good shape now. That said, this also changes how many other websites look, so I would not call this a solution (pardon initial reaction).

If anyone else has any other advice (maybe it is a GPU-related issue after all?) - please don't hold it back.

由 hsws 於 修改

more options

Hey HWSW,

I am also facing issue related to Blurry text and other elements. When i Open my bigbash site I also see some of the elements have issues when I open site in Mozilla Browser.

So Any solution for this

Regards Ann Mariaa

more options

If you choose not to show website fonts then this affects icon fonts that are widely used by website to display special images, so it is best to leave this in the default state and allow website to choose their own fonts (and colors). Also make sure that you haven't accidentally zoomed the page.

You can start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

cor-el said

If you choose not to show website fonts then this affects icon fonts that are widely used by website to display special images, so it is best to leave this in the default state and allow website to choose their own fonts (and colors). Also make sure that you haven't accidentally zoomed the page. You can start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.
  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Thanks a lot

more options

cor-el said

safe mode, default theme, no extensions

@cor-el

Hi and thanks for your input.

I followed all your suggestions and I am afraid this does not help. I shot a short video (1 min long) that showcases what is happening. I recommend opening this in full screen in order to see what I'm talking about:

https://www.youtube.com/watch?v=QjKOEBVcYYc

Any other ideas? =)

由 hsws 於 修改

more options

Bump in case anyone came up with possible solutions.

more options

Gmail uses Roboto. In my Firefox, it seems to suffer at lower zoom levels (see attached screenshot).

Do you notice a similar difference on the Roboto demo page or is it somewhat peculiar to Gmail?

https://fonts.google.com/specimen/Roboto

more options

jscher2000 said

Do you notice a similar difference on the Roboto demo page or is it somewhat peculiar to Gmail?

Hi and thanks for your input. No, sadly the page you linked looks absolutely normal. Do you think this is an issue exclusive to Roboto fonts?

more options

It's good to hear Roboto looks normal for you on the sample page.

What I noticed about Gmail on my Firefox is that it uses peculiar font size and spacing modifications. Such things can introduce "rounding errors" with font smoothing at smaller font sizes. If you zoom Gmail up to 120%, does it look smoother? (Zooming isn't the solution; possibly overriding Google's font rules would help, though.)

more options

jscher2000 said

If you zoom Gmail up to 120%, does it look smoother?

Tried that, issue still persists, at least in Gmail. If what you suspect is indeed the case... man this is an awful move by Google.

Thanks for your input once again.

more options

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.