搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

False security risk messages when internet connection fails

  • 5 回覆
  • 1 有這個問題
  • 43 次檢視
  • 最近回覆由 milesrf

more options

I often get false security risk messages from 69.0.2 if I try to go to a web site while the internet connection has failed. No error code, though.

I suspect that it cannot distinguish error codes from the modem about the failed internet connection from genuine security risks.

Look at the top line of the attached picture for a message about the failed internet connection.

I often get false security risk messages from 69.0.2 if I try to go to a web site while the internet connection has failed. No error code, though. I suspect that it cannot distinguish error codes from the modem about the failed internet connection from genuine security risks. Look at the top line of the attached picture for a message about the failed internet connection.
附加的畫面擷圖

所有回覆 (5)

more options
more options

This is a problem with captive portal services.

If you do not need it then you can disable this feature via the about:config page


Are you using a WIFI connection?

You can check the connection settings.

  • Options/Preferences -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

more options

The security software is not one of those.

This is not a captive portal, not using WiFi, and not using a proxy.

No security warning code is displayed, even if I take extra steps to show more about the "security risk".

Accessing the same site after the internet connection is working properly again displays the web page normally with no security risk message.

more options

I notice the "You must log in to this network before you can access the Internet" notification bar in the screenshots you posted. This bar is shown when Firefox tries to detect a captive portal.

Did you try to set the pref I mentioned above to false on the about:config page?

  • network.captive-portal-service.enabled = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

more options

I did not try it.

However, the lights on the modem indicated an internet connection problem, and other programs using the internet were also unable to make internet connections, so I did not expect any change of Firefox settings to fix the problem.

If I have a similar problem in the future, I'll try to remember your suggestion; however such problems are uncommon.