X
點擊此處開啟此網站的行動版。

技術支援討論區

Themes mysteriously change

已張貼

When I install a theme that distinguishes the active tab by removing the bottom border line, I find that, with no apparent cause, before long that bottom border line will reappear. I can restore the correct appearance by restarting Fx, but pretty soon the fault will resurface. How can I cure this?

When I install a theme that distinguishes the active tab by removing the bottom border line, I find that, with no apparent cause, before long that bottom border line will reappear. I can restore the correct appearance by restarting Fx, but pretty soon the fault will resurface. How can I cure this?
引用

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 32.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

更多資訊

jscher2000
  • Top 10 Contributor
8695 個解決方法 71074 個答案

Usually there's no border line on the bottom side of the active tab. However, if you use an extension that places that tab into a Container, there should be a heavy line color-coded to the relevant container at the bottom of the tab (not completely edge-to-edge). Could that be the issue?

Usually there's no border line on the bottom side of the active tab. However, if you use an extension that places that tab into a Container, there should be a heavy line color-coded to the relevant container at the bottom of the tab (not completely edge-to-edge). Could that be the issue?
這篇文章有幫助嗎?
引用

提出問題者

jscher2000 said

Usually there's no border line on the bottom side of the active tab. However, if you use an extension that places that tab into a Container, there should be a heavy line color-coded to the relevant container at the bottom of the tab (not completely edge-to-edge). Could that be the issue?

I don't think so. I have no extensions involving containers, to the best of my knowledge.The two theme extensions where I've seen this issue are Internet Explorer Blue and SebaArt Blue Dream.

''jscher2000 [[#answer-1254015|said]]'' <blockquote> Usually there's no border line on the bottom side of the active tab. However, if you use an extension that places that tab into a Container, there should be a heavy line color-coded to the relevant container at the bottom of the tab (not completely edge-to-edge). Could that be the issue? </blockquote> I don't think so. I have no extensions involving containers, to the best of my knowledge.The two theme extensions where I've seen this issue are Internet Explorer Blue and SebaArt Blue Dream.

由 Odin3 於 修改

這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17479 個解決方法 157955 個答案

Containers are builtin, you do not need an extension.

Can you attach a screenshot?

Containers are builtin, you do not need an extension. *https://support.mozilla.org/en-US/kb/containers Can you attach a screenshot? *https://support.mozilla.org/en-US/kb/how-do-i-create-screenshot-my-problem *use a compressed image type like PNG or JPG to save the screenshot
這篇文章有幫助嗎?
引用

提出問題者

Here it is, cor-el. The bottom border line for the active tab--this one--should not be there. (This is not too bad with this theme, as the color change is pronounced. The same thing happens however with Internet Blue, which is my preferred theme.)

Here it is, cor-el. The bottom border line for the active tab--this one--should not be there. (This is not too bad with this theme, as the color change is pronounced. The same thing happens however with Internet Blue, which is my preferred theme.)
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8695 個解決方法 71074 個答案

Hi Odin3, I don't get the line when I test in a new profile (see attached). Could it be something in your userChrome.css file?

Hi Odin3, I don't get the line when I test in a new profile (see attached). Could it be something in your userChrome.css file?
這篇文章有幫助嗎?
引用

提出問題者

jscher2000 said

Hi Odin3, I don't get the line when I test in a new profile
The line never appears from the outset, but only later. And restarting Fx will remove the line, but (unfortunately) only temporarily.

Is my userChrome the culprit? I don't know. I would show you my userChrome, but (a) a screenshot won't display the entire file and (b) copy-and-paste distorts the contents.

''jscher2000 [[#answer-1254116|said]]'' <blockquote> Hi Odin3, I don't get the line when I test in a new profile </blockquote>The line never appears from the outset, but only later. And restarting Fx will remove the line, but (unfortunately) only temporarily. Is my userChrome the culprit? I don't know. I would show you my userChrome, but (a) a screenshot won't display the entire file and (b) copy-and-paste distorts the contents.
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8695 個解決方法 71074 個答案

Odin3 said

The line never appears from the outset, but only later. And restarting Fx will remove the line, but (unfortunately) only temporarily.

Can you see a pattern to it? Does it ever happen if you use the built-in Light theme?

Is my userChrome the culprit? I don't know. I would show you my userChrome, but (a) a screenshot won't display the entire file and (b) copy-and-paste distorts the contents.

Yes, please don't paste large amounts of CSS here. You can use a site like Pastebin and share the link back here. Below the box where you paste, there a way to specify that it is CSS, which adds syntax coloring to make it easier to read.

https://pastebin.com/

''Odin3 [[#answer-1254125|said]]'' <blockquote> The line never appears from the outset, but only later. And restarting Fx will remove the line, but (unfortunately) only temporarily.</blockquote> Can you see a pattern to it? Does it ever happen if you use the built-in Light theme? <blockquote>Is my userChrome the culprit? I don't know. I would show you my userChrome, but (a) a screenshot won't display the entire file and (b) copy-and-paste distorts the contents.</blockquote> Yes, please don't paste large amounts of CSS here. You can use a site like Pastebin and share the link back here. Below the box where you paste, there a way to specify that it is CSS, which adds syntax coloring to make it easier to read. https://pastebin.com/
這篇文章有幫助嗎?
引用

提出問題者

jscher2000 said

Can you see a pattern to it? Does it ever happen if you use the built-in Light theme?
Don't know. I'd have to use the theme for a while before the fault appears.
You can use a site like Pastebin and share the link back here.
Thanks for the tip. You can see my userChrome at https://pastebin.com/RmkGLvZ4.
''jscher2000 [[#answer-1254129|said]]'' <blockquote>Can you see a pattern to it? Does it ever happen if you use the built-in Light theme?</blockquote>Don't know. I'd have to use the theme for a while before the fault appears. <blockquote> You can use a site like Pastebin and share the link back here. </blockquote>Thanks for the tip. You can see my userChrome at https://pastebin.com/RmkGLvZ4.
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8695 個解決方法 71074 個答案

有幫助的回覆

You have several CSS rules related to tabs/the tab bar and the title bar. Tabs may appear in the "title bar" when you do not enable the optional Menu Bar or Title Bar. But off the top of my head I can't tell what the cumulative effect of those changes is.

If you are familiar with the Browser Toolbox, you could "inspect" the toolbar area to try and determine where the line comes from (for example, is it a border, or a drop-shadow, or something else). https://developer.mozilla.org/docs/Tools/Browser_Toolbox

You have several CSS rules related to tabs/the tab bar and the title bar. Tabs may appear in the "title bar" when you do not enable the optional Menu Bar or Title Bar. But off the top of my head I can't tell what the cumulative effect of those changes is. If you are familiar with the Browser Toolbox, you could "inspect" the toolbar area to try and determine where the line comes from (for example, is it a border, or a drop-shadow, or something else). https://developer.mozilla.org/docs/Tools/Browser_Toolbox
這篇文章有幫助嗎? 1
引用

提出問題者

Thanks, jscher. Currently my preferred theme [Internet Explorer Blue] is running as it should--no bottom border line. If and when the fault reappears, I'll try your suggestion.

Thanks, jscher. Currently my preferred theme [Internet Explorer Blue] is running as it should--no bottom border line. If and when the fault reappears, I'll try your suggestion.
這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17479 個解決方法 157955 個答案

Does toggling drag space in customize mode make a difference?

This could also be some border or box shadow added to the Navigation Toolbar and not a tab bar issue.

Does toggling drag space in customize mode make a difference? This could also be some border or box shadow added to the Navigation Toolbar and not a tab bar issue.
這篇文章有幫助嗎?
引用

提出問題者

Thanks, cor-el. For now I'm using SebaArt Blue Dream, which so far does not trigger the subject fault. Once the fault reappears I'll try to give you an answer.

Thanks, cor-el. For now I'm using SebaArt Blue Dream, which so far does not trigger the subject fault. Once the fault reappears I'll try to give you an answer.
這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題