X
點擊此處開啟此網站的行動版。

技術支援討論區

Why does firefox block only reddit?

已張貼

No matter what I do firefox blocks www.reddit.com from loading. It just sits thinking with a new tab and a blank page. I have specifically allowed this site in cookies and content blocking. No other sites are blocked or get blocked. Reddit loads fine in Chrome and Edge.

No matter what I do firefox blocks www.reddit.com from loading. It just sits thinking with a new tab and a blank page. I have specifically allowed this site in cookies and content blocking. No other sites are blocked or get blocked. Reddit loads fine in Chrome and Edge.
附加的畫面擷圖
引用

額外的系統細節

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

更多資訊

Wesley Branton
  • Top 10 Contributor
589 個解決方法 4999 個答案

Do you get the same issue when you run Firefox in Safe Mode?

You may also want to try clearing your cookies and site data for Reddit. Sometimes this information can be corrupted and cause issues like these.

Hope this helps.

Do you get the same issue when you [[Troubleshoot Firefox issues using Safe Mode|run Firefox in Safe Mode]]? You may also want to try [[Clear cookies and site data in Firefox|clearing your cookies and site data for Reddit]]. Sometimes this information can be corrupted and cause issues like these. Hope this helps.
這篇文章有幫助嗎? 0
引用

提出問題者

Yes I cleared all site data and cookies but it still won't load. It does work in safe mode.

Why does this happen only for reddit? No other site has this problem.

Yes I cleared all site data and cookies but it still won't load. It does work in safe mode. Why does this happen only for reddit? No other site has this problem.
這篇文章有幫助嗎?
引用
Wesley Branton
  • Top 10 Contributor
589 個解決方法 4999 個答案

If it works fine in Safe Mode and clearing the cookies didn't help, I would guess that it's something to do an add-on that you have installed on Firefox. Go to the about:addons page in Firefox and use trial and error to see what add-on(s) is causing the problem.

TIP: Add-ons that block content (trackers, ads, etc) are the most common culprit.
If it works fine in Safe Mode and clearing the cookies didn't help, I would guess that it's something to do an add-on that you have installed on Firefox. Go to the <code>about:addons</code> page in Firefox and use trial and error to see what add-on(s) is causing the problem. <blockquote>'''TIP:''' Add-ons that block content (trackers, ads, etc) are the most common culprit.</blockquote>
這篇文章有幫助嗎? 0
引用

提出問題者

I have no extensions and only two Plugins. Turning them off didn't help.

I have no extensions and only two Plugins. Turning them off didn't help.
這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17465 個解決方法 157835 個答案

有幫助的回覆

Your screenshot shows that a hidden http:// protocol is used.

Does https://www.reddit.com fail as well?

You can check the connection settings.

  • Options/Preferences -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.


Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

Your screenshot shows that a hidden http:// protocol is used. Does https://www.reddit.com fail as well? You can check the connection settings. *Options/Preferences -> General -> Network: Connection -> Settings If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly. See "Firefox connection settings": *https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History"). Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of involved files. If you revisit a 'forgotten' website then data from that website will be saved once again. *https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox ---- Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems. *https://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *https://www.7tutorials.com/4-ways-boot-safe-mode-windows-10
這篇文章有幫助嗎? 1
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題