搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox displays some wrong letters on my MacBook Pro, even though I let the website pick its own fonts.

  • 17 回覆
  • 2 有這個問題
  • 93 次檢視
  • 最近回覆由 Chris Ilias

more options

Numeral 'nine' displays as 'hyphen', 'semicolon' doesn't display at all, 'x' displays as 'quotation mark'. Using Firefox Quantum 69.0, MacBook Pro (2015) with MacOS 10.14.6. Have run lots of tests with other web sites and browsers, esp. Safari, no such probs with those.

所有回覆 (17)

more options

Hello Vincent,

This sure rings a bell ....

Would you please take a look at this thread :

https://support.mozilla.org/en-US/questions/1268528

I'm keeping my fingers crossed that for you the duplicate copies of Helvetica (like Helvetica Regular and Helvetica Bold) will turn out to be the culprit .....

more options

Thanks for your prompt reply. I checked all the font settings. Nothing irregular there. I noticed the problem with Times New Roman on a web site, and with the mailer "Roundcube" used by my science department. I think that its font is Arial but am not 100% sure. I've never had this bug before, so it might be that it's due to the latest Firefox update, but again I'm not absolutely certain about that. I ran lots of tests with other browsers and text editors, but found no problems there. So I conclude that the known ingredients are: [1] MacBook Pro (2015) with OS 10.14.6 [2] Firefox Quantum 69.0 [3] Some web sites, but especially the Roundcube mailer

It's annoying but not lethal, maybe wait for the next Firefox update release.

Thanks for your note!

more options

I was so hoping that Helvetica would turn out to be the culprit ....  :(

Let's hope that someone else here will come up with the perfect solution for you.

Just in case that doesn't happen within a reasonable amount of time - if you want to, you could file a bug report :

https://bugzilla.mozilla.org/enter_bug.cgi

https://developer.mozilla.org/docs/Mozilla/QA/Bug_writing_guidelines

more options

Just to show that the exact same problem (not just with the number 9) was reported with Chrome (and the problem did not exist in Safari) :

https://www.reddit.com/r/chrome/comments/aqzfd6/number_9_not_working/

Then this on Linux : https://forums.linuxmint.com/viewtopic.php?t=293821

And here, with Chrome, but not with Firefox : https://support.google.com/chrome/thread/2120514?hl=en

I know this doesn't help you right now, but I thought it might give my fellow contributors some ideas.

more options

Vincent Icke said

I noticed the problem with Times New Roman on a web site, and with the mailer "Roundcube" used by my science department. I think that its font is Arial but am not 100% sure.

The actual font being used is something you can investigate using the Inspector tool. Right-click (one-button: Ctrl+click) on text that appears incorrectly and choose Inspect Element. That should open the Developer Tools in the lower part of the tab, open to the Page Inspector, highlighting the element you right-clicked.

On the right side are one or two panes, and there should either be a little Fonts heading, or a triangle with a drop-down list of panes so you can select Fonts. That, finally, shows you the font(s) used for the selected element. So you can see which one(s) might have an issue in your Firefox.

more options

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

more options

Thanks for the suggestions. I had already checked the fonts, which are: Lucida Grande and Lucida Grande Bold for the mailer entries, and Courier for the mail text. All are System fonts, and I had already set Firefox to let the web site pick its own fonts (no interference or smartass tricks on my part). Story continues, thanks anyway!

more options

You can test a specific font in Firefox via a data URI that you paste in the location bar.

data:text/html,%3Cp%20style%3D%22font-family%3ALucida Grande%3Bfont-size%3A25px%3B%22%3EabcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ0123456789%3C%2Fp%3E

data:text/html,%3Cp%20style%3D%22font-family%3ALucida Grande Bold%3Bfont-size%3A25px%3B%22%3EabcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ0123456789%3C%2Fp%3E

data:text/html,%3Cp%20style%3D%22font-family%3ACourier%3Bfont-size%3A25px%3B%22%3EabcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ0123456789%3C%2Fp%3E

more options

Hi Vincent, I'm also using a Macbook Pro with Firefox 69, and have access to an instance of Roundcube, but I'm not experiencing any issues here.

Would you mind sending us a screenshot of what you're seeing? For instructions, see How do I create a screenshot of my problem?.

In the meantime, if you close Firefox, then start Firefox in Safe Mode, does the problem still occur? To start in Safe Mode, go to Help > Restart with Add-ons Disabled.

If the problem does not occur in Safe Mode, then you can disable your extensions one-by-one until you find out which one is causing the problem. For more info, visit Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems.

more options

Here's another "number 9" report with Lucida Grande on Reddit:

https://www.reddit.com/r/firefox/comments/d2rk98/weird_bug_cant_see_the_number_9/

more options

Maybe this LG font isn't a vector font and Firefox can't display all glyphs in some sizes.

more options

You can try to remove the Lucida Grande fonts to see if that works better.

more options

Hi all,

Thanks for your input, much appreciated. I've tried it all but to no avail so far. I'm attaching a screenshot of one of your responses, which isn't from Roundcube, so I presume that the suspicion rests on Firefox only (and on my Mac, alas - and, who knows, on me).

What I find curious is that I've never had this problem before; I noticed it first a few weeks ago but cannot remember if that was straight after a Firefox update.

Jes' tooling on...

more options

Vincent Icke said

What I find curious is that I've never had this problem before; I noticed it first a few weeks ago but cannot remember if that was straight after a Firefox update.

Hello again Vincent,

First of all : thank you for trying everything that was suggested !

As you can see in the links to other threads : you are definately not the only one with this (weird) problem.

I was hoping that the brainboxes around here would come up with a solution, but alas .....

Would you consider filing a bug report, as I suggested earlier ?

more options

I'd like to file a report as late as possible because I don't want to cry wolf. But it seems that filing might be OK now. I will wait until the release of the Catalina MacOS, and see if that solves the problem.

more options

Vincent Icke said

I will wait until the release of the Catalina MacOS, and see if that solves the problem.

Keep us posted, will you please ?

more options

Vincent, If you close Firefox, then start Firefox in Safe Mode, does the problem still occur? To start in Safe Mode, go to Help > Restart with Add-ons Disabled.

If the problem does not occur in Safe Mode, then you can disable your extensions one-by-one until you find out which one is causing the problem. For more info, visit Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems.