X
點擊此處開啟此網站的行動版。

技術支援討論區

Accessibility Issue: In Firefox, why are closed captions NOT displayed in Facebook videos?

已張貼

In Firefox, CC does not display on Facebook videos. CC displays in ALL other browsers - Chrome, MS Edge, & IE for FB videos, but not in FF. To comply with accessibility requirements (ADA), CC must be available on all browsers and platforms. If CC is not available via Firefox, then we won't be able to post any videos to FB any longer - all must have CC available.

In Firefox, CC does not display on Facebook videos. CC displays in ALL other browsers - Chrome, MS Edge, & IE for FB videos, but not in FF. To comply with accessibility requirements (ADA), CC must be available on all browsers and platforms. If CC is not available via Firefox, then we won't be able to post any videos to FB any longer - all must have CC available.

由 zarker 於 修改

引用

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 32.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

更多資訊

jscher2000
  • Top 10 Contributor
8785 個解決方法 71850 個答案

Hi zarker, to save me time searching around for an example video with captions, could you share a link to one that doesn't require being logged in to a FB account? Thanks.

Hi zarker, to save me time searching around for an example video with captions, could you share a link to one that doesn't require being logged in to a FB account? Thanks.
這篇文章有幫助嗎?
引用

提出問題者

Sure.

https://www.facebook.com/DukeComputerScience/videos/vb.174747922544354/454483091944929/

or go to: facebook.com/DukeComputerScience/ and click on Featured video there.

This also affects other Facebook pages - captions do not display: facebook.com/DukeUniv and view any video there

I did a quick check of CNN and USA Today FB videos - each of those sites, the Featured Video had CC when I viewed it in Firefox, but none of the other videos both CNN and USA Today posted had CC available for Firefox.

Please let me know if there is some way to fix this - to get the captions to display in Firefox.

Thanks.

Sure. https://www.facebook.com/DukeComputerScience/videos/vb.174747922544354/454483091944929/ or go to: facebook.com/DukeComputerScience/ and click on Featured video there. This also affects other Facebook pages - captions do not display: facebook.com/DukeUniv and view any video there I did a quick check of CNN and USA Today FB videos - each of those sites, the Featured Video had CC when I viewed it in Firefox, but none of the other videos both CNN and USA Today posted had CC available for Firefox. Please let me know if there is some way to fix this - to get the captions to display in Firefox. Thanks.
這篇文章有幫助嗎?
引用
TyDraniu
  • Top 25 Contributor
334 個解決方法 1890 個答案

No, it works after turning it on.

No, it works after turning it on.
這篇文章有幫助嗎? 0
引用

提出問題者

I don't see any means to turn on CC. No CC option is displayed in Firefox for me. It works in Chrome, IE and Edge.

I don't see any means to turn on CC. No CC option is displayed in Firefox for me. It works in Chrome, IE and Edge.
這篇文章有幫助嗎?
引用
TyDraniu
  • Top 25 Contributor
334 個解決方法 1890 個答案

Just click the video options (the cog wheel). The first switch is for captions.

At least for me.

Just click the video options (the cog wheel). The first switch is for captions. At least for me.
這篇文章有幫助嗎? 0
引用

提出問題者

Are you viewing it in Firefox? When I click on the cog I see only the settings shown in the attached image. When I click on More Video settings, I see what is shown in the second image. No way to turn on CC in Firefox that I can see.

Are you viewing it in Firefox? When I click on the cog I see only the settings shown in the attached image. When I click on More Video settings, I see what is shown in the second image. No way to turn on CC in Firefox that I can see.
這篇文章有幫助嗎?
引用
McCoy
  • Top 10 Contributor
545 個解決方法 5143 個答案

TyDraniu said

Just click the video options (the cog wheel). The first switch is for captions.
At least for me.

Works for me too (of course with Firefox) :

''TyDraniu [[#answer-1251057|said]]'' <blockquote> Just click the video options (the cog wheel). The first switch is for captions.<BR> At least for me. </blockquote> Works for me too (of course with Firefox) :
這篇文章有幫助嗎? 0
引用

提出問題者

I have no option to turn on captions in Firefox! Yes, I have the most recent FF version, so it is a puzzle. And as I wrote above, it is the same - no option in FF - for other Facebook sites' videos as well.

I have no option to turn on captions in Firefox! Yes, I have the most recent FF version, so it is a puzzle. And as I wrote above, it is the same - no option in FF - for other Facebook sites' videos as well.
這篇文章有幫助嗎?
引用
TyDraniu
  • Top 25 Contributor
334 個解決方法 1890 個答案

Try to logout from facebook and then check your video.

Try to logout from facebook and then check your video.
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8785 個解決方法 71850 個答案

It look me a couple clicks to get the controls bar, as though the player needed time to detect the feature or retrieve options, but I do see the option there.

I notice our control bars have a number of differences including icon design and sequence:

Since we both run Windows 10, I wonder whether one of your add-ons could be modifying the video player?

It look me a couple clicks to get the controls bar, as though the player needed time to detect the feature or retrieve options, but I do see the option there. I notice our control bars have a number of differences including icon design and sequence: <img src="https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2019-09-11-07-27-37-4b1433.png" width="500"> Since we both run Windows 10, I wonder whether one of your add-ons could be modifying the video player?
這篇文章有幫助嗎?
引用

提出問題者

Here is a screen shot of Firefox plugins, there are 3.

Here is a screen shot of Firefox plugins, there are 3.
這篇文章有幫助嗎?
引用
McCoy
  • Top 10 Contributor
545 個解決方法 5143 個答案

zarker said

Here is a screen shot of Firefox plugins, there are 3.

How about extensions - do you have any ?

''zarker [[#answer-1251075|said]]'' <blockquote> Here is a screen shot of Firefox plugins, there are 3. </blockquote> How about extensions - do you have any ?
這篇文章有幫助嗎?
引用
McCoy
  • Top 10 Contributor
545 個解決方法 5143 個答案
Probably redundant, but just in case : https://www.facebook.com/help/427723640933279?helpref=uf_permalink
這篇文章有幫助嗎? 0
引用

提出問題者

I actually have 0 (that's zero) extensions in Firefox.

As to the link to FB's how to turn on captions - I had included a screenshot above, indicating that I had indeed already selected the option to always display CC.

I actually have 0 (that's zero) extensions in Firefox. As to the link to FB's how to turn on captions - I had included a screenshot above, indicating that I had indeed already selected the option to always display CC.
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8785 個解決方法 71850 個答案

Taking this hint --

TyDraniu said

Try to logout from facebook and then check your video.

-- since I was viewing the video logged out, I viewed it logged in and did get the control bar you have, but it does have the captions option on the gear menu. (Screenshot attached)

That leads me to wonder whether your Firefox is for some reason not loading the captions file, and therefore FB isn't putting them in the document, and therefore FB isn't showing that option on the gear menu.

When I right-click > Inspect Element on the video, I can see where the captures are being fed into the page. (Second screenshot) Flipping the switch on the gear menu shows or hides the div with the caption, but either way, FB keeps feeding in the captions.

Do you see that on yours or is FB not putting the captions into the page at all?

Taking this hint -- ''TyDraniu [[#answer-1251066|said]]'' <blockquote> Try to logout from facebook and then check your video. </blockquote> -- since I was viewing the video logged out, I viewed it logged in and did get the control bar you have, but it does have the captions option on the gear menu. (Screenshot attached) That leads me to wonder whether your Firefox is for some reason not loading the captions file, and therefore FB isn't putting them in the document, and therefore FB isn't showing that option on the gear menu. When I right-click > Inspect Element on the video, I can see where the captures are being fed into the page. (Second screenshot) Flipping the switch on the gear menu shows or hides the div with the caption, but either way, FB keeps feeding in the captions. Do you see that on yours or is FB not putting the captions into the page at all?
這篇文章有幫助嗎? 0
引用

提出問題者

Again, as posted several hours ago (above): There is no option on the cog for closed captioning whatsoever in Firefox. (There is in Chrome, IE and Edge.) In Firefox, when I click on the cog I see only the settings shown in the attached first screen shot image. When I click on More Video settings, I see what is shown in the second screen shot image. No way to turn on CC in Firefox that I can see.

Again, as posted several hours ago (above): There is no option on the cog for closed captioning whatsoever in Firefox. (There is in Chrome, IE and Edge.) In Firefox, when I click on the cog I see only the settings shown in the attached first screen shot image. When I click on More Video settings, I see what is shown in the second screen shot image. No way to turn on CC in Firefox that I can see.
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8785 個解決方法 71850 個答案

Hi zarker, I think my question wasn't clear.

We know that your player controls are different from ours, but we don't yet know why. Can you try the Page Inspector as I described in my last reply:

jscher2000 said

When I right-click > Inspect Element on the video, I can see where the captures are being fed into the page. (Second screenshot) Flipping the switch on the gear menu shows or hides the div with the caption, but either way, FB keeps feeding in the captions.

Do you see that on yours or is FB not putting the captions into the page at all?

When I asked "do you see that" I meant in the Inspector, the div with the caption text that isn't showing on yours (screenshot).

Hi zarker, I think my question wasn't clear. We know that your player controls are different from ours, but we don't yet know why. Can you try the Page Inspector as I described in my last reply: ''jscher2000 [[#answer-1251112|said]]'' <blockquote> When I right-click > Inspect Element on the video, I can see where the captures are being fed into the page. (Second screenshot) Flipping the switch on the gear menu shows or hides the div with the caption, but either way, FB keeps feeding in the captions. <br><br> Do you see that on yours or is FB not putting the captions into the page at all? </blockquote> When I asked "do you see that" I meant in the Inspector, the div with the caption text that isn't showing on yours ([https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2019-09-11-09-38-56-4fd1f0.png screenshot]).
這篇文章有幫助嗎?
引用

提出問題者

Thank you for your patience. When I right-clicked directly on the video, I could not get to the Code Inspector, it said: Play, Mute, Show video URL, Copy video URL at current time - per first image below.

The second image is the Code Inspector when I right-clicked directly below the video on the page. I don't see captions there, but the inspector said there were 65 occurrences of the word "video". So I highlighted the first one - that's what you see in the screen shot. There are errors displayed, but not sure what they mean.

Thank you for your patience. When I right-clicked directly on the video, I could not get to the Code Inspector, it said: Play, Mute, Show video URL, Copy video URL at current time - per first image below. The second image is the Code Inspector when I right-clicked directly below the video on the page. I don't see captions there, but the inspector said there were 65 occurrences of the word "video". So I highlighted the first one - that's what you see in the screen shot. There are errors displayed, but not sure what they mean.
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8785 個解決方法 71850 個答案

Thanks. If the video gets a blue highlight/fog when you hover over that particular video tag, it's the active one. It looks like the caption data isn't loading, but I don't know why.

The first error refers to FB being framed by a Duke site. If you are directly on FB, I don't see why that would come up.

The second error indicates a file couldn't be retrieved. That could be relevant depending on what "t.update.fbsbx.com" is used for. It seems related to video, but when I view in a private window either logged out or logged in, I don't see any retrievals from it. ??

The third error, no idea how to interpret that, it seems to be written for FB people to understand.

If you click over to the Console tab, are there any earlier or later messages that refer to failure to load files?

Thanks. If the video gets a blue highlight/fog when you hover over that particular video tag, it's the active one. It looks like the caption data isn't loading, but I don't know why. The first error refers to FB being framed by a Duke site. If you are directly on FB, I don't see why that would come up. The second error indicates a file couldn't be retrieved. That could be relevant depending on what "t.update.fbsbx.com" is used for. It seems related to video, but when I view in a private window either logged out or logged in, I don't see any retrievals from it. ?? The third error, no idea how to interpret that, it seems to be written for FB people to understand. If you click over to the Console tab, are there any earlier or later messages that refer to failure to load files?
這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17567 個解決方法 158896 個答案
Can you load this SRT file? view-source:https://scontent-amt2-1.xx.fbcdn.net/v/t39.2093-6/70794525_454504448609460_4157944000872972288_n.srt?_nc_cat=110&_nc_oc=AQnZ6A9cGtXY8_GeZdBzMmiD-a7LYEFIXcOG0rvCZXdgjcGFV45uHd2FywsKShfnUDk&_nc_ht=scontent-amt2-1.xx&oh=0348ae902ad19e11a37d57a2e03dc80b&oe=5DFB6E13 See also the More Video Settings page. *https://www.facebook.com/settings/?tab=videos

由 cor-el 於 修改

這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題