X
點擊此處開啟此網站的行動版。

技術支援討論區

Multiple tabs are opening in reverse sequence - Firefox68

已張貼

Moving up to Firefox 68 from Firefox 54.

I open multiple tabs ("open all tabs") on many web sites. I have them organized alphabetically in subfolders. So, when I click on "open all tabs" I'm used to seeing "A" as the leftmost tab and "Z" as the rightmost tab.

In Firefox 68, I'm seeing "A" as the rightmost tab and "Z" as the leftmost tab.

I know you may think this is a trivial difference, but it slows down my work. I could, I suppose, go through all of my bookmarks and re-order but that pretty much defeats the "sort by name" bookmark function.

I've installed Foxy Tabs, Tab Mix (the web extension) and Tree Tab extensions, so I disabled all three to see if it made a difference. It doesn't. Any idea how to fix this?

Moving up to Firefox 68 from Firefox 54. I open multiple tabs ("open all tabs") on many web sites. I have them organized alphabetically in subfolders. So, when I click on "open all tabs" I'm used to seeing "A" as the leftmost tab and "Z" as the rightmost tab. In Firefox 68, I'm seeing "A" as the rightmost tab and "Z" as the leftmost tab. I know you may think this is a trivial difference, but it slows down my work. I could, I suppose, go through all of my bookmarks and re-order but that pretty much defeats the "sort by name" bookmark function. I've installed Foxy Tabs, Tab Mix (the web extension) and Tree Tab extensions, so I disabled all three to see if it made a difference. It doesn't. Any idea how to fix this?

被選擇的解決方法

Found the offending addon: Open Tabs Next to Current.

Not sure why it changes the display order, but it does. Tabs now load in the correct order.

I really should have tried disabling all of the tab-related extensions in the first place, but since they were pretty much duplicates of the ones I use in FF54, it didn't occur to me.

Thanks to all of you for your help.

從原來的回覆中察看解決方案 0
引用
jscher2000
  • Top 10 Contributor
8692 個解決方法 71041 個答案

Hi RemySecor, I haven't noticed anything like that. Are you opening the bookmarks folder using the

  • Bookmarks Sidebar (Ctrl+B)
  • (optional menu bar) Bookmarks menu
  • (optional) Bookmarks Menu toolbar button menu ()
  • Bookmarks Toolbar
  • something else
Hi RemySecor, I haven't noticed anything like that. Are you opening the bookmarks folder using the * Bookmarks Sidebar (Ctrl+B) * (optional menu bar) Bookmarks menu * (optional) Bookmarks Menu toolbar button menu (<img src="https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/gallery/images/2017-10-14-13-54-51-ad9ea7.png">) * Bookmarks Toolbar * something else
這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17470 個解決方法 157899 個答案

Are you possibly using Sync to sync the bookmarks as this can be a cause of bookmarks getting scrambled?

Are you possibly using Sync to sync the bookmarks as this can be a cause of bookmarks getting scrambled?

由 cor-el 於 修改

這篇文章有幫助嗎?
引用

提出問題者

Not using sync.

Say I have a Folder on the Bookmarks Toolbar called Monday I click on it and and a dropdown menu shows a bunch of other bookmark folders So, say, under Monday there's a folder called News And in the News folder there are 5 papers, arranged alphabetically. In that subfolder, I click on Open All Tabs. In Firefox 54, the tabs are arranged, left to right, A to Z. In Firefox 68, the tabs are arranged, left to right, Z to A.

Not using sync. Say I have a Folder on the Bookmarks Toolbar called Monday I click on it and and a dropdown menu shows a bunch of other bookmark folders So, say, under Monday there's a folder called News And in the News folder there are 5 papers, arranged alphabetically. In that subfolder, I click on Open All Tabs. In Firefox 54, the tabs are arranged, left to right, A to Z. In Firefox 68, the tabs are arranged, left to right, Z to A.
這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17470 個解決方法 157899 個答案

You can probably affect this behavior via the pref that sets where to open a new tab.

  • browser.tabs.insertRelatedAfterCurrent = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

You can probably affect this behavior via the pref that sets where to open a new tab. *browser.tabs.insertRelatedAfterCurrent = false You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *https://support.mozilla.org/en-US/kb/about-config-editor-firefox
這篇文章有幫助嗎?
引用

提出問題者

Toggling to false didn't help. However, I found an extension (sort tabs - advanced) that lets me resort the tabs. It's a pain (as much about Firefox 68 is), but it works.

Toggling to false didn't help. However, I found an extension (sort tabs - advanced) that lets me resort the tabs. It's a pain (as much about Firefox 68 is), but it works.
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8692 個解決方法 71041 個答案

You definitely shouldn't need an add-on for this. If new tabs normally open from left to right, "Open All in Tabs" should open them left to right.

Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

You definitely shouldn't need an add-on for this. If new tabs normally open from left to right, "Open All in Tabs" should open them left to right. Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
這篇文章有幫助嗎?
引用

提出問題者

Oops, just remembered: I downloaded a userChrome.css file from github to put the tab bar under the Bookmarks bar. It didn't occur to me that it would do anything else.

I installed the Atom editor so I could edit the file but, after looking at the code, I honestly can't tell if it contains an ordering sequence or not. Anybody know how Github feels about newbie questions?

Oops, just remembered: I downloaded a userChrome.css file from github to put the tab bar under the Bookmarks bar. It didn't occur to me that it would do anything else. I installed the Atom editor so I could edit the file but, after looking at the code, I honestly can't tell if it contains an ordering sequence or not. Anybody know how Github feels about newbie questions?
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8692 個解決方法 71041 個答案

I don't think style rules to change the vertical order of toolbars should affect where tabs open. Firefox should march down the list of bookmarks in the folder and open them one after another and each new tab should open at the end of the bar.

Unless the style rules are doing something very peculiar like reversing the order of the tabs somehow. But if you open links in new tabs, they presumably open in the expected location at the right end of the bar?

I don't think style rules to change the vertical order of toolbars should affect where tabs open. Firefox should march down the list of bookmarks in the folder and open them one after another and each new tab should open at the end of the bar. Unless the style rules are doing something ''very'' peculiar like reversing the order of the tabs somehow. But if you open links in new tabs, they presumably open in the expected location at the right end of the bar?
這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17470 個解決方法 157899 個答案

Did you check both browser.tabs.insert prefs?

  • browser.tabs.insertAfterCurrent
  • browser.tabs.insertRelatedAfterCurrent
Did you check both <b>browser.tabs.insert</b> prefs? *browser.tabs.insertAfterCurrent *browser.tabs.insertRelatedAfterCurrent
這篇文章有幫助嗎?
引用

提出問題者

Re browser.tabs.insert - tried setting both to false, both to true, one to false, one to true. No difference.

If I open a new tab, it does open to the right of my current tab

Re browser.tabs.insert - tried setting both to false, both to true, one to false, one to true. No difference. If I open a new tab, it does open to the right of my current tab
這篇文章有幫助嗎?
引用

提出問題者

I've reviewed the userChrome.css file. I'm not a programmer (well, not in current languages), but there doesn't seem to be anything in the file related to the order that tabs are opened.

I'm baffled. The add-on gives me a workaround, but it is irritating to use because there is no way to set a default option. (I do think the add-on's differing sort options is a very nice feature.)

I've reviewed the userChrome.css file. I'm not a programmer (well, not in current languages), but there doesn't seem to be anything in the file related to the order that tabs are opened. I'm baffled. The add-on gives me a workaround, but it is irritating to use because there is no way to set a default option. (I do think the add-on's differing sort options is a very nice feature.)
這篇文章有幫助嗎?
引用

提出問題者

So, I wondered it it might have anything to do with the "sort by name" option. So I unsorted a subfolder. Clicked on "sort by name". It did. But, in Firefox54 when I click on "sort by name" it shows a checkmark when it is on and no checkmark when it is off. That's not happening in Firefox 68 (now updated to 68.02).

Is that standard behavior or not?

So, I wondered it it might have anything to do with the "sort by name" option. So I unsorted a subfolder. Clicked on "sort by name". It did. But, in Firefox54 when I click on "sort by name" it shows a checkmark when it is on and no checkmark when it is off. That's not happening in Firefox 68 (now updated to 68.02). Is that standard behavior or not?
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8692 個解決方法 71041 個答案

RemySecor said

So, I wondered it it might have anything to do with the "sort by name" option. So I unsorted a subfolder. Clicked on "sort by name". It did. But, in Firefox54 when I click on "sort by name" it shows a checkmark when it is on and no checkmark when it is off. That's not happening in Firefox 68 (now updated to 68.02). Is that standard behavior or not?

The built-in Sort By Name function is a one-time command. There is no checkmark because Firefox will continue to add new bookmarks to the end of the list. If you have a check mark next to Sort By Name in Firefox 54, that's probably been modified by an extension.

''RemySecor [[#answer-1248406|said]]'' <blockquote> So, I wondered it it might have anything to do with the "sort by name" option. So I unsorted a subfolder. Clicked on "sort by name". It did. But, in Firefox54 when I click on "sort by name" it shows a checkmark when it is on and no checkmark when it is off. That's not happening in Firefox 68 (now updated to 68.02). Is that standard behavior or not? </blockquote> The built-in Sort By Name function is a one-time command. There is no checkmark because Firefox will continue to add new bookmarks to the end of the list. If you have a check mark next to Sort By Name in Firefox 54, that's probably been modified by an extension.
這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17470 個解決方法 157899 個答案

Did you disable the extension when you did the testing with the preferences on about:config?

Did you disable the extension when you did the testing with the preferences on about:config?
這篇文章有幫助嗎?
引用

提出問題者

jsher2000: In Firefox54, the default when adding a bookmark is to add it at the "top" of the folder. It gets added in sort order only if I have sort order checked. Note: I do have an "add bookmark here" extension in Firefox54.

Are you saying that in Firefox68, the default is to add in sort order?

I'm going to try disabling every extension I have related to bookmarks or tabs and see if that makes any difference in 68. Will report back.

jsher2000: In Firefox54, the default when adding a bookmark is to add it at the "top" of the folder. It gets added in sort order only if I have sort order checked. Note: I do have an "add bookmark here" extension in Firefox54. Are you saying that in Firefox68, the default is to add in sort order? I'm going to try disabling every extension I have related to bookmarks or tabs and see if that makes any difference in 68. Will report back.
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8692 個解決方法 71041 個答案

RemySecor said

In Firefox54, the default when adding a bookmark is to add it at the "top" of the folder.

Hmm, that's never how mine has worked. Always added at the bottom.

Are you saying that in Firefox68, the default is to add in sort order?

No, the default is still to add at the bottom.

''RemySecor [[#answer-1248650|said]]'' <blockquote> In Firefox54, the default when adding a bookmark is to add it at the "top" of the folder. </blockquote> Hmm, that's never how mine has worked. Always added at the bottom. <blockquote>Are you saying that in Firefox68, the default is to add in sort order?</blockquote> No, the default is still to add at the bottom.
這篇文章有幫助嗎?
引用

選擇的解決方法

Found the offending addon: Open Tabs Next to Current.

Not sure why it changes the display order, but it does. Tabs now load in the correct order.

I really should have tried disabling all of the tab-related extensions in the first place, but since they were pretty much duplicates of the ones I use in FF54, it didn't occur to me.

Thanks to all of you for your help.

Found the offending addon: Open Tabs Next to Current. Not sure why it changes the display order, but it does. Tabs now load in the correct order. I really should have tried disabling all of the tab-related extensions in the first place, but since they were pretty much duplicates of the ones I use in FF54, it didn't occur to me. Thanks to all of you for your help.
這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題