X
點擊此處開啟此網站的行動版。

技術支援討論區

dates and time not displaying correctly

已張貼

running firefox dev ed rev 69.0b14

i run prestashop ecommerce on a hosting server. but when i use admin on my PC, i have an application that displays 2 sets of date/time, ie start and end.

however the 1st displayed time shows it correctly ie 26/08/2019 00:00 but the 2nd displayed time it is shown as 1566860340

the coding that generates this seems to be correct, check attached image.

any ideas please, as when I use any other browser it displays date and time correctly.

running firefox dev ed rev 69.0b14 i run prestashop ecommerce on a hosting server. but when i use admin on my PC, i have an application that displays 2 sets of date/time, ie start and end. however the 1st displayed time shows it correctly ie 26/08/2019 00:00 but the 2nd displayed time it is shown as 1566860340 the coding that generates this seems to be correct, check attached image. any ideas please, as when I use any other browser it displays date and time correctly.
附加的畫面擷圖

被選擇的解決方法

Error message in Web Console?

unreachable code after return statement cp-admin-popup-builder.js:319:2

However I found that the cause of the problem was down to 1 out of 3 plugins. Could not isolate which of the 3, so all 3 are now disabled.

All works fine now.

I am not going to think as to why this has caused the problem, as its OK.

Thanks

從原來的回覆中察看解決方案 0
引用

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 32.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

更多資訊

cor-el
  • Top 10 Contributor
  • Moderator
17422 個解決方法 157414 個答案

有幫助的回覆

It looks that the JavaScript code that should process the date-value attribute isn't working in that second input field.

date-value="1566860340" => Mon 26 Aug 2019 22:59:00 GMT
date-value="1566774000" => Sun 25 Aug 2019 23:00:00 GMT

Are there any messages related to this issue in the Web Console?

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content.

  • click the shield icon for more details and possibly disable the protection

You can check the Web Console about what content is blocked

It looks that the JavaScript code that should process the date-value attribute isn't working in that second input field. date-value="1566860340" => Mon 26 Aug 2019 22:59:00 GMT date-value="1566774000" => Sun 25 Aug 2019 23:00:00 GMT Are there any messages related to this issue in the Web Console? *"3-bar" menu button or Tools -> Web Developer *https://developer.mozilla.org/en-US/Tools/Web_Console If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content. *make sure your extensions and filters are updated to the latest version *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content. *click the shield icon for more details and possibly disable the protection You can check the Web Console about what content is blocked *"3-bar" menu button or Tools -> Web Developer *https://support.mozilla.org/en-US/kb/content-blocking
這篇文章有幫助嗎? 1
引用

選擇的解決方法

Error message in Web Console?

unreachable code after return statement cp-admin-popup-builder.js:319:2

However I found that the cause of the problem was down to 1 out of 3 plugins. Could not isolate which of the 3, so all 3 are now disabled.

All works fine now.

I am not going to think as to why this has caused the problem, as its OK.

Thanks

Error message in Web Console? unreachable code after return statement cp-admin-popup-builder.js:319:2 However I found that the cause of the problem was down to 1 out of 3 plugins. Could not isolate which of the 3, so all 3 are now disabled. All works fine now. I am not going to think as to why this has caused the problem, as its OK. Thanks
這篇文章有幫助嗎? 0
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題