搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I prevent recent history from appearing in my bookmarks bar?

more options

Recent history keeps appearing in my bookmarks bar. I delete the items one by one but then new ones appear. How do I prevent this?

所有回覆 (20)

more options

Thats should not happen. try to restart firefox with addons disabled and see if that problem exists while addons has been disabled (you can do it via `about:profiles` page) if its keep happening, try via `about:profiles`to create a new profile and set it as default. (and restart firefox right after)

more options

All recent items like Recent History and Recently Bookmarked are not real folders, but are so called smart folders that show the result of a query in a list. If you remove an item then the next item will appear. If this is an item on the Bookmarks Toolbar then you can simply remove this folder. Firefox also shows these recent items in the Library toolbar button drop-down list (bookmarks, history). These items can't be easily hidden.

more options

Eldar Value said

Thats should not happen. try to restart firefox with addons disabled and see if that problem exists while addons has been disabled (you can do it via `about:profiles` page) if its keep happening, try via `about:profiles`to create a new profile and set it as default. (and restart firefox right after)

Which addon did you have in mind?

more options

cor-el said

All recent items like Recent History and Recently Bookmarked are not real folders, but are so called smart folders that show the result of a query in a list. If you remove an item then the next item will appear. If this is an item on the Bookmarks Toolbar then you can simply remove this folder. Firefox also shows these recent items in the Library toolbar button drop-down list (bookmarks, history). These items can't be easily hidden.

I guess this just doesn't seem to me to be consistent with deleting your history when you shut down the browser. I got in my head somewhere that Firefox was doing that with the "never remember history" setting and "delete cookies and site data when firefox is closed".

more options

So, ultimately no remediation for the condition? It is not very consistent with protecting privacy to have your recent browsing history writ large at the top of the browser.

more options

Where is it appearing? These are the terms I use for the different bars:

Bookmarks may be listed on either:

  • Library menu toolbar button () -- especially "Recently Bookmarked" list
  • optional Bookmarks menu toolbar button ()
  • Bookmarks Toolbar
  • Bookmarks Sidebar
  • optional menu bar > Bookmarks menu

History may be listed on either:

  • Library menu toolbar button () -- especially "Recent Highlights" list
  • optional History menu toolbar button (looks like a clock)
  • optional menu bar > History menu
more options

The history is appearing in the optional book marks tool bar.

Which I would like to use for book marks frequently used but not for the crowd of book marks in the library book marks.

But recently visited sites are crowding into the optional book marks tool bar un-invited. I have not found a remediation other than deleting them individually as they arrive.

more options

Hmm, something is very wrong if every site you visit is automatically bookmarked onto the Bookmarks Toolbar. First, Firefox doesn't automatically bookmark sites. Second, any list like "Most Visited" should be a folder-like drop-down and not directly on the bar.

Did you test whether history items are saved as bookmarks in Firefox's Safe Mode? See: Troubleshoot Firefox issues using Safe Mode. I think you asked a question about that suggestion but maybe didn't try it:

terryholland001 said

Eldar Value said
Thats should not happen. try to restart firefox with addons disabled and see if that problem exists while addons has been disabled (you can do it via `about:profiles` page) if its keep happening, try via `about:profiles`to create a new profile and set it as default. (and restart firefox right after)

Which addon did you have in mind?


You might also try a toolbar layout reset to see whether that restores the normal functioning of the Bookmarks Toolbar. There's a "Restore Defaults" button at the bottom center of the Customize panel: Customize Firefox controls, buttons and toolbars.

more options

It is not every site. I haven't seen this happen running in safe mode. The book marks tool bar is not present in safe mode.

more options

Can you attach a screenshot?

more options

For what it is worth, screen shot. Book mark tool bar is reset and has no book marks. Despite that a search I did earlier this weekend appears in my book marks tool bar. I can delete it but eventually another unrequested bit if history will appear in the book mark tool bar.

more options

terryholland001 said

I haven't seen this happen running in safe mode. The book marks tool bar is not present in safe mode.

You could turn on the Bookmarks Toolbar in Safe Mode if it would help with investigating further. For example:

  • right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button)
  • (menu bar) View > Toolbars
    On Windows, tap the Alt key to activate the menu bar temporarily.
  • in Customize mode > Toolbars button (see: Customize Firefox controls, buttons and toolbars)

To turn on the Bookmarks Toolbar, Menu Bar, or other bars, click it on the list.

more options

Your System Details list shows the "Trend Micro Toolbar" extension. Maybe this extension is adding the toolbar with the recent visits.

If it works in Safe Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via one of these:

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit
more options

I turned off trend micro tool bar and restarted all the fire fox windows. I picked up another rider in the book mark bar even still. It seems to pick them randomly.

more options

Try AdwCleaner tool from malwarebytes,

more options

Eldar Value said

Try AdwCleaner tool from malwarebytes,

Did not find any malware. Trend micro keeps complaining about the missing tool bar. Adding it back in to see if book marks keep coming back. Though I think the tool bar is just a little symbol on the upper left, not an actual bar until you expand it.

more options

jscher2000 said

Hmm, something is very wrong if every site you visit is automatically bookmarked onto the Bookmarks Toolbar. First, Firefox doesn't automatically bookmark sites. Second, any list like "Most Visited" should be a folder-like drop-down and not directly on the bar. Did you test whether history items are saved as bookmarks in Firefox's Safe Mode? See: Troubleshoot Firefox issues using Safe Mode. I think you asked a question about that suggestion but maybe didn't try it: terryholland001 said
Eldar Value said
Thats should not happen. try to restart firefox with addons disabled and see if that problem exists while addons has been disabled (you can do it via `about:profiles` page) if its keep happening, try via `about:profiles`to create a new profile and set it as default. (and restart firefox right after)

Which addon did you have in mind?


You might also try a toolbar layout reset to see whether that restores the normal functioning of the Bookmarks Toolbar. There's a "Restore Defaults" button at the bottom center of the Customize panel: Customize Firefox controls, buttons and toolbars.

I'm not sure where "Hmm, something is very wrong if every site you visit is automatically bookmarked onto the Bookmarks Toolbar" came from as I never indicated that every site I visit is automatically bookmarked into the book marks tool bar.

Removing trend micro tool bar did not help and in any case despite the name the trend micro tool bar does not appear as a tool bar like the fire fox tool bars. Restoring defaults hasn't made a difference either as eventually something I did not book mark appeared in the bookmarks tool bar.

more options

Normally, the only way a bookmark could get to the Bookmarks Toobar is if you put it there yourself. Ctrl+d adds to Other Bookmarks by default; if you right-click > Bookmark Page on a History entry, it goes to the Bookmarks Menu by default. To get something on the Bookmarks Toolbar, you usually need to change the selected folder in an add bookmark dialog or drag and drop a URL there. So it's very difficult to explain items appearing on the bar with no action by you.

Have we ruled out all of your extensions as potential culprits?

You also could consider running the "Verify Integrity" function to spruce up the Places database in case there's some kind of curable corruption. That's here:

Open Firefox's Troubleshooting Information page using any of these methods:

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Near the bottom, there is a section titled Places Database -- that's the file which stores history and bookmarks. Click the button labeled Verify Integrity. There may be a 10-15 second delay before results appear.

If all is well, the report that appears below the button should start with:

> Task: checkIntegrity
+ The places.sqlite database is sane
+ The favicons.sqlite database is sane

Does everything there look good? Any improvement over time?

more options

"Have we ruled out all of your extensions as potential culprits?" Is kinda open ended and vague. I've asked for advice more specific. Trend micro tool bar doesn't seem to make a difference. Running in safe mode or resetting to defaults only hides the book marks tool bar. Neither changes anything if I un-hide the book marks tool bar. Do those actions rule out extensions as potential culprits?

Eventually something will appear in my otherwise blank (these days) book marks tool bar as I remove all the book marks I can find just in case.

Places Database Integrity

> Task: checkIntegrity + The places.sqlite database is sane + The favicons.sqlite database is sane

more options

Is it possible that you're accidentally clicking the star icon, or that you're accidentally pressing ctrl-D?

Either of these would be adding a bookmark automatically - though they should only be adding to the "Other Bookmarks" folder.

Can you also go into "Show all bookmarks" and look at the folder structure under "All bookmarks" and makes sure it looks sane. You should have three or four folders under "All Bookmarks" - "Bookmarks Toolbar", "Bookmarks Menu", "Other Bookmarks" and maybe "Mobile Bookmarks". Underneath those, you may have more folders that you've created.

  1. 1
  2. 2