X
點擊此處開啟此網站的行動版。

技術支援討論區

Firefox 68 Mac, can't start w/profile from command line

已張貼

Long-time Firefox user with several profiles defined via ProfileManager. Have several AppleScript apps that start firefox-bin with "-P profilename" to start Firefox with the named profile (see <https://spf13.com/post/managing-multiple-firefox-profiles-in-os-x/> for a description of how this is set up). They no longer work. Starting the profiles from a shell prompt also does not seem to work, at best it opens a new Firefox window in each currently-open Firefox profile. Have tried -P with profile name (profile name quoted), --profile with path to profile's "Root Directory", --profile with path to profile's "Local Directory", pathnames quoted if necessary; all of the above with --new-instance. No joy. What am I missing?

Long-time Firefox user with several profiles defined via ProfileManager. Have several AppleScript apps that start firefox-bin with "-P profilename" to start Firefox with the named profile (see <https://spf13.com/post/managing-multiple-firefox-profiles-in-os-x/> for a description of how this is set up). They no longer work. Starting the profiles from a shell prompt also does not seem to work, at best it opens a new Firefox window in each currently-open Firefox profile. Have tried -P with profile name (profile name quoted), --profile with path to profile's "Root Directory", --profile with path to profile's "Local Directory", pathnames quoted if necessary; all of the above with --new-instance. No joy. What am I missing?

被選擇的解決方法

There were a few changes here recently, you might want to try `firefox -P profile -no-remote`

從原來的回覆中察看解決方案 2
引用

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 32.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:68.0) Gecko/20100101 Firefox/68.0

更多資訊

提出問題者

Additional information: One way profiles do work: about:profiles, and "Launch profile in new browser". So I think my profile definitions are in order, it's getting them going via firefox-bin command-line arguments that is broken.

Additional information: One way profiles do work: about:profiles, and "Launch profile in new browser". So I think my profile definitions are in order, it's getting them going via firefox-bin command-line arguments that is broken.
這篇文章有幫助嗎? 0
引用
cor-el
  • Top 10 Contributor
  • Moderator
17534 個解決方法 158559 個答案

Does it work if you use firefox -P "profile" instead of firefox-bin ?

Does it work if you use firefox -P "profile" instead of firefox-bin ?
這篇文章有幫助嗎?
引用

提出問題者

It works the same way: I get a new window for each in-use profile.

It works the same way: I get a new window for each in-use profile.
這篇文章有幫助嗎?
引用

提出問題者

Running this from the AppleScript again, I am reminded that it put up a dialog, "The command exited with a non-zero status", and that if I echo $? after trying the same command from a shell prompt the status is 1. (I also get the new window open under the in-use profile, as opposed to the profile I wanted to launch).

Running this from the AppleScript again, I am reminded that it put up a dialog, "The command exited with a non-zero status", and that if I echo $? after trying the same command from a shell prompt the status is 1. (I also get the new window open under the in-use profile, as opposed to the profile I wanted to launch).
這篇文章有幫助嗎?
引用
Standard8 35 個解決方法 196 個答案

選擇的解決方法

There were a few changes here recently, you might want to try `firefox -P profile -no-remote`

There were a few changes here recently, you might want to try `firefox -P profile -no-remote`
這篇文章有幫助嗎? 2
引用

提出問題者

That seems to work well enough to get the AppleScript method going again. Thanks! (Might be nice if it were in the usage message.)

That seems to work well enough to get the AppleScript method going again. Thanks! (Might be nice if it were in the usage message.)
這篇文章有幫助嗎?
引用
kat5 0 個解決方法 1 個答案

I'm having the same issue. I have two profiles (work and personal) which I usually leave open; the -P flag seems to be ignored and instead any URL I pass in is opened in both profiles. `-no-remote` doesn't work for me... it either brings up an error complaining that the profile is already open, or it just hangs. All I want is some way to open a link in a specific profile (e.g. from an Alfred shortcut).

I'm having the same issue. I have two profiles (work and personal) which I usually leave open; the -P flag seems to be ignored and instead any URL I pass in is opened in both profiles. `-no-remote` doesn't work for me... it either brings up an error complaining that the profile is already open, or it just hangs. All I want is some way to open a link in a specific profile (e.g. from an Alfred shortcut).
這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題