X
點擊此處開啟此網站的行動版。

技術支援討論區

DOH potential security risk message

已張貼

When trying DNS over https in in a neetwork that uses googles DNS 8.8.8.8 and 8.8.4.4 I configured FF as follows set network.trr.mode=3 set network.trr.bootstarpaddress=8.8.8.8 set network.trr.uri=https://dns.google/dns-query

Then I went to https://1.1.1.1/help knowing full well that I am use googles DOH and not cloudflare expecting cloudflare web site to tell me I am not using there services with results being all negative.

Instead FF reported that "Warning potential security problem ahead". See enclosed If I am using Googles DOH values and I go to a cloudgflare site why would FF flag the site as a security risk? Keeping in mind FF appears to be working for other sites in the DOH configuration for Google with no visible problems.

When trying DNS over https in in a neetwork that uses googles DNS 8.8.8.8 and 8.8.4.4 I configured FF as follows set network.trr.mode=3 set network.trr.bootstarpaddress=8.8.8.8 set network.trr.uri=https://dns.google/dns-query Then I went to https://1.1.1.1/help knowing full well that I am use googles DOH and not cloudflare expecting cloudflare web site to tell me I am not using there services with results being all negative. Instead FF reported that "Warning potential security problem ahead". See enclosed If I am using Googles DOH values and I go to a cloudgflare site why would FF flag the site as a security risk? Keeping in mind FF appears to be working for other sites in the DOH configuration for Google with no visible problems.
附加的畫面擷圖

被選擇的解決方法

The network is a library in Canada, Toronto area. I didn't believe that the library would filter a specific 1.1.1.1 address and not other DOH sites. But It appears that is the case because I tried another device on that network and then I tried it on another public network and it worked.

I will have to put this question to the Library as to why the filter? Not that I expect an answer

從原來的回覆中察看解決方案 0
引用
jscher2000
  • Top 10 Contributor
8634 個解決方法 70618 個答案

Can you click the Advanced button for more information about why the certificate verification failed?

Can you click the Advanced button for more information about why the certificate verification failed?
這篇文章有幫助嗎? 1
引用
cor-el
  • Top 10 Contributor
  • Moderator
17413 個解決方法 157295 個答案

有幫助的回覆

1.1.1.1 would normally redirect you to a server in your vicinity using anycast, so there might be a domain mismatch for the certificate after the redirect.

1.1.1.1 would normally redirect you to a server in your vicinity using anycast, so there might be a domain mismatch for the certificate after the redirect.
這篇文章有幫助嗎? 1
引用

有幫助的回覆

The certificate failed because it was not HTTPs so the connection was not secure. But strangely I was not able to connect using CloudFlare DOh value only with Googles DOH value shown in this web site "https://github.com/curl/curl/wiki/DNS-over-HTTPS#publicly-available-servers"

The certificate failed because it was not HTTPs so the connection was not secure. But strangely I was not able to connect using CloudFlare DOh value only with Googles DOH value shown in this web site "https://github.com/curl/curl/wiki/DNS-over-HTTPS#publicly-available-servers"
這篇文章有幫助嗎? 1
引用
Eldar Value 4 個解決方法 45 個答案

Those settings are working:

about:config?filter=network.trr

network.trr.bootstrapAddress > 8.8.8.8 network.trr.confirmationNS > dns.google network.trr.credentials > dns.google network.trr.disable-ECS > false network.trr.early-AAAA > true network.trr.mode > 3 network.trr.uri > https://dns.google.com/experimental

after set, restart firefox and enjoy :)

'''Those settings are working:''' about:config?filter=network.trr network.trr.bootstrapAddress > 8.8.8.8 network.trr.confirmationNS > dns.google network.trr.credentials > dns.google network.trr.disable-ECS > false network.trr.early-AAAA > true network.trr.mode > 3 network.trr.uri > https://dns.google.com/experimental '''after set, restart firefox and enjoy :)'''
這篇文章有幫助嗎? 1
引用

提出問題者

I have already stated the settings I used. I have already stated that google DOH worked.

Why does cloudflare the default used by FF not work?

I have already stated the settings I used. I have already stated that google DOH worked. Why does cloudflare the default used by FF not work?
這篇文章有幫助嗎? 1
引用
philipp
  • Top 25 Contributor
  • Moderator
5287 個解決方法 23362 個答案

again, please click on advanced on the error page to see what's the error code and possibly inspect the failing certificate...

again, please click on advanced on the error page to see what's the error code and possibly inspect the failing certificate...
這篇文章有幫助嗎?
引用

提出問題者

You dont seem to understand. No certificate was obtained as shown in my enclosure.

Why would cloudflare site be blocked and not google? Why is it I could not get through to cloudflare when google DOH was working?

You dont seem to understand. No certificate was obtained as shown in my enclosure. Why would cloudflare site be blocked and not google? Why is it I could not get through to cloudflare when google DOH was working?
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8634 個解決方法 70618 個答案

Hi Mace2, on the error page, there is an Advanced button -- the gray one next to the large blue one. That Advanced button opens a panel with more technical information about the problem. I don't think you can diagnose the issue without that.

Hi Mace2, on the error page, there is an Advanced button -- the gray one next to the large blue one. That Advanced button opens a panel with more technical information about the problem. I don't think you can diagnose the issue without that.
這篇文章有幫助嗎?
引用

提出問題者

Enclosed is the advance tab. Keep in mind the google DOH values are set and work. But the cloudflare web site 1.1.1.1/help did not work

Enclosed is the advance tab. Keep in mind the google DOH values are set and work. But the cloudflare web site 1.1.1.1/help did not work
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8634 個解決方法 70618 個答案

I'm looking at the domains of the certificate provided to Firefox in your screenshot and I wonder whether your service provider may not permit IP address URLs, or at least this one. Otherwise, why would that certificate be showing up?

I'm looking at the domains of the certificate provided to Firefox in your screenshot and I wonder whether your service provider may not permit IP address URLs, or at least this one. Otherwise, why would that certificate be showing up?
這篇文章有幫助嗎?
引用

選擇的解決方法

The network is a library in Canada, Toronto area. I didn't believe that the library would filter a specific 1.1.1.1 address and not other DOH sites. But It appears that is the case because I tried another device on that network and then I tried it on another public network and it worked.

I will have to put this question to the Library as to why the filter? Not that I expect an answer

The network is a library in Canada, Toronto area. I didn't believe that the library would filter a specific 1.1.1.1 address and not other DOH sites. But It appears that is the case because I tried another device on that network and then I tried it on another public network and it worked. I will have to put this question to the Library as to why the filter? Not that I expect an answer
這篇文章有幫助嗎? 0
引用
jscher2000
  • Top 10 Contributor
8634 個解決方法 70618 個答案

Do you think they filter 1.1.1.1 in particular, or filter IP address URLs in general?

Do you think they filter 1.1.1.1 in particular, or filter IP address URLs in general?
這篇文章有幫助嗎?
引用

提出問題者

I think a greater question is why Cloidflare DOH was filtered over Google DOH

I think a greater question is why Cloidflare DOH was filtered over Google DOH
這篇文章有幫助嗎? 0
引用
jscher2000
  • Top 10 Contributor
8634 個解決方法 70618 個答案

So if you aren't using DOH you can access https://1.1.1.1/help on that same network?

So if you aren't using DOH you can access https://1.1.1.1/help on that same network?
這篇文章有幫助嗎?
引用

提出問題者

I am using DOH. I am using googles DOH server. The librayr is filtering only cloudflare DOH.

the configuration network.trr.mode=3 ensures only DOH is being used.

I am using DOH. I am using googles DOH server. The librayr is filtering only cloudflare DOH. the configuration network.trr.mode=3 ensures only DOH is being used.
這篇文章有幫助嗎? 0
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題