搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

no animation of photos in own created website, no slideshow with pictures

  • 27 回覆
  • 1 有這個問題
  • 142 次檢視
  • 最近回覆由 McCoy

more options

what shall I do? please help

由 cor-el 於 修改

被選擇的解決方法

The website is working now, have a look. It was a bug in the configuration of the website software. You could make a cross, whether the slidershow should appear by accident or as an automatic playback. I then checked the automatic playback. Now it runs under firefox, you can see all the photos. There are no continuation arrows, but the photos are all visible. I'm very satisfied. Greetings

從原來的回覆中察看解決方案 👍 0

所有回覆 (20)

more options

Hello ute.buse,

Would you please take a look at this :

https://developer.mozilla.org/en-US/docs/Web/CSS/CSS_Animations/Using_CSS_animations

Would you consider giving this add-on a try (?) :

https://addons.mozilla.org/en-US/firefox/addon/media-slideshow/

more options

not okay. I cannot see the fotos with a slidershow. Look: fewo-buse-greetsiel.de

more options

ute.buse said

not okay. I cannot see the fotos with a slidershow. Look: fewo-buse-greetsiel.de

I see what you mean (should have asked you to provide a link to your website).

Question though : does it work when you use another browser ?

If so : would you try this please :
Clear the Firefox cache :
https://support.mozilla.org/en-US/kb/how-clear-firefox-cache

"Remove the cookies" from websites that cause problems :
https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored (scroll down to : "Delete cookies for a single site")


If you use extensions like Adblock Plus, NoScript, Flash Block, Ghostery, then always make sure such extensions do not block (wanted) content.

You could also check your settings here :

https://support.mozilla.org/en-US/kb/content-blocking


If none of the above do the trick, then let's Try Firefox in Safe Mode :

If Firefox is not running : Hold down the Shift key when starting Firefox.

If Firefox is running : 3-bar menu => ' ? ' (at the bottom of the dropdown) => 'Restart with Add-ons disabled'. Then OK the restart. A small dialog should appear. Click 'Start in Safe Mode' ( not 'Refresh' !)

See : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

And : https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems



Just in case this might interest you :

https://www.proteusthemes.com/blog/7-design-tips-improve-slider-images/

由 McCoy 於 修改

more options

No problems here with the slideshow.

The most probable cause is a content blocking extension.

You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content.

You can check the Network Monitor to see if content is blocked or otherwise fails to load.

If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log.

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)
more options

It`s too difficult, the problem isn`t on other browsers, only firefox. Webdisigner and networt I cannot understand. I will take another browser

more options

the follow mistake send my web-konsole: Diese Website verwendet anscheinend einen scroll-verknüpften Positionierungseffekt. Dies könnte mit asynchronem Verschieben (Panning) schlecht zusammenspielen; siehe https://developer.mozilla.org/docs/Mozilla/Performance/ScrollLinkedEffects für weitere Details und nehmen Sie an der Diskussion über damit verbundene Werkzeuge und Funktionen teil! in English: This website apparently uses a scroll-linked positioning effect. This could be bad with asynchronous panning; see https://developer.mozilla.org/docs/Mozilla/Performance/ScrollLinkedEffects for more details and participate in the discussion of related tools and functions!

What can I do?

more options

Are you using any content blocking extensions?

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

In Firefox I can only get the slideshow to work using a finger on my touchscreen - arrows are missing.

I'm not blocking content in any way; disabling hardware acceleration makes no difference.

Arrows are present in Edge and slideshow works just fine.

more options

Then I must live with this problem

more options

ute.buse said

Then I must live with this problem

You shouldn't have to - I think it's script-related, which (unfortunately) I know nothing about ......

I'm going to ask somebody (who might know) to take a look at this.

more options

"In Firefox I can only get the slideshow to work using a finger on my touchscreen - arrows are missing.

I'm not blocking content in any way; disabling hardware acceleration makes no difference.

Arrows are present in Edge and slideshow works just fine."

Exactly my problem

You have many work with me, thank you very much. Every people istn`t so nice. I have konfigurated my website with Incomedia website X5 evolution13. Can this help you? I would be happy

more options

ute.buse said

"I have konfigurated my website with Incomedia website X5 evolution13. Can this help you?

I'm hoping that it will help my fellow contributors - I went to their Help Center, but couldn't find anything related to this particular problem  :(

When it works in other browsers, it should also work in Firefox !

Hopefully my colleagues will come to your rescue - but we're dealing with different time zones, and they may be asleep right now, so please hang in there ......

more options

ute.buse said

This website apparently uses a scroll-linked positioning effect. This could be bad with asynchronous panning; see https://developer.mozilla.org/docs/Mozilla/Performance/ScrollLinkedEffects for more details and participate in the discussion of related tools and functions!
What can I do?

I'm hoping that others will find a clue there (it's mumbo jumbo to me ....)

more options

Here are two screenshots, showing the slideshow with left-right arrow buttons (and I also pulled up the images at the bottom) in Edge, and the same page in Firefox (note the button at the bottom right, where the little hand prompted me to slide using my touchscreen) :

more options

Hi ute.buse, I think you are a little bit stuck here, unless the "Gallery" configuration lets you include BOTH mouse buttons AND touch controls for touchscreen users instead of only including one or the other.


The site uses Modernizr to check for touch event support. Firefox normally shows touch support enabled when the user has a touch screen. There is a preference or two to disable touch event support (first screenshot), and when you switch those, the touch feature stops working. However, Modernizr uses three methods to check for touch event support and Firefox only changes the result for those of those (second screenshot). So this makes the problem worse because now the site thinks touch works and it doesn't work any more. Therefore, I don't suggest changing this setting.

more options

Unless somebody here comes up with a solution, I suggest you contact Incomedia :

https://www.websitex5.com/en/contact-support.php

And maybe give them a link to this thread.

If it works properly in other browsers, it should in Firefox as well (and not just for those who have a touch screen).

more options

Thank you for the answer. That`s right. I wait until wednesday, perhaps I still get results. Then I will ask the kontact of my website software. Thank you for the link.

more options

ute.buse said

Thank you for the answer. That`s right. I wait until wednesday, perhaps I still get results. Then I will ask the kontact of my website software. Thank you for the link.

Will you keep us posted, please  ? I'm really curious about the outcome !

more options

I will do that, that goes without saying. You are a very helpful person

more options

I wanted to say you all that the pictures of my homepage on Firefox are okay. I have no Problem with it, fewo-Buse-Greetsiel.de. The Konfiguration wasn‘t okay. I must also Write in the Gallery : automatic repeat x . thank you for all your help, I‘m so happy

  1. 1
  2. 2