X
點擊此處開啟此網站的行動版。

技術支援討論區

4 Firefox entries in Task manager

已張貼

Firefox 68.0.1 64bit Win 7 Pro:

I have four ' firefox.exe' entries in task manager. Is this normal?

Thanks, Dave.

Firefox 68.0.1 64bit Win 7 Pro: I have four ' firefox.exe' entries in task manager. Is this normal? Thanks, Dave.
引用

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 32.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

更多資訊

RobertJ
  • Top 10 Contributor
125 個解決方法 1303 個答案

Hi EF80, Firefox moved to a multi-process architecture to provide a more stable browser. Here's an article from ghacks which helps explain: Multi-Process Firefox: everything you need to know

Hi EF80, Firefox moved to a multi-process architecture to provide a more stable browser. Here's an article from ghacks which helps explain: [https://www.ghacks.net/2016/07/22/multi-process-firefox/ Multi-Process Firefox: everything you need to know]
這篇文章有幫助嗎? 0
引用

提出問題者

It is enabled in about support I have disabled it in about con fig as directed and makes NO difference, still there are four firefox.exe entries in Task manager after rebooting

1) consuming 13,008 2) consuming 42,224 3) consuming 179,008 4) consuming 63,928

Dave

It is enabled in about support I have disabled it in about con fig as directed and makes NO difference, still there are four firefox.exe entries in Task manager after rebooting 1) consuming 13,008 2) consuming 42,224 3) consuming 179,008 4) consuming 63,928 Dave

由 EF80 於 修改

這篇文章有幫助嗎?
引用
McCoy
  • Top 10 Contributor
579 個解決方法 5433 個答案

Hello Dave,

Unfortunately you can no longer disable multi-process (e10s) on the "about:config" page.

Please see :

https://www.ghacks.net/2019/05/17/going-forward-multi-process-cant-be-turned-off-anymore-in-firefox/

https://techdows.com/2019/05/mozilla-firefox-68-doesnt-allow-turning-off-e10s.html

(note that running 4 processes is perfectly normal)

Should you absolutely want to disable multi-process (which, in your case, I won't recommend) :

You can set an environment variable to disable multi-process. :
• set MOZ_FORCE_DISABLE_E10S=1
How to set environment variables : http://www.computerhope.com/issues/ch000549.htm

You can use the set command to create a temporary environment variable.

  • open command prompt window
  • change to installation directory
  • type "set MOZ_FORCE_DISABLE_E10S=1" and press enter
  • type "firefox.exe" and press enter

How to use set command : http://www.computerhope.com/sethlp.htm

Hello Dave, Unfortunately you can no longer disable multi-process (e10s) on the "about:config" page. Please see : https://www.ghacks.net/2019/05/17/going-forward-multi-process-cant-be-turned-off-anymore-in-firefox/ https://techdows.com/2019/05/mozilla-firefox-68-doesnt-allow-turning-off-e10s.html (note that running 4 processes is perfectly normal) Should you absolutely want to disable multi-process (which, in your case, I won't recommend) : You can set an environment variable to disable multi-process. :<BR> • set MOZ_FORCE_DISABLE_E10S=1<BR> How to set environment variables : http://www.computerhope.com/issues/ch000549.htm You can use the set command to create a temporary environment variable. * open command prompt window * change to installation directory * type "set MOZ_FORCE_DISABLE_E10S=1" and press enter * type "firefox.exe" and press enter How to use set command : http://www.computerhope.com/sethlp.htm
這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17699 個解決方法 160142 個答案

You normally see more Firefox processes running.

  • one process for the main Firefox thread (user interface)
  • one or more content processes, see:
    Options/Preferences -> General -> Performance
    remove checkmark: [ ] "Use recommended performance settings"
  • one process for the compositor thread
  • one process for the WebRender when this feature is enabled

You can find the current multi-process state on the Troubleshooting Information page (about:support).

  • "Help -> Troubleshooting Information" -> "Application Basics":
    Multiprocess Windows
    Remote Processes

See also the Remote Processes section further down for more detail.

You normally see more Firefox processes running. *one process for the main Firefox thread (user interface) *one or more content processes, see:<br>Options/Preferences -> General -> Performance<br>remove checkmark: [ ] "Use recommended performance settings" *one process for the compositor thread *one process for the WebRender when this feature is enabled You can find the current multi-process state on the Troubleshooting Information page (about:support). *"Help -> Troubleshooting Information" -> "Application Basics":<br>Multiprocess Windows<br>Remote Processes See also the Remote Processes section further down for more detail.
這篇文章有幫助嗎?
引用
pdsimdars 0 個解決方法 34 個答案

有幫助的回覆

These answers make no sense. I have 7 instances of Firefox in my task manager. They are consuming most of the memory. 184,000 K, 165,000K, 67,000K, 65,000K, 58,000K, 55,000K and 14,000K. the other day I had 10 of them. This is unacceptable. One guy posted articles about how you can no longer change the number of processes. Not helpful for those who think there are too many. Then said you can change that environmental variable and put another article about how to change variables which didn't really tell how to change that variable but talked about the path variable. Then there was the suggestion of going to the cmd prompt and setting a variable. I did that. Then restarted Firefox and still have 5 processes in the Task Manager. Why does firefox need to take up 608,000k Meg of my memory to run? And, more importantly, how can I force a limit? Developers should be required to develop on a computer with 2 Gig of Ram so they would learn to do things within boundaries and think about how to do what they want to do with less. Otherwise, you get a big, sprawling Goliath. Slick an efficient is much better. Anyone know of a good browser that isn't such a resource hog? Thanks

These answers make no sense. I have 7 instances of Firefox in my task manager. They are consuming most of the memory. 184,000 K, 165,000K, 67,000K, 65,000K, 58,000K, 55,000K and 14,000K. the other day I had 10 of them. This is unacceptable. One guy posted articles about how you can no longer change the number of processes. Not helpful for those who think there are too many. Then said you can change that environmental variable and put another article about how to change variables which didn't really tell how to change that variable but talked about the path variable. Then there was the suggestion of going to the cmd prompt and setting a variable. I did that. Then restarted Firefox and still have 5 processes in the Task Manager. Why does firefox need to take up 608,000k Meg of my memory to run? And, more importantly, how can I force a limit? Developers should be required to develop on a computer with 2 Gig of Ram so they would learn to do things within boundaries and think about how to do what they want to do with less. Otherwise, you get a big, sprawling Goliath. Slick an efficient is much better. Anyone know of a good browser that isn't such a resource hog? Thanks
這篇文章有幫助嗎? 2
引用

提出問題者

I'm trying Opera at the moment AND it doesn't take all day to load.

Dave

I'm trying Opera at the moment AND it doesn't take all day to load. Dave
這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17699 個解決方法 160142 個答案

Firefox can have a maximum of eight content processes. With three or four extra processes for internal purposes you can have 11 or 12 processes. The plugin container used for Flash can also add additional processes.

You can set a maximum for to number of content processes in Options/Preferences.

Firefox can have a maximum of eight content processes. With three or four extra processes for internal purposes you can have 11 or 12 processes. The plugin container used for Flash can also add additional processes. You can set a maximum for to number of content processes in Options/Preferences. *Options/Preferences -> General -> Performance<br>remove checkmark: [ ] "Use recommended performance settings" *https://support.mozilla.org/en-US/kb/performance-settings
這篇文章有幫助嗎?
引用
pdsimdars 0 個解決方法 34 個答案

I'll look into Opera. I had been using Pale Moon previously, but then it had no add-ons and once you get used to ad-blocker and some others, it's hard to go back. I'll see if Opera has ad blocking and a few others I like. Thanks.

I'll look into Opera. I had been using Pale Moon previously, but then it had no add-ons and once you get used to ad-blocker and some others, it's hard to go back. I'll see if Opera has ad blocking and a few others I like. Thanks.
這篇文章有幫助嗎?
引用
pdsimdars 0 個解決方法 34 個答案

I did look into that "Options/Preferences -> General -> Performance" and set it for 2 and then restarted Firefox. That was some improvement but I guess firefox didn't do well with math because there are now 4 instances of firefox in the task manager. At least it cut it down some. thanks PS -- nice username :-)

I did look into that "Options/Preferences -> General -> Performance" and set it for 2 and then restarted Firefox. That was some improvement but I guess firefox didn't do well with math because there are now 4 instances of firefox in the task manager. At least it cut it down some. thanks PS -- nice username :-)

由 pdsimdars 於 修改

這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17699 個解決方法 160142 個答案

You only set the number of content processes in Options/Preferences. There are still the basic processes mentioned above for the main processor thread and the compositor thread and other possible threads that are added.

You only set the number of content processes in Options/Preferences. There are still the basic processes mentioned above for the main processor thread and the compositor thread and other possible threads that are added.
這篇文章有幫助嗎?
引用
pdsimdars 0 個解決方法 34 個答案

Opera. So I went and downloaded it and my computer was crawling again so I looked in the task manager and there were 8 entries for Opera. Not a real solution. But thanks for the suggestion. I tried pale moon again and they do have an ad blocker but that's about all. BUT, there is only ONE instance in the task manager.

Opera. So I went and downloaded it and my computer was crawling again so I looked in the task manager and there were 8 entries for Opera. Not a real solution. But thanks for the suggestion. I tried pale moon again and they do have an ad blocker but that's about all. BUT, there is only ONE instance in the task manager.

由 pdsimdars 於 修改

這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題