搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I suppress the Mozilla privacy notice tab every time I open Firefox

more options

How can I suppress the Mozilla privacy notice tab that appears every time I open Firefox

被選擇的解決方法

You can check that those pages aren't set as multiple homepages.

You can check the homepage setting.

Firefox supports multiple homepages separated by '|' (pipe) symbols.

從原來的回覆中察看解決方案 👍 0

所有回覆 (20)

more options

Do you have a Homepage saved? Screenshot of the error every-time you open the Browser? So that others can see what is happening.

由 WestEnd 於 修改

more options

選擇的解決方法

You can check that those pages aren't set as multiple homepages.

You can check the homepage setting.

Firefox supports multiple homepages separated by '|' (pipe) symbols.

more options

Here is the screenshot that Westend requested. My homepage is Bing search.

more options

Any thoughts on how to fix this ? Any way to prevent this from appearing unless there is an update? I don't need to review it multiple times a day.

more options

You can check for problems with the sessionstore.jsonlz4 file in the Firefox profile folder that stores session data.

  • delete sessionstore.jsonlz4 and sessionstore.js

When sessionstore.jsonlz4 is deleted you lose pinned tabs and open tabs and you will have to recreate them, so if necessary make a note or bookmark them.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

more options

cor-el Before I try to understand your directions. Not sure that I do, but anyway, the problem started when I refreshed Firefox. Does that help you to know what is causing the problem?

由 loyall 於 修改

more options

Would it be possible to see a screen shot of one of the warning pages?

As the problem started after a refresh have you thought of deleting Firefox and then adding it again? Remember to make sure you have your sign in details and password saved somewhere so you can sign back into the same account. If you have linked/synced your account with another device so much the better as you should be able to use that to sync from/to.

more options

C Man, Your question was already asked by WestEnd and answered.

more options

cor-el, Did you see where I said that the the privacy notice began appearing after I refreshed Firefox, which means I created a new profile? Your directions to sessionstore.jsonlz4 and sessionstore.js do not work for me. All they do is bring me to my default profile which I am not allowed to delete.

more options

Loyall,

You posted a screenshot of your Bing search page. You had three tabs to the right which are the ones that I would like to see. There is nothing in your screenshot which gives a clue to the issue you are facing.

more options

The C Man (Call me C) said

Loyall, You posted a screenshot of your Bing search page. You had three tabs to the right which are the ones that I would like to see. There is nothing in your screenshot which gives a clue to the issue you are facing.

@ C Man :

The screenshot shows these four tabs :

https://www.mozilla.org/en-US/privacy/firefox/

more options

That is the standard warning page. Did you check everything contained in the page? What page do you sign into when you first open Firefox? Have you tried using the Firefox default page?

Why did you create a new profile? You can delete a profile using the advice in https://support.mozilla.org/en-US/kb/uninstall-firefox-from-your-computer. If you did not delete the previous profile it may still be stored and possibly causing a conflict when you now open your new profile.

Personally when I delete something I use an uninstaller that deletes everything at the same time (Iobit Uninstaller).

more options

Hi McCoy, Remember when you helped me before? Thanks for your help explaining to C Man. He seems to think that the privacy notice is a warning or an error message, which it is not. The problem is I can't stop it from appearing every time I go to my home page. I will prepare a reply to him. Perhaps he can still help me.

But can you, McCoy, help me with something else? When I tried to log in to this community two days ago, I was unable to even though I am sure that I recalled my correct log-in credentials. I had to create a new account, and lost my old posting history. Do you know if this forum cleared all accounts and made everyone create new ones? Anyway can you tell me how to set my new account to auto notify when someone replies to me? it is inconvenient not to have that feature enabled.

由 loyall 於 修改

more options

Hello loyall,

Yes, everybody (including us, contributors) had to upgrade their existing Mozilla account to Firefox Accounts, see :

https://support.mozilla.org/en-US/kb/firefox-accounts-mozilla-support-faq

As for getting notified when someone replies to your posts : to the right of your original post you can click on "Get email notifications".

But back to the problem you posted here : I think you'd best wait for "cor-el" to get back to you about it.

(edit : typo)

由 McCoy 於 修改

more options

cor-el had the right idea way back in the third post. I just didn't understand him. I checked the url in the custom home page field, and found that it contained a pipe symbol followed by some more garbage. When I removed the pipe and everything after it, the privacy notices no longer appeared. Weird or Not? How did that other garbage get in there? Anyway my problem is solved.

more options

McCoy said, "As for getting notified when someone replies to your posts : to the right of your original post you can click on "Get email notifications"."

To the right of my initial question, I can find no such link as you describe.

more options

I'm glad your problem is solved - well done !

About your Firefox account :

Could it be that, when you made the switch to the new account, you used a different email address (or username) ?

(see the link I gave you in my last post)

more options

loyall said

McCoy said, "As for getting notified when someone replies to your posts : to the right of your original post you can click on "Get email notifications"."
To the right of my initial question, I can find no such link as you describe.

Sorry, I should have said "Get email updates" (not "notifications").

more options

McCoy said, "Sorry, I should have said "Get email updates" (not "notifications")." That simple word difference would not have stopped me. I do not see get email anything. What am I missing?

On a different topic, could you tell me how to enable replies to private messages?

由 loyall 於 修改

more options

loyall said

McCoy said, "Sorry, I should have said "Get email updates" (not "notifications")." That simple word difference would not have stopped me. I do not see get email anything. What am I missing?

To the right of your original post, do you see "Question Tools" ? If so : would you click on it please ? Now do you see "Get email updates"?

  1. 1
  2. 2