搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Add-ons page in Preferences is blank. Restarted in Safe Mode; page is still blank, so I can't troubleshoot extensions.

  • 7 回覆
  • 1 有這個問題
  • 19 次檢視
  • 最近回覆由 FredMcD

more options

Manage Extension pages for each Add-On is informational only; does not allow me to disable extension etc. I haven't made any changes to extensions or customized Firefox in any way since the beginning of the year. Seems bizarre as seems to have happened rather suddenly.

Additional help suggestion offered by Firefox: * Shockwave Flash 32.0 r0 installed. No idea what to do about this; if it relates to Adobe Flash Player in Mac System Preferences, system plug-in is up-to-date.

Latest version of Firefox for Mac.

Thanks for any help.

被選擇的解決方法

Did you post your question from that computer? Your System Details shows many add-ons are on-line.

It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files":

+++++++++++++++++++++++++++ You will have to approve the updating one last time.

從原來的回覆中察看解決方案 👍 1

所有回覆 (7)

more options

Edit: Hardware Acceleration is not an available preference, so I am not using it.

more options

選擇的解決方法

Did you post your question from that computer? Your System Details shows many add-ons are on-line.

It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files":

+++++++++++++++++++++++++++ You will have to approve the updating one last time.

more options

Hi Firefox User, the Enable/Disable, Preferences and Remove functions got moved to a menu. There should be an icon of ••• on the right side for each extension. Example screenshot attached. Can you find that on yours?

more options

FredMcD and jscher, thank you for your detailed responses. I'll work on them and let you know how it goes. Really appreciate your input on this!

more options

Can you attach a screenshot?

more options

FredMcD, I followed your instructions, though perhaps not precisely, as I needed to reinstall my extensions. Your route did solve the problem, though. In the course of reinstalling extensions, I dropped a number of them which I can probably live without.

jscherr, FWIW, the Manage Your Extensions page was blank (except for the usual menu items down the left side). No three vertical dots, no gear wheel, and no blank white tiles.

cor-el, thanks for the offer of help.

Firefox has become my main browser, but I don't know my way around it nearly as well as I do Safari, so I appreciate your help.

more options

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution.

Thank you for contacting Mozilla Support.