X
點擊此處開啟此網站的行動版。

技術支援討論區

How to deactivate FireFox starts with "recommended" Ads/Updates of visited sites - security leak

已張貼

Hello,

I notice on ubuntu with FireFox 68.0 64bit that some times after starting the browser that a small Ubuntu Notification appears: FireFox displays some recommendation to visit, f.e. did I received today a popup, displaying a new Reddit Post.

This is a huge issue, because: There was NO Reddit Tab open There was NO Tab loaded (browser started fresh) - the last selected Tab opened, which has nothing to do with Reddit There is NO cookie of Reddit on this computer / I use addons to auto-delete cookies after closing a Tab There is NO exception rule in this Addon for Reddit

To me this is some serious issue, that FireFox is doing something (like checking on websites) without my explicit command for it!

What is it by name and how to stop this? Are you aware of any other features like that, calling "home" or calling other servers (exept of update server) without my knowledge?

Thanks

Hello, I notice on ubuntu with FireFox 68.0 64bit that some times after starting the browser that a small Ubuntu Notification appears: FireFox displays some recommendation to visit, f.e. did I received today a popup, displaying a new Reddit Post. This is a huge issue, because: There was NO Reddit Tab open There was NO Tab loaded (browser started fresh) - the last selected Tab opened, which has nothing to do with Reddit There is NO cookie of Reddit on this computer / I use addons to auto-delete cookies after closing a Tab There is NO exception rule in this Addon for Reddit To me this is some serious issue, that FireFox is doing something (like checking on websites) without my explicit command for it! What is it by name and how to stop this? Are you aware of any other features like that, calling "home" or calling other servers (exept of update server) without my knowledge? Thanks
引用

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 32.0 r0

應用程式

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

更多資訊

提出問題者

Mh, I just went into about:config and had a look:

there is a whole set called "app.normandy..." Is it that "shit", because without notifing or asking me there is "shit" like unique users ID set with it and pointing to some shitty Mozilla URL.

Will deactivate it and report back. Anyway: Blame on Mozilla for this crap!

Mh, I just went into about:config and had a look: there is a whole set called "app.normandy..." Is it that "shit", because without notifing or asking me there is "shit" like unique users ID set with it and pointing to some shitty Mozilla URL. Will deactivate it and report back. Anyway: Blame on Mozilla for this crap!
這篇文章有幫助嗎? 0
引用
philipp
  • Top 25 Contributor
  • Moderator
5280 個解決方法 23329 個答案

有幫助的回覆

hi, such notifications would not be something that mozilla would be sending out - please check in your firefox permission settings if you have given a website the permission to send you push notifications and revoke them if you haven't done so intentionally: Web Push notifications in Firefox

hi, such notifications would not be something that mozilla would be sending out - please check in your firefox permission settings if you have given a website the permission to send you push notifications and revoke them if you haven't done so intentionally: [[Web Push notifications in Firefox]]
這篇文章有幫助嗎? 1
引用

提出問題者

I guess this could be it. When granting Notification Permissions a ServiceWorker is installed, like an invisible background website.

Is there any way to see what ServiceWorkers are in FireFox - a gathered list like with saved passwords would be helpful?

Thanks

I guess this could be it. When granting Notification Permissions a ServiceWorker is installed, like an invisible background website. Is there any way to see what ServiceWorkers are in FireFox - a gathered list like with saved passwords would be helpful? Thanks
這篇文章有幫助嗎?
引用
philipp
  • Top 25 Contributor
  • Moderator
5280 個解決方法 23329 個答案

有幫助的回覆

you can see/control active service workers by typing about:serviceworkers into the address bar.

you can see/control active service workers by typing ''about:serviceworkers'' into the address bar.
這篇文章有幫助嗎? 1
引用

提出問題者

Thanks again! That worked - and that list had youtube, ebay and reddit. Ahhhhh - I get nightmares thinking of them collecting some data of me by me accidently allowing this. Is there any way to complete deactivate the notification feature, so I do not get prompted everytime?

Thank you

Thanks again! That worked - and that list had youtube, ebay and reddit. Ahhhhh - I get nightmares thinking of them collecting some data of me by me accidently allowing this. Is there any way to complete deactivate the notification feature, so I do not get prompted everytime? Thank you
這篇文章有幫助嗎?
引用

提出問題者

Found it by myself: See for "Menu" -> Preferences -> Notifications -> Settings for Notifications -> block all new request to allow notifications.

The list there also has other websites listed: In my case one website did not installed any ServiceWorker but still was allowed for Notification, as listed in here.

Topic closed.

Found it by myself: See for "Menu" -> Preferences -> Notifications -> Settings for Notifications -> block all new request to allow notifications. The list there also has other websites listed: In my case one website did not installed any ServiceWorker but still was allowed for Notification, as listed in here. Topic closed.
這篇文章有幫助嗎?
引用

提出問題者

Ps.: Doing it by about:config dom.webnotifications.enabled set to false

Ps.: Doing it by about:config dom.webnotifications.enabled set to false
這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題