X
點擊此處開啟此網站的行動版。

技術支援討論區

tab crash mozilla::MediaDecoderStateMachine::DecodeMetadataState::OnMetadataRead

fs
已張貼

Hi, my firefox tabs crashe constantly.

The signature is mozilla::MediaDecoderStateMachine::DecodeMetadataState::OnMetadataRead

I reported the crashes https://crash-stats.mozilla.org/report/index/e9960374-a690-4480-a343-8902e0190717

It happens on nearly every page, including most reddit pages, imgur, twitch, basicly everwhere where anyform of media is shown. I've tried the firefox secure start up without any addons...still the tabs crash.

This never happend to me before, I did not change anything about Firefox or my PC in the last couple of days. Firefox is up to date.(well I DID uninstall one add on which has nothing to do with media playback, and which was deactivated anyway).

Can somebody help me out? Thanks in advance.

Hi, my firefox tabs crashe constantly. The signature is mozilla::MediaDecoderStateMachine::DecodeMetadataState::OnMetadataRead I reported the crashes https://crash-stats.mozilla.org/report/index/e9960374-a690-4480-a343-8902e0190717 It happens on nearly every page, including most reddit pages, imgur, twitch, basicly everwhere where anyform of media is shown. I've tried the firefox secure start up without any addons...still the tabs crash. This never happend to me before, I did not change anything about Firefox or my PC in the last couple of days. Firefox is up to date.(well I DID uninstall one add on which has nothing to do with media playback, and which was deactivated anyway). Can somebody help me out? Thanks in advance.

被選擇的解決方法

Hm, well this is akward. I did not change anything, but today the problem seems to be fixed. Thanks for the help anyway. I just hope it stays that way.

從原來的回覆中察看解決方案 0
引用

額外的系統細節

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

更多資訊

jscher2000
  • Top 10 Contributor
8580 個解決方法 70167 個答案

Hi fs, sorry to hear about this problem.

If I understand, you tried Firefox "Safe Mode" (Restart with Add-ons Disabled...) and you had the same problem?

Did it start in Firefox 67, or just after the update to Firefox 68 (since last week)?


Could you disable the new graphics engine called WebRender and see whether that makes any difference? Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste webren and pause while the list is filtered

Near the bottom:

(3) If the gfx.webrender.enabled preference is true, double-click it to toggle it to false

(4) Double-click the gfx.webrender.force-disabled preference to switch the value from false to true

Presumably that will take effect after you next exit and restart Firefox.

Any improvement?

Hi fs, sorry to hear about this problem. If I understand, you tried Firefox "Safe Mode" (Restart with Add-ons Disabled...) and you had the same problem? Did it start in Firefox 67, or just after the update to Firefox 68 (since last week)? ---- Could you disable the new graphics engine called WebRender and see whether that makes any difference? Here's how: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''webren''' and pause while the list is filtered ''Near the bottom:'' (3) If the '''gfx.webrender.enabled''' preference is true, double-click it to toggle it to false (4) Double-click the '''gfx.webrender.force-disabled''' preference to switch the value from false to true Presumably that will take effect after you next exit and restart Firefox. Any improvement?
這篇文章有幫助嗎?
引用

提出問題者

Hey, it started yesterday, I used the same PC everday, however I do not know when the updated to 68 happened. If the update happened before 2019-07-17 then the occurrence of the error is not directly correlated to the update, but with some delay.

gfx.webrender.enabled was false.

gfx.webrender.force-disabled was false as well...but if the webrender was not enabled anyway, what will this change?

I will try it anyway as soon as possible.

Hey, it started yesterday, I used the same PC everday, however I do not know when the updated to 68 happened. If the update happened before 2019-07-17 then the occurrence of the error is not directly correlated to the update, but with some delay. gfx.webrender.enabled was false. gfx.webrender.force-disabled was false as well...but if the webrender was not enabled anyway, what will this change? I will try it anyway as soon as possible.
這篇文章有幫助嗎?
引用

選擇的解決方法

Hm, well this is akward. I did not change anything, but today the problem seems to be fixed. Thanks for the help anyway. I just hope it stays that way.

Hm, well this is akward. I did not change anything, but today the problem seems to be fixed. Thanks for the help anyway. I just hope it stays that way.
這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題