X
點擊此處開啟此網站的行動版。

技術支援討論區

Search suggestions not turning off

已張貼

Firefox 68, Win 7pro.

I can't rid Google search suggestio, they just will not turn off? In the older version I could apply this script in Adblock Plus [ https://google.com/extern-js/ ] to stop search suggestions - I cant get that to work with the FF68.

The only way to rid is to turn Java off in about:config. AND DO lets have a nice plain Theme for Firefox, this is one reason I am still using an outdated version Firefox 2 reloaded was a classic, we ALL don't want flashing bright designs.

Dave

Firefox 68, Win 7pro. I can't rid Google search suggestio, they just will not turn off? In the older version I could apply this script in Adblock Plus [ https://google.com/extern-js/ ] to stop search suggestions - I can''t get that to work with the FF68. The only way to rid is to turn Java off in about:config. AND DO lets have a nice plain Theme for Firefox, this is one reason I am still using an outdated version Firefox 2 reloaded was a classic, we ALL don't want flashing bright designs. Dave

由 EF80 於 修改

被選擇的解決方法

EF80 said

I don't know about sending an Email

I posted the email address earlier: support@adblockplus.org

But everything's okay now, so "case closed", eh ?

從原來的回覆中察看解決方案 1
引用

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 32.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

更多資訊

提出問題者

Sorry Firefox 68 not 64 as stated (Edited above)

Sorry Firefox 68 not 64 as stated (Edited above)

由 EF80 於 修改

這篇文章有幫助嗎?
引用
Standard8 33 個解決方法 184 個答案

You can turn off search suggestions in the address bar and search bar by going to the three-bar menu, then Options. On that page, you can select "Search" on the left and then in the default browser section, deselect "Provide search suggestions" - See the attached image.

If they're not the suggestions you want to stop, then please describe in more detail the suggestions you want to block and maybe provide a screenshot, that will help us to understand what you're attempting to do.

You can turn off search suggestions in the address bar and search bar by going to the three-bar menu, then Options. On that page, you can select "Search" on the left and then in the default browser section, deselect "Provide search suggestions" - See the attached image. If they're not the suggestions you want to stop, then please describe in more detail the suggestions you want to block and maybe provide a screenshot, that will help us to understand what you're attempting to do.
這篇文章有幫助嗎?
引用

提出問題者

It DOES NOT work....! I have tried that -:

I did say.... I can't rid Google search suggestio, they just will not turn off?

Nor does the latest Adblock work.... you can create 'My list' but nothing else. I can't white' list it or 'black' list it.

What DOES work as said is turning JS script off in about:config ,toggle JS script enabled to disable or removing Adblock and using Ublock.

So what to do? Well, I'll have another play on a spare drive, I want to get it work the way 'I' want or we'll play with other browsers - sorry half right nearly there is NOT good enough for me.

Dave

It DOES NOT work....! I have tried that -: I did say.... I'' can't rid Google search suggestio, they just will not turn off? Nor does the latest Adblock work.... you can create 'My list' but nothing else. I can't white' list it or 'black' list it. What DOES work as said is turning JS script off in about:config ,toggle JS script enabled to disable or removing Adblock and using Ublock. So what to do? Well, I'll have another play on a spare drive, I want to get it work the way 'I' want or we'll play with other browsers - sorry half right nearly there is NOT good enough for me. Dave

由 EF80 於 修改

這篇文章有幫助嗎?
引用
Standard8 33 個解決方法 184 個答案

Are you seeing this in the location bar or the search bar or somewhere else?

Can you please attach a screenshot of the Firefox window which shows where you are seeing this?

Are you seeing this in the location bar or the search bar or somewhere else? Can you please attach a screenshot of the Firefox window which shows where you are seeing this?
這篇文章有幫助嗎? 0
引用

提出問題者

Having trouble posting screenshot, I'm sorry I can't explain any simpler, I'll try to-:

I go to TOOLS/ OPTIONS/ Search (selecting the magnifier glass) underneath the DEFAULT SEARCH ENGINE are three boxes the first one PROVIDE SEARCH SUGGESTIONS, presently it is UNITCKED -blank..

I have tried ticking it and rebooting Firefox, I've tried unticking it and rebooting Firefox. Please beleive me when I say doing this makes NO DIFFERENCE, it does not work on other browsers to add.

Also the latest Adblocker, I can enter the script into Adblock as decribed previously, works with FF 46 and a older version of Adblock but not with the new version of Adblock and FF68.

I entered the script in 'User list' or something but no way to black or white list it - it just sits there.

This 'quirk' is about getting me down and running out of 'playtime' soon will be ditching all for something that works.

Having trouble posting screenshot, I'm sorry I can't explain any simpler, I'll try to-: I go to TOOLS/ OPTIONS/ Search (selecting the magnifier glass) underneath the DEFAULT SEARCH ENGINE are three boxes the first one PROVIDE SEARCH SUGGESTIONS, presently it is UNITCKED -blank.. I have tried ticking it and rebooting Firefox, I've tried unticking it and rebooting Firefox. Please beleive me when I say doing this makes NO DIFFERENCE, it does not work on other browsers to add. Also the latest Adblocker, I can enter the script into Adblock as decribed previously, works with FF 46 and a older version of Adblock but not with the new version of Adblock and FF68. I entered the script in 'User list' or something but no way to black or white list it - it just sits there. This 'quirk' is about getting me down and running out of 'playtime' soon will be ditching all for something that works.

由 EF80 於 修改

這篇文章有幫助嗎?
引用

提出問題者

Can't get Adblock to work on Firefox 68, it wiill not block Java script like the older version I use on FF46.

I've deleted Adblock and used Ublock instead.

What IS annoying you turn search suggestion off in Firefox (the one under default search engine) and it does not work on ANY browser!

I do think we are looking at two faults here, one Firefox and the other Adblock Plus not blocking Java script.

Can't get Adblock to work on Firefox 68, it wiill not block Java script like the older version I use on FF46. I've deleted Adblock and used Ublock instead. What IS annoying you turn search suggestion off in Firefox (the one under default search engine) and it '''does not''' work on ANY browser! I do think we are looking at two faults here, one Firefox and the other Adblock Plus not blocking Java script.

由 EF80 於 修改

這篇文章有幫助嗎?
引用
Standard8 33 個解決方法 184 個答案

Unfortunately, you still haven't told us where you are seeing the search suggestions. That really does make it hard to help.

Are you on seeing them in the popup from the toolbar, in the middle page, on a search engine page? What is the URL that you are at when you're seeing these?

Unfortunately, you still haven't told us where you are seeing the search suggestions. That really does make it hard to help. Are you on seeing them in the popup from the toolbar, in the middle page, on a search engine page? What is the URL that you are at when you're seeing these?
這篇文章有幫助嗎?
引用

提出問題者

Ah, I'm sorry.... Google search suggestions, Startpage search suggestions are the two that won't turn off, I've tried all way's.

The only way was to either disable Java in about config, Adblock+ would'nt stop it either even if I entered the script that I'd used on FF46 and older version of Adblcok.

I did find that Ublock stopped them, but shouldn't unchecking 'Search suggestions' do just that without havinbg to use add-ons?

EDIT: Google search page and their Search bar in the middle is where I'm seeing them NOT in the Firefox search bar at the top.

Dave

Ah, I'm sorry.... Google search suggestions, Startpage search suggestions are the two that won't turn off, I've tried all way's. The only way was to either disable Java in about config, Adblock+ would'nt stop it either even if I entered the script that I'd used on FF46 and older version of Adblcok. I did find that Ublock stopped them, but shouldn't unchecking 'Search suggestions' do just that without havinbg to use add-ons? EDIT: Google search page and their Search bar in the middle is where I'm seeing them NOT in the Firefox search bar at the top. Dave

由 EF80 於 修改

這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8568 個解決方法 70054 個答案

有幫助的回覆

EF80 said

Google search page and their Search bar in the middle is where I'm seeing them NOT in the Firefox search bar at the top.

Hi Dave, assuming you mean this --

-- the setting in Firefox won't help because it's only for Firefox's own search boxes (address bar, new tab page, etc.). Well, you already know that.

I'm assuming you see the drop-down as a distraction and you don't really care if Google is off generating suggestions in the background? So it would be a sufficient solution to make the drop-down invisible? That wouldn't require turning off scripts, it just requires finding a reliable way to identify the element and then applying a filter or style rule to it.

I don't know how to write Adblock-style filters, but maybe you can ask on their forums how to suppress this element (this is the HTML of the tag when I load it):

<div class="UUbT9" jscontroller="tg8oTe" jsname="UUbT9" jsaction="mouseout:ItzDCd;mouseleave:MWfikb;hBEIVb:nUZ9le;YMFC3:VKssTb">

Since Google uses gibberish naming, it's possible this will change again and require another new filter. That's just how they roll.

''EF80 [[#answer-1238590|said]]'' <blockquote> Google search page and their Search bar in the middle is where I'm seeing them NOT in the Firefox search bar at the top.</blockquote> Hi Dave, assuming you mean this -- <img src="https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2019-07-18-18-33-35-a5a441.png" width="500"> -- the setting in Firefox won't help because it's only for Firefox's own search boxes (address bar, new tab page, etc.). Well, you already know that. I'm assuming you see the drop-down as a distraction and you don't really care if Google is off generating suggestions in the background? So it would be a sufficient solution to make the drop-down invisible? That wouldn't require turning off scripts, it just requires finding a reliable way to identify the element and then applying a filter or style rule to it. I don't know how to write Adblock-style filters, but maybe you can ask on their forums how to suppress this element (this is the HTML of the tag when I load it): &lt;div class="UUbT9" jscontroller="tg8oTe" jsname="UUbT9" jsaction="mouseout:ItzDCd;mouseleave:MWfikb;hBEIVb:nUZ9le;YMFC3:VKssTb"> Since Google uses gibberish naming, it's possible this will change again and require another new filter. That's just how they roll.
這篇文章有幫助嗎? 1
引用
cor-el
  • Top 10 Contributor
  • Moderator
17334 個解決方法 156713 個答案
See also: *https://support.google.com/websearch/forum/AAAAgtjJeM4-3mvLNkE3oA/
這篇文章有幫助嗎? 0
引用
McCoy
  • Top 10 Contributor
488 個解決方法 4493 個答案

Hello Dave,

I'd hate it if I didn't get those search suggestions; they often save me so much time !

But as it was AdBlock Plus that used to help you get rid of them - have you tried to contact them about it via email yet ?

support@adblockplus.org

(very nice people there .... )

Hello Dave, I'd hate it if I didn't get those search suggestions; they often save me so much time ! But as it was AdBlock Plus that used to help you get rid of them - have you tried to contact them about it via email yet ? support@adblockplus.org (very nice people there .... )
這篇文章有幫助嗎?
引用

提出問題者

I've submitted a ticket to Adblock and my post remains unanswered on their forum.

@jscher2000

You are spot on the script I used was google.com/extern-js/ it worled a charm with FF46 and an older adblcok version, sorry I didn't describe it better.

If Adblock can't respond then I just won't use their product. I was understanding that unticking 'provide search suggestions' did just that, never giving it a thought whether it was in the tool bar or not, I never tried it up there.

At least U block does the trick. So I reckon we can closed this matter.... unless someone comes up with a solution.

Thank you all for your perseverance. Dave

I've submitted a ticket to Adblock and my post remains unanswered on their forum. @jscher2000 You are spot on the script I used was google.com/extern-js/ it worled a charm with FF46 and an older adblcok version, sorry I didn't describe it better. If Adblock can't respond then I just won't use their product. I was understanding that unticking 'provide search suggestions' did just that, never giving it a thought whether it was in the tool bar or not, I never tried it up there. At least U block does the trick. So I reckon we can closed this matter.... unless someone comes up with a solution. Thank you all for your perseverance. Dave
這篇文章有幫助嗎?
引用
McCoy
  • Top 10 Contributor
488 個解決方法 4493 個答案

有幫助的回覆

EF80 said

I've submitted a ticket to Adblock and my post remains unanswered on their forum.
If Adblock can't respond then I just won't use their product.

On their forum you're dealing with people in different time zones; people who have regular jobs etc..

Have you tried sending them an email ?

However; if uBlock Origin does the trick, might as well forget about ABP .....

''EF80 [[#answer-1238721|said]]'' <blockquote> I've submitted a ticket to Adblock and my post remains unanswered on their forum.<BR> If Adblock can't respond then I just won't use their product. </blockquote> On their forum you're dealing with people in different time zones; people who have regular jobs etc.. Have you tried sending them an email ? However; if uBlock Origin does the trick, might as well forget about ABP .....
這篇文章有幫助嗎? 1
引用

提出問題者

I don't know about sending an Email but have filled a ticket form in as well a posting. I agree I might as well stick with U Block.

It IS a Adblock issue because the script I use on a older install still works but not with the new versions of FF and Adblock, to me this means the script is still valid. I do know what I am searching for and require no help from Google - I do find it quite annoying. Once upon a time you could add 'complete=0' to Googles search and that would stop it.

I've started using Startpage because I can't abide Googles new look. I do agree since the response to date is lack lustre from Adblcok I'll carry on using Ublock and perhaps forget about them.

Dave

I don't know about sending an Email but have filled a ticket form in as well a posting. I agree I might as well stick with U Block. It IS a Adblock issue because the script I use on a older install still works '''but not''' with the new versions of FF and Adblock, to me this means the script is still valid. I do know what I am searching for and require no help from Google - I do find it quite annoying. Once upon a time you could add 'complete=0' to Googles search and that would stop it. I've started using Startpage because I can't abide Googles new look. I do agree since the response to date is lack lustre from Adblcok I'll carry on using Ublock and perhaps forget about them. Dave
這篇文章有幫助嗎?
引用
McCoy
  • Top 10 Contributor
488 個解決方法 4493 個答案

選擇的解決方法

EF80 said

I don't know about sending an Email

I posted the email address earlier: support@adblockplus.org

But everything's okay now, so "case closed", eh ?

''EF80 [[#answer-1238759|said]]'' <blockquote> I don't know about sending an Email </blockquote> I posted the email address earlier: support@adblockplus.org But everything's okay now, so "case closed", eh ?
這篇文章有幫助嗎? 1
引用

提出問題者

Yes close the case, I'll continue with Ublock, many thanks to you all. Dave

Yes close the case, I'll continue with Ublock, many thanks to you all. Dave
這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題