X
點擊此處開啟此網站的行動版。

技術支援討論區

Firefox not showing proper content?

已張貼

Not showing proper data, In first screenshot its showing "A in Box" in place of content. as in screenshot 1 by comparison from firefox and safari browser. While in screen shot2 all the data converted into normal text.

It is really very hard to work with FIREFOX with these problems, which are increasing every second. Now almost at every website We are likely to face these problem and more commonly in in-house web services when we open into Firefox. browser.

Not showing proper data, In first screenshot its showing "A in Box" in place of content. as in screenshot 1 by comparison from firefox and safari browser. While in screen shot2 all the data converted into normal text. It is really very hard to work with FIREFOX with these problems, which are increasing every second. Now almost at every website We are likely to face these problem and more commonly in in-house web services when we open into Firefox. browser.
附加的畫面擷圖

由 amzad1 於 修改

引用

額外的系統細節

應用程式

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/600.8.9 (KHTML, like Gecko) Version/8.0.8 Safari/600.8.9

更多資訊

howdytom
  • Top 25 Contributor
18 個解決方法 179 個答案

This is looks like font caching issue. Did you already tried to clear your Cache in Firefox? Your 2nd screenshot shows a XML error from a local dev enviroment. I don't think this issue is related.

How to clear the Firefox cache

This is looks like font caching issue. Did you already tried to clear your Cache in Firefox? Your 2nd screenshot shows a XML error from a local dev enviroment. I don't think this issue is related. [https://support.mozilla.org/en-US/kb/how-clear-firefox-cache How to clear the Firefox cache]

由 howdytom 於 修改

這篇文章有幫助嗎?
引用

提出問題者

I always used to clear the cache as described in the suggested forum.

I always used to clear the cache as described in the suggested forum.
這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17567 個解決方法 158888 個答案

You can check for sandbox security issues when Firefox has a problem to access fonts installed locally.

You can set this pref to 2 or 1 on the about:config page to reduce the sandbox security level.

  • security.sandbox.content.level = 1
  • close and restart Firefox to make the change effective.

If '1' still doesn't have effect then try '0' to disable the sandbox.

If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

See also:

You can check for sandbox security issues when Firefox has a problem to access fonts installed locally. *https://wiki.mozilla.org/Security/Sandbox You can set this pref to 2 or 1 on the <b>about:config</b> page to reduce the sandbox security level. *security.sandbox.content.level = 1 *close and restart Firefox to make the change effective. If '1' still doesn't have effect then try '0' to disable the sandbox. If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *https://support.mozilla.org/en-US/kb/about-config-editor-firefox See also: *https://wiki.mozilla.org/Security/Sandbox#Content_Levels
這篇文章有幫助嗎? 0
引用

提出問題者

After changing about:config settings security.sandbox.content.level = 1 & 2 which was 3 earlier. I got the disastrous output (refer attachment).

After changing about:config settings security.sandbox.content.level = 1 & 2 which was 3 earlier. I got the disastrous output (refer attachment).
這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17567 個解決方法 158888 個答案

What does the Font inspector show as the font that Firefox wants to use and then falls back to the last resort (A) font?

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

This usually happen if you are using a third party cookie manager that installs font in a location that Firefox can't access.

What does the Font inspector show as the font that Firefox wants to use and then falls back to the last resort (A) font? You can check in the <b>Rules</b> tab in the right panel in the Inspector what font-family is used for selected text. You can check in the <b>Font</b> tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website. *https://developer.mozilla.org/en-US/Tools/Page_Inspector/How_to/View_fonts This usually happen if you are using a third party cookie manager that installs font in a location that Firefox can't access.
這篇文章有幫助嗎?
引用

提出問題者

I crosschecked fonts from inspector and found that it is using very basic Arial, ArialBold and ArialItalic font. Which is already installed and available into FontAgentPro.

I crosschecked fonts from inspector and found that it is using very basic '''Arial, ArialBold and ArialItalic''' font. Which is already installed and available into FontAgentPro.
這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17567 個解決方法 158888 個答案

If Firefox isn't able to use this Arial font then it is installed in a location that Firefox can't access.

If Firefox isn't able to use this Arial font then it is installed in a location that Firefox can't access. *https://wiki.mozilla.org/Security/Sandbox#Content_Levels
這篇文章有幫助嗎?
引用
howdytom
  • Top 25 Contributor
18 個解決方法 179 個答案

I have updated my answer. Please take a look below

I have updated my answer. Please take a look below

由 howdytom 於 修改

這篇文章有幫助嗎?
引用
howdytom
  • Top 25 Contributor
18 個解決方法 179 個答案
  • You have mentioned FontAgentPro. It could be a orphaned or duplicate font issue. Try flushing your system font cache in FontAgentPro > Preferences > Caches > Clear cache now
  • It is also possible to clear your font cache manually via command line. sudo atsutil databases –remove
  • Afterwards, reboot your Mac
* You have mentioned FontAgentPro. It could be a orphaned or duplicate font issue. Try flushing your system font cache in FontAgentPro > Preferences > Caches > '''Clear cache now''' * It is also possible to clear your font cache manually via command line. '''sudo atsutil databases –remove ''' * Afterwards, reboot your Mac

由 howdytom 於 修改

這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題