X
點擊此處開啟此網站的行動版。

技術支援討論區

Videos won't play and plugins may not be working

已張貼

I am no longer able to play videos on Twitter, Facebook or other sites such as the UK's channel 4 on demand streaming service and BBC iPlayer.

On twitter I get the same error described on this page: https://forums.guru3d.com/threads/firefox-will-not-play-videos-on-twitter.419952/ . See image 1 for the Browser Console log.

On Facebook, if I click a video I just get a black video with the video duration shown as 0:00 (as thought the video has not loaded).

On the UK's channel 4 service I get an error message saying, "Digital Rights Management (DRM) Not Enabled. You must enable DRM in Firefox to play video on channel4.com. Click the "Enable DRM" button provided above". However the Widevine plugin is present on Firefox and is set to "always activate". See image 2 for the Browser Console log.

On BBC iPlayer, I get an error message saying, "The content doesn't seem to be working. Please try again later". See image 3 for the Browser Console log.

When I go to https://www.youtube.com/html5 "H.264" and "MSE & H.264" are shown as red exclamation marks.

I have tried the solutions mentioned on the web (such as clearing cache, turning off content blocking, clearing cookies & site data, creating new profile, refreshing Firefox, uninstalling Firefox (including from the registry) and reinstalling, etc) and nothing has worked. These issues are not resolved by opening Firefox in Safe Mode.

Any assistance would be greatly appreciated. Thank you!

I am no longer able to play videos on Twitter, Facebook or other sites such as the UK's channel 4 on demand streaming service and BBC iPlayer. On twitter I get the same error described on this page: https://forums.guru3d.com/threads/firefox-will-not-play-videos-on-twitter.419952/ . See image 1 for the Browser Console log. On Facebook, if I click a video I just get a black video with the video duration shown as 0:00 (as thought the video has not loaded). On the UK's channel 4 service I get an error message saying, "Digital Rights Management (DRM) Not Enabled. You must enable DRM in Firefox to play video on channel4.com. Click the "Enable DRM" button provided above". However the Widevine plugin is present on Firefox and is set to "always activate". See image 2 for the Browser Console log. On BBC iPlayer, I get an error message saying, "The content doesn't seem to be working. Please try again later". See image 3 for the Browser Console log. When I go to https://www.youtube.com/html5 "H.264" and "MSE & H.264" are shown as red exclamation marks. I have tried the solutions mentioned on the web (such as clearing cache, turning off content blocking, clearing cookies & site data, creating new profile, refreshing Firefox, uninstalling Firefox (including from the registry) and reinstalling, etc) and nothing has worked. These issues are not resolved by opening Firefox in Safe Mode. Any assistance would be greatly appreciated. Thank you!
附加的畫面擷圖
引用

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 32.0 r0

應用程式

  • Firefox 67.0.4
  • 使用者代理:Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/67.0.4/WINNT/en-US/

擴充套件

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: NVIDIA GeForce GTX 750 Ti
  • adapterDescription2: Intel(R) HD Graphics 4600
  • adapterDeviceID: 0x1380
  • adapterDeviceID2: 0x0412
  • adapterDrivers: C:\WINDOWS\System32\DriverStore\FileRepository\nv_desktop_ref4wu.inf_amd64_7ca7dcb22df47474\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_desktop_ref4wu.inf_amd64_7ca7dcb22df47474\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_desktop_ref4wu.inf_amd64_7ca7dcb22df47474\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_desktop_ref4wu.inf_amd64_7ca7dcb22df47474\nvldumdx.dll C:\WINDOWS\System32\DriverStore\FileRepository\nv_desktop_ref4wu.inf_amd64_7ca7dcb22df47474\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_desktop_ref4wu.inf_amd64_7ca7dcb22df47474\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_desktop_ref4wu.inf_amd64_7ca7dcb22df47474\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_desktop_ref4wu.inf_amd64_7ca7dcb22df47474\nvldumd.dll
  • adapterDrivers2: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
  • adapterRAM: 2048
  • adapterRAM2: Unknown
  • adapterSubsysID: 105f10de
  • adapterSubsysID2: 05b71028
  • adapterVendorID: 0x10de
  • adapterVendorID2: 0x8086
  • clearTypeParameters: \\.\DISPLAY1 [ Gamma: 1.8 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50 ] \\.\DISPLAY4 [ Gamma: 1.8 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50 ]
  • contentUsesTiling: False
  • crashGuards: []
  • direct2DEnabled: False
  • direct2DEnabledMessage: {u'key': u''}
  • directWriteEnabled: True
  • directWriteVersion: 10.0.17134.829
  • driverDate: 3-23-2018
  • driverDate2: 11-10-2016
  • driverVersion: 23.21.13.9135
  • driverVersion2: 20.19.15.4549
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'Acceleration blocked by safe-mode', u'type': u'runtime'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct2D', u'log': [{u'status': u'unavailable', u'message': u'Direct2D requires Direct3D 11 compositing', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'disabled', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'unavailable', u'message': u'D3D11 compositing is disabled', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'blocked', u'description': u'GPU Process', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'Safe-mode is enabled', u'type': u'runtime'}], u'name': u'GPU_PROCESS'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u'ANGLE is disabled', u'type': u'runtime'}], u'name': u'WEBRENDER'}, {u'status': u'available', u'description': u'WebRender qualified', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'WEBRENDER_QUALIFIED'}, {u'status': u'blocked', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'OMTP blocked by safe-mode', u'type': u'runtime'}], u'name': u'OMTP'}]}
  • info: {u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'cairo', u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • isGPU2Active: False
  • lowEndMachine: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: {u'key': u''}
  • numTotalWindows: 2
  • offMainThreadPaintEnabled: False
  • offMainThreadPaintWorkerCount: 0
  • targetFrameRate: 60
  • usesTiling: False
  • webgl1DriverExtensions: -
  • webgl1Extensions: -
  • webgl1Renderer: WebGL is currently disabled.
  • webgl1Version: -
  • webgl1WSIInfo: -
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL is currently disabled.
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic
  • windowUsingAdvancedLayers: False

修改過的偏好設定

其他

  • User JS: 否
  • 輔助功能: 否
Wesley Branton
  • Top 10 Contributor
640 個解決方法 5230 個答案

If you are having issues with the H.264 codec, you need to reinstall the Windows Feature Pack.

This is the software that Firefox uses to play that format of video. It's fairly common for something like a Windows update to damage that, so reinstalling it usually helps to repair it.

Hope this helps.

If you are having issues with the H.264 codec, you need to [[Fix video and audio playback problems on Firefox for Windows|reinstall the Windows Feature Pack]]. This is the software that Firefox uses to play that format of video. It's fairly common for something like a Windows update to damage that, so reinstalling it usually helps to repair it. Hope this helps.
這篇文章有幫助嗎?
引用

提出問題者

Thanks for your reply.

I am running Windows 10 Home (not K or KN) so Windows Feature Pack is already installed. I tried to toggle it off/on via Windows Features in the Control Panel but unfortunately this resulted in my registry somehow becoming corrupted and I had to do a fresh Windows install. In any case Firefox is working fine now!

Thanks for your assistance in any case.

Thanks for your reply. I am running Windows 10 Home (not K or KN) so Windows Feature Pack is already installed. I tried to toggle it off/on via Windows Features in the Control Panel but unfortunately this resulted in my registry somehow becoming corrupted and I had to do a fresh Windows install. In any case Firefox is working fine now! Thanks for your assistance in any case.
這篇文章有幫助嗎?
引用
Wesley Branton
  • Top 10 Contributor
640 個解決方法 5230 個答案

Well, glad that you managed to fix it!

Well, glad that you managed to fix it!
這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題