X
點擊此處開啟此網站的行動版。

技術支援討論區

I can't go to a website. This is the most basic functionality of a browser, but I can't do it. No matter what I try, I get sent to a previously opened tab.

已張貼

I sort of like Firefox. It dies regularly because it runs out of RAM all the time, but I can restart it, so it kind of works.

But... sometimes, I want to go to a website. I can type whatever I want, or click whatever I want, but Firefox overrides me and forces me to some tab that was already open, which is not what I wanted. I think this is a fixable flaw. There is probably a secret recipe for avoiding it in the first place.

The only reason I am posting here is because I spent the last hour browsing the boards and could not find a solution, and I suspect that devs would not put up with being unable to do what they want. So I'm sure there's a workaround.

I sort of like Firefox. It dies regularly because it runs out of RAM all the time, but I can restart it, so it kind of works. But... sometimes, I want to go to a website. I can type whatever I want, or click whatever I want, but Firefox overrides me and forces me to some tab that was already open, which is not what I wanted. I think this is a fixable flaw. There is probably a secret recipe for avoiding it in the first place. The only reason I am posting here is because I spent the last hour browsing the boards and could not find a solution, and I suspect that devs would not put up with being unable to do what they want. So I'm sure there's a workaround.
引用

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 11.9 r900

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0

更多資訊

jscher2000
  • Top 10 Contributor
8637 個解決方法 70648 個答案

Hi bbushnell, youi mention both typing and clicking.

"Switch to Tab"

The address bar has a feature called switch to tab. If you start typing a URL or search query that matches an open tab, it will appear on the autocomplete drop-down with a little tab icon and instead of the URL will show "Switch to Tab". As described, clicking that (or arrowing down to it and pressing Enter) will switch to that tab instead of loading the page anew. To override Switch to Tab you can hold down the Shift key.

Otherwise...

It's difficult to explain why Firefox wouldn't follow load a page or follow a link that you clicked. If you haven't already, could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Hi bbushnell, youi mention both typing and clicking. "Switch to Tab" The address bar has a feature called switch to tab. If you start typing a URL or search query that matches an open tab, it will appear on the autocomplete drop-down with a little tab icon and instead of the URL will show "Switch to Tab". As described, clicking that (or arrowing down to it and pressing Enter) will switch to that tab instead of loading the page anew. To override Switch to Tab you can hold down the Shift key. ''Otherwise...'' It's difficult to explain why Firefox wouldn't follow load a page or follow a link that you clicked. If you haven't already, could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8637 個解決方法 70648 個答案

Also, your Firefox identified itself to the forum as version 52. As you may know, the current versions of Firefox are:

(Note for 64-bit Windows users: How to switch from 32-bit to 64-bit Firefox)

If something is holding you back from upgrading Firefox, please let us know so we can suggest solutions or workarounds. Version 52 is not secure.

Also, your Firefox identified itself to the forum as version 52. As you may know, the current versions of Firefox are: * Regular release: 67.0.4 ([https://www.mozilla.org/firefox/all/ Installers]) * Extended Support Release (ESR): 60.7.2esr ([https://www.mozilla.org/firefox/organizations/all/ Installers]) ''(Note for 64-bit Windows users: [[How to switch from 32-bit to 64-bit Firefox]])'' If something is holding you back from upgrading Firefox, please let us know so we can suggest solutions or workarounds. Version 52 is not secure.
這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17416 個解決方法 157344 個答案

You can remove the checkmark on "Open Tabs" in the location bar settings to disable "Switch to tab.

  • Options/Preferences > Privacy > Location Bar: When using the location bar, suggest: [] Open tabs
You can remove the checkmark on "Open Tabs" in the location bar settings to disable "Switch to tab. *Options/Preferences > Privacy > Location Bar: When using the location bar, suggest: [] Open tabs
這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題