X
點擊此處開啟此網站的行動版。
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

技術支援討論區

Add-ons page - addons boxes blank

已張貼

Hi, Please see pictures.

As per everytime I update Firefox I end up spending hours trying to sort issues out and ending up in a foul mood. Everything was fine in 65, I update to 67 and I'm not sure whether I want to scream or cry more.

Issue 1. I lost Adblock plus, I managed to reinstall and lost all my settings that I can't recover. Years of settings gone. All other apps as far as I can tell are still installed so why did adblock get deleted with all the settings?

Issue 2 I can't see addons on the addons page. Same goes for themes and plugins. I've done safe mode where I can see them. I updated them in safe mode. But still can't see them. They were fine in ver 65.

Any ideas? Thanks

Hi, Please see pictures. As per everytime I update Firefox I end up spending hours trying to sort issues out and ending up in a foul mood. Everything was fine in 65, I update to 67 and I'm not sure whether I want to scream or cry more. Issue 1. I lost Adblock plus, I managed to reinstall and lost all my settings that I can't recover. Years of settings gone. All other apps as far as I can tell are still installed so why did adblock get deleted with all the settings? Issue 2 I can't see addons on the addons page. Same goes for themes and plugins. I've done safe mode where I can see them. I updated them in safe mode. But still can't see them. They were fine in ver 65. Any ideas? Thanks
附加的畫面擷圖

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 32.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

更多資訊

WestEnd 60 個解決方法 5387 個答案

The message says your in Private Mode and some of them don't work and it gives your a link to configure.

Also did you read this for Private Mode.

https://support.mozilla.org/en-US/kb/private-browsing-use-firefox-without-history

The message says your in Private Mode and some of them don't work and it gives your a link to configure. Also did you read this for Private Mode. https://support.mozilla.org/en-US/kb/private-browsing-use-firefox-without-history

由 WestEnd 於 修改

jscher2000
  • Top 10 Contributor
8950 個解決方法 73359 個答案

Hi carltonbp, sorry to hear about this problem.

Firefox 67 introduced a new default profile named default-release and the migration isn't going smoothly for all users. You might need to change profiles.

But first, if you haven't already, could you close out of Firefox and do a normal Windows shutdown and restart to complete any pending updates and release any file locks.

If Firefox again starts up without full functionality, could you check whether your stuff is available in a different profile, as follows:

Profile Manager Page

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

This page should list at least one profile and could list many. Each will show links to a pair of folders; please ignore those for now. Please do not delete anything here -- don't use any Remove buttons.

The profile that Firefox is currently using will have this:

This is the profile in use and it cannot be deleted.

Do you have another profile named default or default-longnumber listed on this page? If so, you can check whether it is the one you were using recently by clicking its Launch profile in new browser button.

If it isn't what you want, simply close that new window.

If it IS what you want, back on the about:profiles page, click the Set as default profile button for that profile so Firefox uses it automatically at the next startup.

Any improvement?

Hi carltonbp, sorry to hear about this problem. Firefox 67 introduced a new default profile named default-release and the migration isn't going smoothly for all users. You might need to change profiles. But first, if you haven't already, could you close out of Firefox and do a normal Windows shutdown and restart to complete any pending updates and release any file locks. If Firefox again starts up without full functionality, could you check whether your stuff is available in a different profile, as follows: '''Profile Manager Page''' Inside Firefox, type or paste '''about:profiles''' in the address bar and press Enter/Return to load it. This page should list at least one profile and could list many. Each will show links to a pair of folders; please ignore those for now. ''Please do not delete anything here -- don't use any Remove buttons.'' The profile that Firefox is currently using will have this: '''This is the profile in use and it cannot be deleted.''' Do you have another profile named '''default''' or default-''longnumber'' listed on this page? If so, you can check whether it is the one you were using recently by clicking its '''Launch profile in new browser''' button. If it isn't what you want, simply close that new window. If it IS what you want, back on the about:profiles page, click the '''Set as default profile''' button for that profile so Firefox uses it automatically at the next startup. Any improvement?
cor-el
  • Top 10 Contributor
  • Moderator
17846 個解決方法 161535 個答案

Can you see the extensions listed on the "Help -> Troubleshooting Information" (about:support) page?

Can you see the extensions listed on the "Help -> Troubleshooting Information" (about:support) page?

提出問題者

WestEnd said

The message says your in Private Mode and some of them don't work and it gives your a link to configure. Also did you read this for Private Mode. https://support.mozilla.org/en-US/kb/private-browsing-use-firefox-without-history

Hi, They're not in private mode, I check in safe mode and allowed all of them. Anyway even if they were private mode only I should be able to see them so I can change the settings. Thanks

''WestEnd [[#answer-1227719|said]]'' <blockquote> The message says your in Private Mode and some of them don't work and it gives your a link to configure. Also did you read this for Private Mode. https://support.mozilla.org/en-US/kb/private-browsing-use-firefox-without-history </blockquote> Hi, They're not in private mode, I check in safe mode and allowed all of them. Anyway even if they were private mode only I should be able to see them so I can change the settings. Thanks

提出問題者

jscher2000 said

Hi carltonbp, sorry to hear about this problem. Firefox 67 introduced a new default profile named default-release and the migration isn't going smoothly for all users. You might need to change profiles.

Sorry should have mentioned I checked my profiles. I have 2, 1 current and one from 2017. The current is the default. Thanks

''jscher2000 [[#answer-1227724|said]]'' <blockquote> Hi carltonbp, sorry to hear about this problem. Firefox 67 introduced a new default profile named default-release and the migration isn't going smoothly for all users. You might need to change profiles. </blockquote> Sorry should have mentioned I checked my profiles. I have 2, 1 current and one from 2017. The current is the default. Thanks

提出問題者

cor-el said

Can you see the extensions listed on the "Help -> Troubleshooting Information" (about:support) page?

Hi, Yes they're all listed, I can see them in safe mode too.

''cor-el [[#answer-1227780|said]]'' <blockquote> Can you see the extensions listed on the "Help -> Troubleshooting Information" (about:support) page? </blockquote> Hi, Yes they're all listed, I can see them in safe mode too.

提出問題者

I've also in safe mode disabled all addons. No change.

I've also in safe mode disabled all addons. No change.
cor-el
  • Top 10 Contributor
  • Moderator
17846 個解決方法 161535 個答案

You can check for problems with the extensions registry files in the profile folder.

Try to to reset the extensions registry and rename extensions.json (extensionsOLD.json) and rename/remove previously used extensions files like extensions.ini and extensions.sqlite when present and rename/remove compatibility.ini in the Firefox profile folder with Firefox closed.

New files will be created when required.

See "Corrupt extension files":

You can check for possible updates in case of issues.

  • click the cogwheel button (left of the Search bar) on the about:addons page to "Check for updates"

If this didn't help then delete add-ons.json and possibly prefs.js in case there is a problem with preferences.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

You can check for problems with the extensions registry files in the profile folder. Try to to reset the extensions registry and rename extensions.json (extensionsOLD.json) and rename/remove previously used extensions files like extensions.ini and extensions.sqlite when present and rename/remove compatibility.ini in the Firefox profile folder with Firefox closed. *https://support.mozilla.org/en-US/kb/Profiles New files will be created when required. See "Corrupt extension files": *https://support.mozilla.org/en-US/kb/unable-install-add-ons-extensions-or-themes You can check for possible updates in case of issues. *click the cogwheel button (left of the Search bar) on the about:addons page to "Check for updates" If this didn't help then delete add-ons.json and possibly prefs.js in case there is a problem with preferences. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox