X
點擊此處開啟此網站的行動版。

技術支援討論區

Proxy with private browsing mode

已張貼

After the last browser update I can't use the private browsing mode, because the browser in the private window keeps asking me for the password continuously, thus precluding the possibility of browsing.

After the last browser update I can't use the private browsing mode, because the browser in the private window keeps asking me for the password continuously, thus precluding the possibility of browsing.
引用

額外的系統細節

已安裝的外掛程式

Adobe Acrobat

應用程式

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:67.0) Gecko/20100101 Firefox/67.0

更多資訊

提出問題者

It is possible that I found where is the problem: if I set "do not save history" in normal browsing, the problem of requesting the proxy password is the same.

It is possible that I found where is the problem: if I set "do not save history" in normal browsing, the problem of requesting the proxy password is the same.
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8642 個解決方法 70715 個答案

Hi beatricespada95, I apologize that I am not very familiar with using a proxy in Firefox.

If I understand correctly, everything is fine for you in regular windows -- proxy doesn't require login -- but not in private windows. And this problem in private windows started in Firefox 67.

Do you have Firefox set to automatically provide a login to your proxy using the checkbox in the Connection settings on the Preferences page:

Firefox's built-in Password Manager has reduced functionality in private windows. It can fill login forms on web pages, but cannot save new logins. Perhaps it also does not automatically authenticate to your proxy any more??

If that is a recent change, it may be possible to research it and confirm whether it was intentional, or is a "bug" that will be changed back to the previous behavior.

Hi beatricespada95, I apologize that I am not very familiar with using a proxy in Firefox. If I understand correctly, everything is fine for you in regular windows -- proxy doesn't require login -- but not in private windows. And this problem in private windows started in Firefox 67. Do you have Firefox set to automatically provide a login to your proxy using the checkbox in the Connection settings on the Preferences page: <center><img src="https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2019-05-26-10-04-03-20665a.png" width="400"></center> Firefox's built-in Password Manager has reduced functionality in private windows. It can fill login forms on web pages, but cannot save new logins. Perhaps it also does not automatically authenticate to your proxy any more?? If that is a recent change, it may be possible to research it and confirm whether it was intentional, or is a "bug" that will be changed back to the previous behavior.

由 jscher2000 於 修改

這篇文章有幫助嗎? 0
引用

提出問題者

Hi jscher2000, I try to explain better the problem: jscher2000 said

Hi beatricespada95, I apologize that I am not very familiar with using a proxy in Firefox. If I understand correctly, everything is fine for you in regular windows -- proxy doesn't require login -- but not in private windows. And this problem in private windows started in Firefox 67. Do you have Firefox set to automatically provide a login to your proxy using the checkbox in the Connection settings on the Preferences page:

Firefox's built-in Password Manager has reduced functionality in private windows. It can fill login forms on web pages, but cannot save new logins. Perhaps it also does not automatically authenticate to your proxy any more??

If that is a recent change, it may be possible to research it and confirm whether it was intentional, or is a "bug" that will be changed back to the previous behavior.

Proxy always required a login both in regular and private windows. In regular windows I have the same problem of private windows if I set the preferences on "do not save history". This problem starts with the last version of Firefox.

I hope this problem can be solved, or I will be precluded from using this browser with the privacy preferences I prefer.

Hi jscher2000, I try to explain better the problem: ''jscher2000 [[#answer-1225208|said]]'' <blockquote> Hi beatricespada95, I apologize that I am not very familiar with using a proxy in Firefox. If I understand correctly, everything is fine for you in regular windows -- proxy doesn't require login -- but not in private windows. And this problem in private windows started in Firefox 67. Do you have Firefox set to automatically provide a login to your proxy using the checkbox in the Connection settings on the Preferences page: <center><img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2019-05-26-10-04-03-20665a.png" width="400"></center> Firefox's built-in Password Manager has reduced functionality in private windows. It can fill login forms on web pages, but cannot save new logins. Perhaps it also does not automatically authenticate to your proxy any more?? If that is a recent change, it may be possible to research it and confirm whether it was intentional, or is a "bug" that will be changed back to the previous behavior. </blockquote> Proxy always required a login both in regular and private windows. In regular windows I have the same problem of private windows if I set the preferences on "do not save history". This problem starts with the last version of Firefox. I hope this problem can be solved, or I will be precluded from using this browser with the privacy preferences I prefer.
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8642 個解決方法 70715 個答案

If you change the History setting from

Firefox will: Remember history

to

Firefox will: Never remember history

then Firefox will restart in automatic private browsing mode with all private windows. So yes, it is the same problem.

How does the login to the proxy work: do you get the "basic authentication" popup that looks like the attached?

And regarding frequency of appearance: in a regular window, you get that once per site (or once per session?) and in the private window you get that once per request (e.g., every single image), or some other frequency)?

If you change the History setting from Firefox will: Remember history to Firefox will: Never remember history then Firefox will restart in automatic private browsing mode with all private windows. So yes, it is the same problem. How does the login to the proxy work: do you get the "basic authentication" popup that looks like the attached? And regarding frequency of appearance: in a regular window, you get that once per site (or once per session?) and in the private window you get that once per request (e.g., every single image), or some other frequency)?
這篇文章有幫助嗎? 0
引用

提出問題者

jscher2000 said

If you change the History setting from Firefox will: Remember history to Firefox will: Never remember history then Firefox will restart in automatic private browsing mode with all private windows. So yes, it is the same problem. How does the login to the proxy work: do you get the "basic authentication" popup that looks like the attached? And regarding frequency of appearance: in a regular window, you get that once per site (or once per session?) and in the private window you get that once per request (e.g., every single image), or some other frequency)?

Yes, the popup looks like the attached. The frequency of appearance, before the last update, was once per session both in regular and private window. Now, after the update, in private window (or in regular window with "never remember history" mode) the frequency is 8 per request.

Thank you for your help

''jscher2000 [[#answer-1225448|said]]'' <blockquote> If you change the History setting from Firefox will: Remember history to Firefox will: Never remember history then Firefox will restart in automatic private browsing mode with all private windows. So yes, it is the same problem. How does the login to the proxy work: do you get the "basic authentication" popup that looks like the attached? And regarding frequency of appearance: in a regular window, you get that once per site (or once per session?) and in the private window you get that once per request (e.g., every single image), or some other frequency)? </blockquote> Yes, the popup looks like the attached. The frequency of appearance, before the last update, was once per session both in regular and private window. Now, after the update, in private window (or in regular window with "never remember history" mode) the frequency is 8 per request. Thank you for your help
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8642 個解決方法 70715 個答案

有幫助的回覆

I haven't been able to find any information on changes in Firefox 67 related to this. Do you want to file a bug report on https://bugzilla.mozilla.org/? Perhaps first, check in a new profile to see whether it is the same there:

New Profile Test

This takes about 3 minutes, plus the time to test your problem site(s).

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the "Create a New Profile" button, then click Next. Assign a name like May2019, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test.

Does proxy login work any better in private windows in the new profile?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile.

I haven't been able to find any information on changes in Firefox 67 related to this. Do you want to file a bug report on [https://bugzilla.mozilla.org/]? Perhaps first, check in a new profile to see whether it is the same there: '''New Profile Test''' This takes about 3 minutes, plus the time to test your problem site(s). Inside Firefox, type or paste '''about:profiles''' in the address bar and press Enter/Return to load it. Click the "Create a New Profile" button, then click Next. Assign a name like May2019, ignore the option to relocate the profile folder, and click the Finish button. After creating the profile, scroll down to it and click the '''Launch profile in new browser''' button. Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test. ''Does proxy login work any better in private windows in the new profile?'' When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile.
這篇文章有幫助嗎? 1
引用
reinhardt-ulrike 0 個解決方法 2 個答案

Beim starten von Firefox erscheint nicht mehr mein privater Bildschirm sondern eine Konvertierung, das möchte ich nicht

Beim starten von Firefox erscheint nicht mehr mein privater Bildschirm sondern eine Konvertierung, das möchte ich nicht

由 reinhardt-ulrike 於 修改

這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8642 個解決方法 70715 個答案

reinhardt-ulrike said

Beim starten von Firefox erscheint nicht mehr mein privater Bildschirm sondern eine Konvertierung, das möchte ich nicht

Are you asked for a password? Can you share a screenshot of the problem?

''reinhardt-ulrike [[#answer-1239723|said]]'' <blockquote> Beim starten von Firefox erscheint nicht mehr mein privater Bildschirm sondern eine Konvertierung, das möchte ich nicht </blockquote> Are you asked for a password? Can you share a screenshot of the problem?
這篇文章有幫助嗎?
引用
reinhardt-ulrike 0 個解決方法 2 個答案

I have made a screenshot but I don't know how to send it!

I have made a screenshot but I don't know how to send it!
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8642 個解決方法 70715 個答案

reinhardt-ulrike said

I have made a screenshot but I don't know how to send it!

If you saved the screenshot to an image file, you can use the Browse button to attach it to a post. If you prefer to use an image sharing site, you can post it there and provide a link to the image.

''reinhardt-ulrike [[#answer-1239916|said]]'' <blockquote> I have made a screenshot but I don't know how to send it! </blockquote> If you saved the screenshot to an image file, you can use the Browse button to attach it to a post. If you prefer to use an image sharing site, you can post it there and provide a link to the image.
這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題