X
點擊此處開啟此網站的行動版。

技術支援討論區

Firefox's display language settings are not applying. I've set them to english, but it's still displaying everything in another language.

已張貼

Menus on Firefox itself are displaying in my native language, when I've set them to English.

I've uninstalled all language packs that aren't English, even removed other languages in Windows settings to make sure Firefox displays menus in the language I want, but none of it worked. Already checked about:config and removed any traces of other languages. The settings page itself and other Mozilla webpages are all displaying in the correct language, but the application itself is not.

It started doing this after the most recent update, was working fine before. Only explanation is Firefox is using my location to set a language and completely ignoring my language settings. Should I just wait for it to be fixed?

Menus on Firefox itself are displaying in my native language, when I've set them to English. I've uninstalled all language packs that aren't English, even removed other languages in Windows settings to make sure Firefox displays menus in the language I want, but none of it worked. Already checked about:config and removed any traces of other languages. The settings page itself and other Mozilla webpages are all displaying in the correct language, but the application itself is not. It started doing this after the most recent update, was working fine before. Only explanation is Firefox is using my location to set a language and completely ignoring my language settings. Should I just wait for it to be fixed?
引用

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 32.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

更多資訊

FredMcD
  • Top 10 Contributor
4246 個解決方法 59390 個答案

Let’s do a full clean re-install;

Note: Firefox comes in three or more folders on all computers. They are;

Maintenance: (Programs Folder) <Windows Only> Firefox itself: (Programs Folder) And two folders in the profile of each user on the computer for each Firefox profile for that user.

If you remove the Firefox folder, the user profiles would not be affected.


Download Firefox For All languages And Systems {web link}

Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Note: Check Both Folders

Mac: Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any Mozilla or Firefox program folders. Do not remove the Mozilla Thunderbird folder if there is one.

Do Not remove any profile folders.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your Computer in safe mode and try again.

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

Let’s do a full clean re-install; Note: Firefox comes in three or more folders on all computers. They are; Maintenance: (Programs Folder) <Windows Only> Firefox itself: (Programs Folder) And two folders in the profile of each user on the computer for each Firefox profile for that user. If you remove the Firefox folder, the user profiles would not be affected. ----------- [http://www.mozilla.org/en-US/firefox/all/ Download Firefox For All languages And Systems] {web link} Save the file. Then '''Close Firefox. ''' Using your file browser, open the '''Programs Folder''' on your computer. '''Windows: ''' C:\Program Files C:\Program Files (x86) '''Note:''' Check Both Folders '''Mac: ''' Open the ''' "Applications" ''' folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac '''Linux: ''' Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any '''Mozilla''' or '''Firefox''' program folders. Do not remove the '''Mozilla Thunderbird''' folder if there is one. '''Do Not''' remove any profile folders. After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your '''Computer''' in safe mode and try again. http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia
這篇文章有幫助嗎? 0
引用
cor-el
  • Top 10 Contributor
  • Moderator
17473 個解決方法 157934 個答案

What language do you get?

Note that language provide string translations for the user interface. They do nothing for websites. It is not guaranteed that you get websites in your preferred language.

You aren't using a Proxy or VPN that locates you in a different country?

You can check the installed languages and their order.

  • Options/Preferences -> General -> Languages

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
What language do you get? Note that language provide string translations for the user interface. They do nothing for websites. It is not guaranteed that you get websites in your preferred language. You aren't using a Proxy or VPN that locates you in a different country? You can check the installed languages and their order. *Options/Preferences -> General -> Languages ---- You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *hold down the Shift key and left-click the Reload button *press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *press "Command + Shift + R" (Mac) Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Remove the Cookies" from websites that cause problems: *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Manage Data "Clear the Cache": *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Clear Data -> Cached Web Content: Clear Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
這篇文章有幫助嗎? 0
引用

提出問題者

FredMcD said

Let’s do a full clean re-install;

Tried that, nothing changed.

cor-el said

What language do you get? Note that language provide string translations for the user interface. They do nothing for websites. It is not guaranteed that you get websites in your preferred language. You aren't using a Proxy or VPN that locates you in a different country?

The user interface itself is whats displaying in the wrong language. Websites and everything else work fine. And no, no VPN. Already tried changing the settings you mentioned and nothing worked.

Guess I'll just wait to see if this is ever fixed. English is not my native language but I prefer using it. From what I can tell Firefox is basing the language off of my location, and not letting me change that. The ONLY languages I have installed are English (added every variation just to make sure) and its still not working. :(

''FredMcD [[#answer-1223990|said]]'' <blockquote> Let’s do a full clean re-install; </blockquote> Tried that, nothing changed. ''cor-el [[#answer-1224129|said]]'' <blockquote> What language do you get? Note that language provide string translations for the user interface. They do nothing for websites. It is not guaranteed that you get websites in your preferred language. You aren't using a Proxy or VPN that locates you in a different country? </blockquote> The user interface itself is whats displaying in the wrong language. Websites and everything else work fine. And no, no VPN. Already tried changing the settings you mentioned and nothing worked. Guess I'll just wait to see if this is ever fixed. English is not my native language but I prefer using it. From what I can tell Firefox is basing the language off of my location, and not letting me change that. The ONLY languages I have installed are English (added every variation just to make sure) and its still not working. :(
這篇文章有幫助嗎? 1
引用
James
  • Moderator
1596 個解決方法 11247 個答案

l3l3l3 said

The user interface itself is whats displaying in the wrong language. Websites and everything else work fine. And no, no VPN. Already tried changing the settings you mentioned and nothing worked. Guess I'll just wait to see if this is ever fixed. English is not my native language but I prefer using it. From what I can tell Firefox is basing the language off of my location, and not letting me change that. The ONLY languages I have installed are English (added every variation just to make sure) and its still not working. :(

If you want Firefox in a specific language then download from www.mozilla.org/firefox/all/ and not www.mozilla.org

How to use the Language Packs https://support.mozilla.org/en-US/kb/use-firefox-another-language

''l3l3l3 [[#answer-1224149|said]]'' <blockquote> The user interface itself is whats displaying in the wrong language. Websites and everything else work fine. And no, no VPN. Already tried changing the settings you mentioned and nothing worked. Guess I'll just wait to see if this is ever fixed. English is not my native language but I prefer using it. From what I can tell Firefox is basing the language off of my location, and not letting me change that. The ONLY languages I have installed are English (added every variation just to make sure) and its still not working. :( </blockquote> If you want Firefox in a specific language then download from www.mozilla.org/firefox/all/ and not www.mozilla.org How to use the Language Packs https://support.mozilla.org/en-US/kb/use-firefox-another-language
這篇文章有幫助嗎? 0
引用
cor-el
  • Top 10 Contributor
  • Moderator
17473 個解決方法 157934 個答案

If you only need one language for the user interface then you do not need language packs and you can disable language packs in case some were installed automatically in "Options/Preferences -> Languages".

If you only need one language for the user interface then you do not need language packs and you can disable language packs in case some were installed automatically in "Options/Preferences -> Languages".
這篇文章有幫助嗎? 0
引用
rustespokesman 0 個解決方法 1 個答案

I have the same problem. I am an American living overseas. I used Firefox in English for years. Now Firefox seems to know that I am in Asia and automatically gives me websites in Chinese.. FB, Yahoo, Google.com... basic websites show up in Chinese even though all my settings are in English. The only active languages in my preferences are English and English. There are no other language packs installed, active, or selected. While most websites have an "English" link that I can usually find, many do not. I tried turning off proxies, no help there. It does seem that Firefox is also basing language settings off of my location regardless of the options and preferences available to me. Same as 131313 above.

I have the same problem. I am an American living overseas. I used Firefox in English for years. Now Firefox seems to know that I am in Asia and automatically gives me websites in Chinese.. FB, Yahoo, Google.com... basic websites show up in Chinese even though all my settings are in English. The only active languages in my preferences are English and English. There are no other language packs installed, active, or selected. While most websites have an "English" link that I can usually find, many do not. I tried turning off proxies, no help there. It does seem that Firefox is also basing language settings off of my location regardless of the options and preferences available to me. Same as 131313 above.
這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17473 個解決方法 157934 個答案

Hi rustespokesman

If you IP locates you in an Asian country then a lot of websites will serve you pages in this local language. You will have to look for a button to get English pages. Such a setting is stored in a cookie, so you need a specific allow exception to keep the cookies for these websites.

You can use websites like these to see how your location is reported via a reverse DNS look up of your IP:

Hi rustespokesman If you IP locates you in an Asian country then a lot of websites will serve you pages in this local language. You will have to look for a button to get English pages. Such a setting is stored in a cookie, so you need a specific allow exception to keep the cookies for these websites. You can use websites like these to see how your location is reported via a reverse DNS look up of your IP: *https://www.iplocation.net/ *https://whatismyipaddress.com/
這篇文章有幫助嗎? 0
引用
anthony.pomerinke 0 個解決方法 1 個答案

I am having the same issue as well. After a recent update Firefox is opening and the URL bar has Japanese text and the right-click menu is showing in Japanese as well. I have uninstalled and reinstalled. I have followed a link specifically for the English version of Firefox that was linked above. I have checked the about:config and tried to find any reference to Japan or Japanese language. I have gone into the regular options page and removed Japanese from the language options, so it's not even listed anymore.

This IS NOT a website issue. I'm pretty sure most users are aware if they are overseas they will receive websites local to that region. This is specifically an issue with Firefox. My windows install is in English, and my region is listed as America. I am currently living in Japan, but I don't recall asking firefox to set my language based on location.

It's also not consistent. Earlier today my URL bar on new tabs was showing in Japanese, I turned off my computer and returned a few hours later for some work, and now only the right click menu is in Japanese and the URL bar on a new tab is not.

Is there any way this can be addressed to the developers? It's kind of frustrating.

I am having the same issue as well. After a recent update Firefox is opening and the URL bar has Japanese text and the right-click menu is showing in Japanese as well. I have uninstalled and reinstalled. I have followed a link specifically for the English version of Firefox that was linked above. I have checked the about:config and tried to find any reference to Japan or Japanese language. I have gone into the regular options page and removed Japanese from the language options, so it's not even listed anymore. This IS NOT a website issue. I'm pretty sure most users are aware if they are overseas they will receive websites local to that region. This is specifically an issue with Firefox. My windows install is in English, and my region is listed as America. I am currently living in Japan, but I don't recall asking firefox to set my language based on location. It's also not consistent. Earlier today my URL bar on new tabs was showing in Japanese, I turned off my computer and returned a few hours later for some work, and now only the right click menu is in Japanese and the URL bar on a new tab is not. Is there any way this can be addressed to the developers? It's kind of frustrating.
這篇文章有幫助嗎?
引用
McCoy
  • Top 10 Contributor
534 個解決方法 5035 個答案

Please see this bug report; especially the last few posts :

https://bugzilla.mozilla.org/show_bug.cgi?id=1564998

Please see this bug report; especially the last few posts : https://bugzilla.mozilla.org/show_bug.cgi?id=1564998
這篇文章有幫助嗎? 0
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題