X
點擊此處開啟此網站的行動版。

技術支援討論區

Firefox 67 no longer warns about closing tabs to the right or all other tabs.

已張貼

Doesn't seem to matter the number, and browser.tabs.warnOnClose and browser.tabs.warnOnCloseOtherTabs are set to 'true'.

Doesn't seem to matter the number, and browser.tabs.warnOnClose and browser.tabs.warnOnCloseOtherTabs are set to 'true'.
引用

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 32.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:67.0) Gecko/20100101 Firefox/67.0

更多資訊

McCoy
  • Top 10 Contributor
426 個解決方法 3800 個答案

Hello MathU41,

You may have the values of those preferences set to "true", but you won't see that warning if you have Firefox set to restore previous session ....

Would you check this please :

3-bar menu (or Tools) => Options => General, under "Tabs":

Restore previous session and : Warn you when quitting the browser

If you do want Firefox to restore your previous session (and get the warn on close warning as well), then make sure that both boxes are checked.

Hello MathU41, You may have the values of those preferences set to "true", but you won't see that warning if you have Firefox set to restore previous session .... Would you check this please : 3-bar menu (or Tools) => Options => General, under "Tabs": '' Restore previous session'' and : '' Warn you when quitting the browser'' If you ''do'' want Firefox to restore your previous session (and get the warn on close warning as well), then make sure that both boxes are checked.
這篇文章有幫助嗎? 1
引用

有幫助的回覆

Neither were checked. Checking both doesn't seem to prompt the warning, either.

Neither were checked. Checking both doesn't seem to prompt the warning, either.
這篇文章有幫助嗎? 1
引用

提出問題者

MathU41 said

Neither were checked. Checking both doesn't seem to prompt the warning, either.

Cancel that, now it does give me a warning, but only when I have like 30 tabs open--I presume more than the 'recently closed tabs' in History retains.

''MathU41 [[#answer-1223918|said]]'' <blockquote> Neither were checked. Checking both doesn't seem to prompt the warning, either. </blockquote> Cancel that, now it does give me a warning, but only when I have like 30 tabs open--I presume more than the 'recently closed tabs' in History retains.
這篇文章有幫助嗎?
引用
McCoy
  • Top 10 Contributor
426 個解決方法 3800 個答案

MathU41 said

browser.tabs.warnOnClose and browser.tabs.warnOnCloseOtherTabs are set to 'true'.

Did you have to change those values yourself, and if so : did you close and restart Firefox after you made the change(s)  ?

''MathU41 [[#question-1259736|said]]'' <blockquote> browser.tabs.warnOnClose and browser.tabs.warnOnCloseOtherTabs are set to 'true'. </blockquote> Did you have to change those values yourself, and if so : did you close and restart Firefox after you made the change(s) ?
這篇文章有幫助嗎?
引用

有幫助的回覆

I did not. I did toggle them to false, checked, and returned them to true. Firefox has restarted since.

I did not. I did toggle them to false, checked, and returned them to true. Firefox has restarted since.
這篇文章有幫助嗎? 1
引用
McCoy
  • Top 10 Contributor
426 個解決方法 3800 個答案

I have absolutely no idea why you don't get the warning - I'm hoping that somebody else does (sorry ...)

I have absolutely no idea why you don't get the warning - I'm hoping that somebody else does (sorry ...)
這篇文章有幫助嗎?
引用
McCoy
  • Top 10 Contributor
426 個解決方法 3800 個答案

MathU41 said

Cancel that, now it does give me a warning, but only when I have like 30 tabs open--I presume more than the 'recently closed tabs' in History retains.

Just a thought :

On the "about:config" page, would you check the value of this setting please :

browser.tabs.MaxOpenBeforeWarn (default = 15)

''MathU41 [[#answer-1223920|said]]'' <blockquote> Cancel that, now it does give me a warning, but only when I have like 30 tabs open--I presume more than the 'recently closed tabs' in History retains. </blockquote> Just a thought : On the "about:config" page, would you check the value of this setting please : '''browser.tabs.MaxOpenBeforeWarn''' (default = 15)
這篇文章有幫助嗎?
引用

提出問題者

Indeed, it's at 15. Thought that was about opening tabs, though, and didn't occur it might mean anything about closing them.

Indeed, it's at 15. Thought that was about opening tabs, though, and didn't occur it might mean anything about closing them.
這篇文章有幫助嗎? 0
引用
umpahpah 0 個解決方法 3 個答案

McCoy said

MathU41 said
Cancel that, now it does give me a warning, but only when I have like 30 tabs open--I presume more than the 'recently closed tabs' in History retains.

Just a thought :

On the "about:config" page, would you check the value of this setting please :

browser.tabs.MaxOpenBeforeWarn (default = 15)

Unfortunately, it does not working. I have the same value in about:config, but when closing more than 15 (for example 22 tabs), warning still does not appearing.

''McCoy [[#answer-1223942|said]]'' <blockquote> ''MathU41 [[#answer-1223920|said]]'' <blockquote> Cancel that, now it does give me a warning, but only when I have like 30 tabs open--I presume more than the 'recently closed tabs' in History retains. </blockquote> Just a thought : On the "about:config" page, would you check the value of this setting please : '''browser.tabs.MaxOpenBeforeWarn''' (default = 15) </blockquote> Unfortunately, it does not working. I have the same value in about:config, but when closing more than 15 (for example 22 tabs), warning still does not appearing.
這篇文章有幫助嗎?
引用
cor-el
  • Top 10 Contributor
  • Moderator
17168 個解決方法 155185 個答案

This is about being able to use "History -> Recently Closed Tabs/Windows" to recover tabs. The maximum for undo (reopen) tabs has been changed to 25. So only if you would close more than 25 tabs to get a warning.

  • browser.sessionstore.max_tabs_undo
  • browser.sessionstore.max_windows_undo

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

This is about being able to use "History -> Recently Closed Tabs/Windows" to recover tabs. The maximum for undo (reopen) tabs has been changed to 25. So only if you would close more than 25 tabs to get a warning. * browser.sessionstore.max_tabs_undo * browser.sessionstore.max_windows_undo You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config
這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題