搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Adblock and duckduckgo were removed and will not download from addons how do I get them back?

  • 6 回覆
  • 10 有這個問題
  • 2862 次檢視
  • 最近回覆由 jscher2000

more options

I just noticed that my Adblock and duckduckgo addons were removed. I tried to redownload them but I get a "download failed please check your connection. How can I restore these addons? Thanks!

被選擇的解決方法

UPDATE: Firefox 66.0.4 and 60.6.2esr are now available with the new certificate needed to solve this problem. See: Update Firefox to the latest release.

Hi JussAskin, well, the problem was with the Add-ons submission process, so ultimately, Mozilla is responsible for the problem.

Over the next few hours, your Firefox should automatically get a patch for this problem through the "studies" feature. For most users, studies are automatically enabled, but you can check on the Options/Preferences page as follows:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type stud and Firefox should filter to the "Firefox Data Collection and Use" section. Here, make sure you have a check in the box for "Allow Firefox to install and run studies". (First screenshot attached.) If you prefer to turn it back off after the patch comes through, that's fine.

So far, I have received two studies related to this, which you can see if you click the View Firefox studies link next to the above preference (or paste about:studies into the address bar and press Enter to load it). (Second screenshot attached.)

If you receive the patches and your extensions remain disabled, check whether they now show an Enable button.

從原來的回覆中察看解決方案 👍 0

所有回覆 (6)

more options

The Add-ons team is working on a fix for this. I don't know whether that will involve running an add-on update or something else. We're all hoping to learn soon.

more options

Add to post ... On the About:addons page these and all my other extensions are listed as "legacy extensions" and have been disabled. They will not reload. Can it be true that Duckduckgo and Adblock, adblock Plus are no longer available?

more options

I guess I'll reply here though I made another thread about this too.

This is also affecting uMatrix and Tampermonkey, and many of my other addons (getting labeled as Legacy). I can't even install security addons I didn't already have, because I get a download error (I tried ublock origin to replace adblock, but that couldn't download).

more options

It looks like a certificate used to sign many popular extensions expired. Whoever wasn't keeping track of that is probably having a very bad night. I don't know how soon re-signed versions of those extensions will become available, or whether another workaround will be discovered.

more options

Okay, so it's not a Firefox problem, it's an Add-on maker problem ... I wonder if getting a certificate re-signed is an involved procedure or is a keystroke or two after they become aware?

Thanks for the work jscher2000

more options

選擇的解決方法

UPDATE: Firefox 66.0.4 and 60.6.2esr are now available with the new certificate needed to solve this problem. See: Update Firefox to the latest release.

Hi JussAskin, well, the problem was with the Add-ons submission process, so ultimately, Mozilla is responsible for the problem.

Over the next few hours, your Firefox should automatically get a patch for this problem through the "studies" feature. For most users, studies are automatically enabled, but you can check on the Options/Preferences page as follows:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type stud and Firefox should filter to the "Firefox Data Collection and Use" section. Here, make sure you have a check in the box for "Allow Firefox to install and run studies". (First screenshot attached.) If you prefer to turn it back off after the patch comes through, that's fine.

So far, I have received two studies related to this, which you can see if you click the View Firefox studies link next to the above preference (or paste about:studies into the address bar and press Enter to load it). (Second screenshot attached.)

If you receive the patches and your extensions remain disabled, check whether they now show an Enable button.

由 jscher2000 於 修改