搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

how avoid firefox takes 100 times more resources than computer have ?

  • 1 回覆
  • 1 有這個問題
  • 31 次檢視
  • 最近回覆由 cor-el

more options

Sometimes with nothing that predicts , Firefoz start eating all resources of my computer , and I can't work anymore until a cold shutdown , what it annoy me , is the Firefox can try allocate 0,4 Tera bytes of memory when my computer just have 4 GB bytes .

ulimit -Sv 10000000 [1] seems that limit Firefox to ought all memory , but can't Firefox be more intelligent ?

More info local news tend to have lots of ads I use ABP (ad block plus) but sometimes they have so many scripts that seems they enter in loop, but Firefox should limit the consume of the resources . Another info this is not nothing I see this problem for at least 4 years , I expect that Firefox Quantum solve the problem, now that I use 66.0.3 without any legacy plugin this still happens or it is worst .

Regards,

[1]

   ulimit -a
   core file size          (blocks, -c) unlimited
   data seg size           (kbytes, -d) unlimited
   scheduling priority             (-e) 0
   file size               (blocks, -f) unlimited
   pending signals                 (-i) 15072
   max locked memory       (kbytes, -l) 16384
   max memory size         (kbytes, -m) unlimited
   open files                      (-n) 1024
   pipe size            (512 bytes, -p) 8
   POSIX message queues     (bytes, -q) 819200
   real-time priority              (-r) 0
   stack size              (kbytes, -s) 8192
   cpu time               (seconds, -t) unlimited
   max user processes              (-u) 15072
   virtual memory          (kbytes, -v) unlimited
   file locks                      (-x) unlimited

由 sergiomb 於 修改

所有回覆 (1)

more options

ABP is known to use a lot of resource. If that is the case then you can give uBlock Origin a try to see whether this makes a difference.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window